aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages microcom)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages readline)
  #:use-module (guix build-system gnu))

(define-public microcom
  (package
    (name "microcom")
    (version "2019.01.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://git.pengutronix.de/git/tools/microcom.git")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32 "0rf4qdkbhknrrqn4rpb737l0km8yn5f498zapks4akf6yjh5aq8y"))))
    (build-system gnu-build-system)
    (inputs (list readline))
    (native-inputs (list automake autoconf))
    (home-page  "https://git.pengutronix.de/?p=tools/microcom.git")
    (synopsis "Minimalistic serial line terminal program")
 (description "Microcom is a minimalistic terminal program for accessing
devices via a serial connection.  It features connection via RS232 serial
interfaces (including setting of transfer rates) as well as in @code{telnetmode}
as specified in rfc2217 and a (Linux specific) CAN mode.")
    (license gpl2+)))
06 00:08:04 -0400'>2022-11-06gnu: protobuf-c: Update to 1.4.1....* gnu/packages/protobuf.scm (protobuf-c): Update to 1.4.1. Maxim Cournoyer 2022-11-06gnu: protobuf: Unbundle googletest....* gnu/packages/protobuf.scm (protobuf) [origin]: Delete third_party directory in snippet. [configure-flags]: Add "-Dprotobuf_USE_EXTERNAL_GTEST=ON". [native-inputs]: Add googletest. Maxim Cournoyer 2022-11-06gnu: protobuf: Update to 3.21.9....* gnu/packages/protobuf.scm (protobuf): Update to 3.21.9. Move outputs field before build system. Move inputs field below arguments. [source]: Apply patch and update URL. [build-system]: Use cmake-build-system. This causes the CMake support files to be installed, which is expected by some packages such as hyperledger-iroha. [arguments]: Use gexps. [configure-flags]: Add BUILD_SHARED_LIBS=ON. [phases]: Add set-c++-standard. [home-page]: Update URL. (protobuf-3.6): Adjust to continue using the gnu-build-system. * gnu/packages/patches/protobuf-fix-build-on-32bit.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. Maxim Cournoyer 2022-10-27gnu: python-mypy-protobuf: Switch to pyproject-build-system....* gnu/packages/protobuf.scm (python-mypy-protobuf)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD. Marius Bakke 2022-08-31gnu: Add python-mypy-protobuf....* gnu/packages/protobuf.scm (python-mypy-protobuf): New variable. Maxim Cournoyer 2022-08-31gnu: Add python-nanopb....* gnu/packages/protobuf.scm (python-nanopb): New variable. Maxim Cournoyer 2022-08-31gnu: Add nanopb....* gnu/packages/protobuf.scm (nanopb): New variable. Maxim Cournoyer 2022-07-24gnu: fstrm: Refer to HPND licence by name....* gnu/packages/protobuf.scm (fstrm)[license]: Use license:hpnd directly. Tobias Geerinckx-Rice 2022-07-24gnu: fstrm: Omit static library....* gnu/packages/protobuf.scm (fstrm)[arguments]: Add "--disable-static" to #:configure-flags. Tobias Geerinckx-Rice 2022-07-24gnu: fstrm: Update to 0.6.1....* gnu/packages/protobuf.scm (fstrm): Update to 0.6.1. [license]: Update too. Tobias Geerinckx-Rice 2022-07-12gnu: protobuf-2: Fix build....Partially fixes <https://issues.guix.gnu.org/51093>. * gnu/packages/protobuf.scm (protobuf-2) [phases]{disable-broken-tests}: Delete phase. Maxim Cournoyer 2022-05-31gnu: Remove python2-protobuf....* gnu/packages/protobuf.scm (python2-protobuf): Delete variable. Maxim Cournoyer 2022-05-27gnu: python-protobuf-3.6: Add missing input....This was removed from python-protobuf in 5f8491ea95d7ba88801aa28b6d2b98f30b033186. * gnu/packages/protobuf.scm (python-protobuf-3.6)[inputs]: Add python-six. Christopher Baines 2022-05-20gnu: Add python-proto-plus....* gnu/packages/protobuf.scm (python-proto-plus): New variable. Ricardo Wurmus 2022-05-20gnu: python-protobuf: Update to 3.20.1....* gnu/packages/protobuf.scm (python-protobuf): Update to 3.20.1. [native-inputs]: Remove python-wheel. [propagated-inputs]: Remove python-six. Ricardo Wurmus 2022-01-16gnu: protozero: Update to 1.7.1....* gnu/packages/protobuf.scm (protozero): Update to 1.7.1. Tobias Geerinckx-Rice 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-08Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-11-07gnu: protozero: Update to 1.7.0....* gnu/packages/protobuf.scm (protozero): Update to 1.7.0. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber