aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages microcom)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages readline)
  #:use-module (guix build-system gnu))

(define-public microcom
  (package
    (name "microcom")
    (version "2019.01.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://git.pengutronix.de/git/tools/microcom.git")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32 "0rf4qdkbhknrrqn4rpb737l0km8yn5f498zapks4akf6yjh5aq8y"))))
    (build-system gnu-build-system)
    (inputs (list readline))
    (native-inputs (list automake autoconf))
    (home-page  "https://git.pengutronix.de/?p=tools/microcom.git")
    (synopsis "Minimalistic serial line terminal program")
 (description "Microcom is a minimalistic terminal program for accessing
devices via a serial connection.  It features connection via RS232 serial
interfaces (including setting of transfer rates) as well as in @code{telnetmode}
as specified in rfc2217 and a (Linux specific) CAN mode.")
    (license gpl2+)))
title='2018-01-06 14:45:01 +0100'>2018-01-06build: Detect broken 'equal?' in Guile 2.2.1....Ludovic Courtès 2017-10-09build: Update automake version requirement to 1.14....Eric Bavier 2017-09-05build: Negate ‘--disable-daemon’ help string....Tobias Geerinckx-Rice 2017-08-02build: Make Guile-Git a hard requirement....Ludovic Courtès 2017-06-30build: Remove check for broken (srfi srfi-37)....Ludovic Courtès 2017-06-09guix: git: Add new module....Mathieu Othacehe 2017-05-05Revert "guix: git: Add new module."...Leo Famulari 2017-05-05guix: git: Add new module....Mathieu Othacehe 2017-05-04build: Use Gnulib's 'git-version-gen'....Ludovic Courtès 2017-03-20build: Install .go files to $libdir/guile/X.Y....Ludovic Courtès 2017-03-18build: Require Guile >= 2.0.9....Ludovic Courtès 2017-03-15build: Prefer Guile 2.2 over 2.0....Ludovic Courtès 2017-03-12build: GnuTLS is now a hard dependency....Ludovic Courtès 2017-02-07build: Warn about lack of substitutes for non-standard stores....Ludovic Courtès 2017-01-13etc: Support indentation of whole files....Ludovic Courtès 2017-01-12etc: Add 'indent-package.el' script....Ludovic Courtès 2016-12-31Add (guix ssh) module....Ludovic Courtès 2016-12-29Remove Emacs interface....Alex Kost 2016-12-20build: Bump version number....Ricardo Wurmus 2016-10-25build: 'guilemoduledir' honors $GUILE_EFFECTIVE_VERSION....Ludovic Courtès 2016-09-20build: Allow builds with Guile 2.2....Ludovic Courtès 2016-09-07Add Zsh completion file....Eric Le Bihan 2016-07-29Merge branch 'master' into core-updatesMark H Weaver 2016-07-29build: Bump version number....Ludovic Courtès 2016-07-20Merge branch 'master' into core-updatesLudovic Courtès 2016-07-19Add (guix zlib)....Ludovic Courtès 2016-06-23build: Remove unneeded conditionals for (guix build syscalls)....Manolis Ragkousis 2016-04-15build: Move environment '.in' scripts to 'build-aux' directory....Mathieu Lirzin 2016-03-24build: Bump version number....Ludovic Courtès 2016-01-12build: 'make check' errors out if file name limits would be hit....Ludovic Courtès 2016-01-05build: Bump version number....Ludovic Courtès 2015-12-09build: Always check for gzip/bzip2/xz....Ludovic Courtès 2015-10-20build: Set DOT_USER_PROGRAM for Emacs interface....Alex Kost 2015-10-09build: Fix libgcrypt detection on FHS systems....Ludovic Courtès 2015-10-06build: Automatically determine libgcrypt's file name....Ludovic Courtès 2015-09-25build: Bump version number....Ludovic Courtès 2015-08-30build: Produce 'guix-config' instead of using compile-time tricks....Mathieu Lirzin 2015-08-27build: Do not build (guix build syscalls) if 'mount' is missing from libc....Ludovic Courtès 2015-06-14doc: Move most 'HACKING' informations into the manual....Mathieu Lirzin 2015-06-03build: Bump version number....Ludovic Courtès 2015-06-01build: Build and install manual pages....Ludovic Courtès 2015-05-10build: Require Guile >= 2.0.7....Ludovic Courtès