aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages microcom)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages readline)
  #:use-module (guix build-system gnu))

(define-public microcom
  (package
    (name "microcom")
    (version "2019.01.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://git.pengutronix.de/git/tools/microcom.git")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32 "0rf4qdkbhknrrqn4rpb737l0km8yn5f498zapks4akf6yjh5aq8y"))))
    (build-system gnu-build-system)
    (inputs (list readline))
    (native-inputs (list automake autoconf))
    (home-page  "https://git.pengutronix.de/?p=tools/microcom.git")
    (synopsis "Minimalistic serial line terminal program")
 (description "Microcom is a minimalistic terminal program for accessing
devices via a serial connection.  It features connection via RS232 serial
interfaces (including setting of transfer rates) as well as in @code{telnetmode}
as specified in rfc2217 and a (Linux specific) CAN mode.")
    (license gpl2+)))
a>...Tobias Geerinckx-Rice 2021-03-10gnu: libtiff: Update to 4.2.0 [security fixes]....Léo Le Bouter 2021-03-09gnu: libavif: Update to 0.9.0....Leo Famulari 2021-03-03gnu: jasper: Update to 2.0.25 [fixes CVE-2021-26926]....Léo Le Bouter 2021-02-21gnu: exiv2-0.26: Remove variable....Nicolas Goaziou 2021-02-21gnu: Add imgp....Vinicius Monego 2021-02-13gnu: Add swappy....Sharlatan Hellseher 2021-01-25Merge branch 'master' into stagingLeo Famulari 2021-01-10gnu: vigra: Raise max-silent-time timeout value to 2 hours....Maxim Cournoyer 2021-01-10Merge branch 'master' into stagingEfraim Flashner 2021-01-02gnu: gpick: Update to 0.2.6....Tobias Geerinckx-Rice 2020-12-30gnu: leptonica: Update to 1.80.0....Vincent Legoll 2020-12-29Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-29Merge branch 'master' into ungraftingMarius Bakke 2020-12-29gnu: jasper: Update to 2.0.23....Vincent Legoll 2020-12-24gnu: libavif: Add support for rav1e....Vinicius Monego 2020-12-24gnu: libavif: Update to 0.8.4....Vinicius Monego 2020-12-13Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-13Merge branch 'master' into ungraftingMarius Bakke 2020-12-11gnu: imlib2: Update to 1.7.1....Efraim Flashner 2020-12-08gnu: Add mypaint....L p R n d n 2020-12-08gnu: libjpeg-turbo: Update to 2.0.5 and remove replacement....Efraim Flashner 2020-12-01Revert "gnu: openjpeg: Enable tests."...Marius Bakke 2020-12-01gnu: openjpeg: Update synopsis and description....Raghav Gururajan 2020-12-01gnu: openjpeg: Enable tests....Raghav Gururajan 2020-12-01gnu: openjpeg: Make some cosmetic changes....Raghav Gururajan 2020-11-26Merge branch 'master' into stagingMarius Bakke 2020-11-24gnu: flameshot: Update to 0.8.5....Zhu Zihao 2020-11-23Merge branch 'master' into stagingMarius Bakke 2020-11-23gnu: mtpaint: Update to 3.49.33....Tobias Geerinckx-Rice 2020-11-22Merge branch 'master' into stagingMarius Bakke 2020-11-20gnu: slurp: Add missing dependency....Marius Bakke 2020-11-20gnu: slurp: Update to 1.3.1....Marius Bakke 2020-11-20gnu: grim: Remove obsolete patch....Marius Bakke 2020-11-19gnu: Don't append '.git' to GitHub uris....Efraim Flashner 2020-10-19Merge branch 'master' into stagingMarius Bakke 2020-10-19gnu: extempore: Inline custom package variants....Marius Bakke 2020-10-14gnu: jasper: Update to 2.0.22....Tobias Geerinckx-Rice