aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages microcom)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages readline)
  #:use-module (guix build-system gnu))

(define-public microcom
  (package
    (name "microcom")
    (version "2019.01.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://git.pengutronix.de/git/tools/microcom.git")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32 "0rf4qdkbhknrrqn4rpb737l0km8yn5f498zapks4akf6yjh5aq8y"))))
    (build-system gnu-build-system)
    (inputs (list readline))
    (native-inputs (list automake autoconf))
    (home-page  "https://git.pengutronix.de/?p=tools/microcom.git")
    (synopsis "Minimalistic serial line terminal program")
 (description "Microcom is a minimalistic terminal program for accessing
devices via a serial connection.  It features connection via RS232 serial
interfaces (including setting of transfer rates) as well as in @code{telnetmode}
as specified in rfc2217 and a (Linux specific) CAN mode.")
    (license gpl2+)))
/td>Tobias Geerinckx-Rice 2021-03-13gnu: wireguard-tools: Update to 1.0.20210223....* gnu/packages/vpn.scm (wireguard-tools): Update to 1.0.20210223. Tobias Geerinckx-Rice 2021-03-11gnu: openvpn: Update to 2.5.1 [security fixes]....Non-exhaustively, fixes CVE-2020-7224. * gnu/packages/vpn.scm (openvpn): Update to 2.5.1. Léo Le Bouter 2021-02-15gnu: Add openconnect-sso....* gnu/packages/vpn.scm (openconnect-sso): New variable. Efraim Flashner 2021-01-10Merge branch 'master' into stagingEfraim Flashner 2021-01-03gnu: wireguard-linux-compat: Update to 1.0.20201221....* gnu/packages/vpn.scm (wireguard-linux-compat): Update to 1.0.20201221. Tobias Geerinckx-Rice 2020-12-29Merge branch 'master' into ungraftingMarius Bakke 2020-12-24gnu: protonvpn-cli: Stop propagating inputs....* gnu/packages/vpn.scm (protonvpn-cli)[inputs]: Add dialog, iproute2, iptables, ncurses, openvpn, procps, python-requests, and which. [arguments]: Add a 'wrap-wrapper' phase. Signed-off-by: Leo Famulari <leo@famulari.name> Ryan Prior 2020-12-21Merge branch 'master' into ungraftingMarius Bakke 2020-12-20gnu: openvpn: Update to 2.4.10....* gnu/packages/vpn.scm (openvpn): Update to 2.4.10. Tobias Geerinckx-Rice 2020-12-20gnu: protonvpn-cli: Update to 2.2.6....* gnu/packages/vpn.scm (protonvpn-cli): Update to 2.2.6. Tobias Geerinckx-Rice 2020-12-13Merge branch 'master' into ungraftingMarius Bakke 2020-12-12gnu: Add openfortivpn...* gnu/packages/vpn.scm (openfortivpn): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> David Dashyan 2020-12-08gnu: gnutls: Update to 3.6.15 and remove replacement....* gnu/packages/tls.scm (gnutls): Update to 3.6.15. [source]: Add "gnutls-cross.patch". [replacement]: Remove. [native-inputs]: Add GUILE-3.0 when (%current-target-system) is true. (gnutls/fixed): Remove. * gnu/packages/package-management.scm (guix)[propagated-inputs]: Remove reference to 'gnutls/fixed'. * gnu/packages/tls.scm (gnutls/dane): Inherit from gnutls. * gnu/packages/vpn.scm (openconnect)[propagated-inputs]: Remove gnutls/fixed, add gnutls. Co-authored-by: Efraim Flashner <efraim@flashner.co.il> Ludovic Courtès 2020-12-03gnu: GnuTLS: Update replacement to 3.6.15 [fixes CVE-2020-24659]....* gnu/packages/tls.scm (gnutls-3.6.14): Rename to ... (gnutls/fixed): ... this. Update to 3.6.15. (gnutls): Adjust for renamed replacement. * gnu/packages/package-management.scm (guix)[propagated-inputs]: Likewise. * gnu/packages/vpn.scm (openconnect)[propagated-inputs]: Likewise. Marius Bakke