aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages microcom)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages readline)
  #:use-module (guix build-system gnu))

(define-public microcom
  (package
    (name "microcom")
    (version "2019.01.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://git.pengutronix.de/git/tools/microcom.git")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32 "0rf4qdkbhknrrqn4rpb737l0km8yn5f498zapks4akf6yjh5aq8y"))))
    (build-system gnu-build-system)
    (inputs (list readline))
    (native-inputs (list automake autoconf))
    (home-page  "https://git.pengutronix.de/?p=tools/microcom.git")
    (synopsis "Minimalistic serial line terminal program")
 (description "Microcom is a minimalistic terminal program for accessing
devices via a serial connection.  It features connection via RS232 serial
interfaces (including setting of transfer rates) as well as in @code{telnetmode}
as specified in rfc2217 and a (Linux specific) CAN mode.")
    (license gpl2+)))
d789f98866b5bf85be95306c969'>gnu: elogind: Update to 252.9....Maxim Cournoyer 2023-08-03services: Add Plasma desktop service....Hartmut Goebel 2023-07-07gnu: gnome: Remove gnome-boxes from default GNOME apps....Josselin Poiret 2023-06-04services: screen-locker-service-type: Configurable PAM and setuid....muradm 2023-05-11services: elogind: Add elogind as a shepherd PAM requirement....Josselin Poiret 2023-05-11system: pam: Let PAM extensions add shepherd requirements....Josselin Poiret 2023-04-07services: desktop: Remove 'xfce-desktop-service' procedure....Bruno Victal 2023-04-07services: desktop: Remove 'mate-desktop-service' procedure....Bruno Victal 2023-04-07services: desktop: Remove 'gnome-desktop-service' procedure....Bruno Victal 2023-03-21services: Add x11-socket-directory-service-type....Bruno Victal 2023-03-10services: xorg: Deprecate 'screen-locker-service' procedure....Bruno Victal 2023-02-26services: desktop: Set default value for geoclue-service-type....Bruno Victal 2023-03-03services: dbus: Deprecate 'dbus-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'bluetooth-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'geoclue-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'udisks-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'accountsservice-service' procedure....Bruno Victal 2023-03-03services: elogind-configuration: Do not ignore 'handle-hibernate-key' by defa......Bruno Victal 2023-03-03services: desktop: Deprecate 'elogind-service' procedure....Bruno Victal 2023-02-28gnu: sugar-desktop-configuration: Allow specification of activities....Ricardo Wurmus 2023-02-28services: Add sugar-desktop-service-type....Ricardo Wurmus 2023-02-25services: gnome-desktop-service-type: Extend setuid-program-service-type....Maxim Cournoyer 2023-02-25services: desktop: Extract a new gnome-package procedure....Maxim Cournoyer 2023-02-25services: gnome-polkit-settings: Add spice-gtk....Maxim Cournoyer 2022-12-30services: enlightenment: Load ddcutil udev rules....Efraim Flashner 2022-12-26gnu: services: Fix bluetooth-service docstring....Ivan Vilata i Balaguer 2022-11-18services: Add Shepherd 'configuration' action to various services....Ludovic Courtès 2022-09-16services: desktop: Mount /var/lib/gdm on a tmpfs file system....Maxim Cournoyer 2022-09-16services: elogind-configuration-file: Do not serialize unspecified items....Maxim Cournoyer 2022-09-04services: upower: Default to a percentage-based policy....Ludovic Courtès 2022-09-04services: upower: Update default percentage values....Ludovic Courtès 2022-08-26gnu: seatd-service-type: Use seat group....muradm 2022-08-10services: elogind: Fix default behavior for lid close....Maxim Cournoyer 2022-06-17gnu: desktop: Add seatd-service-type....muradm 2022-05-28services: elogind: When started by dbus-daemon, wait for the Shepherd service....Ludovic Courtès 2022-04-29services: Add missing 'description' fields....Ludovic Courtès 2022-03-09services: bluetooth: Add missing config parameters....Demis Balbach 2022-01-06services: gnome: Add udev rules....Mathieu Othacehe 2021-12-08services: %desktop-services: Use SDDM rather than GDM on non-x86_64....Ludovic Courtès 2021-10-03services: desktop: Add the sticky bit to the X11 socket directory....Mathieu Othacehe 2021-07-29services: Migrate to <setuid-program>....Brice Waegeneire 2021-06-14services: Remove deprecated service procedures....Ludovic Courtès