aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages mcrypt)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:select (gpl2+))
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages perl))

(define-public mcrypt
  (package
    (name "mcrypt")
    (version "2.6.8")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://sourceforge/mcrypt/MCrypt/"
                          version "/" name "-" version ".tar.gz"))
      (sha256
       (base32
        "161031n1w9pb4yzz9i47szc12a4mwpcpvyxnvafsik2l9s2aliai"))
      (patches (search-patches
                 "mcrypt-CVE-2012-4409.patch"
                 "mcrypt-CVE-2012-4426.patch"
                 "mcrypt-CVE-2012-4527.patch"))))
    (build-system gnu-build-system)
    (inputs
     (list zlib libmcrypt libmhash))
    (home-page "https://mcrypt.sourceforge.net/")
    (synopsis "Replacement for the popular Unix crypt command")
    (description
     "MCrypt is a replacement for the old crypt() package and crypt(1)
command, with extensions.  It allows developers to use a wide range of
encryption functions, without making drastic changes to their code.  It allows
users to encrypt files or data streams without having to be cryptographers.
The companion to MCrypt is Libmcrypt, which contains the actual encryption
functions themselves, and provides a standardized mechanism for accessing
them.")
    (license gpl2+)))

(define-public libmcrypt
  (package
    (name "libmcrypt")
    (version "2.5.8")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://sourceforge/mcrypt/Libmcrypt/" version
                          "/libmcrypt-" version ".tar.gz"))
      (sha256
       (base32
        "0gipgb939vy9m66d3k8il98rvvwczyaw2ixr8yn6icds9c3nrsz4"))))
    (build-system gnu-build-system)
    (home-page "https://mcrypt.sourceforge.net/")
    (synopsis "Encryption algorithm library")
    (description
     "Libmcrypt is a data encryption library.  The library is thread safe and
provides encryption and decryption functions.  This version of the library
supports many encryption algorithms and encryption modes.  Some algorithms
which are supported: SERPENT, RIJNDAEL, 3DES, GOST, SAFER+, CAST-256, RC2,
XTEA, 3WAY, TWOFISH, BLOWFISH, ARCFOUR, WAKE and more.")
    (license gpl2+)))

(define-public libmhash
  (package
    (name "libmhash")
    (version "0.9.9.9")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://sourceforge/mhash/mhash/" version
                          "/mhash-" version ".tar.bz2"))
      (sha256
       (base32
        "1w7yiljan8gf1ibiypi6hm3r363imm3sxl1j8hapjdq3m591qljn"))
      (patches (search-patches "mhash-keygen-test-segfault.patch"
                               "libmhash-hmac-fix-uaf.patch"))))
    (build-system gnu-build-system)
    (native-inputs
     (list perl))                 ;for tests
    (home-page "https://mhash.sourceforge.net/")
    (synopsis "Thread-safe hash library")
    (description
     "Mhash is a thread-safe hash library, implemented in C, and provides a
uniform interface to a large number of hash algorithms.  These algorithms can
be used to compute checksums, message digests, and other signatures.  The HMAC
support implements the basics for message authentication, following RFC 2104.

Algorithms currently supplied are:

CRC-32, CRC-32B, ALDER-32, MD-2, MD-4, MD-5, RIPEMD-128, RIPEMD-160,
RIPEMD-256, RIPEMD-320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, HAVAL-128,
HAVAL-160, HAVAL-192, HAVAL-256, TIGER, TIGER-128, TIGER-160, GOST, WHIRLPOOL,
SNEFRU-128, SNEFRU-256.")
    (license gpl2+)))
kewise. * gnu/packages/disk.scm: Likewise. * gnu/packages/documentation.scm: Likewise. * gnu/packages/education.scm: Likewise. * gnu/packages/engineering.scm: Likewise. * gnu/packages/enlightenment.scm: Likewise. * gnu/packages/fcitx.scm: Likewise. * gnu/packages/fontutils.scm: Likewise. * gnu/packages/freedesktop.scm: Likewise. * gnu/packages/games.scm: Likewise. * gnu/packages/gkrellm.scm: Likewise. * gnu/packages/glib.scm: Likewise. * gnu/packages/gnome.scm: Likewise. * gnu/packages/grub.scm: Likewise. * gnu/packages/gtk.scm: Likewise. * gnu/packages/guile.scm: Likewise. * gnu/packages/ibus.scm: Likewise. * gnu/packages/irc.scm: Likewise. * gnu/packages/iso-codes.scm: Likewise. * gnu/packages/kde-frameworks.scm: Likewise. * gnu/packages/kodi.scm: Likewise. * gnu/packages/linux.scm: Likewise. * gnu/packages/man.scm: Likewise. * gnu/packages/maths.scm: Likewise. * gnu/packages/mono.scm: Likewise. * gnu/packages/mp3.scm: Likewise. * gnu/packages/music.scm: Likewise. * gnu/packages/nano.scm: Likewise. * gnu/packages/networking.scm: Likewise. * gnu/packages/package-management.scm: Likewise. * gnu/packages/pdf.scm: Likewise. * gnu/packages/sawfish.scm: Likewise. * gnu/packages/statistics.scm: Likewise. * gnu/packages/terminals.scm: Likewise. * gnu/packages/version-control.scm: Likewise. * gnu/packages/vpn.scm: Likewise. * gnu/packages/w3m.scm: Likewise. * gnu/packages/webkit.scm: Likewise. * gnu/packages/wicd.scm: Likewise. * gnu/packages/wine.scm: Likewise. * gnu/packages/xdisorg.scm: Likewise. * gnu/packages/xorg.scm: Likewise. Alex Kost 2016-09-22gnu: webkitgtk: Update to 2.14.0....* gnu/packages/webkit.scm (webkitgtk): Update to 2.14.0. Mark H Weaver 2016-09-07gnu: webkitgtk: Update to 2.12.5....* gnu/packages/webkit.scm (webkitgtk): Update to 2.12.5. Mark H Weaver 2016-08-25gnu: webkitgtk: Update to 2.12.4 [fixes CVE-2016-{4590,4591,4622,4624}]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.12.4. [source]: Use HTTPS URL. Leo Famulari 2016-05-25gnu: webkitgtk: Update to 2.12.3 [fixes CVE-2016-{1856,1857}]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.12.3. Mark H Weaver 2016-04-28gnu: webkitgtk: Update to 2.12.2....* gnu/packages/webkit.scm (webkitgtk): Update to 2.12.2. Mark H Weaver 2016-04-22gnu: webkitgtk-2.4: Update to 2.4.11....* gnu/packages/webkit.scm (webkitgtk-2.4): Update to 2.4.11. Mark H Weaver 2016-04-22gnu: webkitgtk: Update to 2.12.1....* gnu/packages/webkit.scm (webkitgtk): Update to 2.12.1. Mark H Weaver 2016-03-23gnu: webkitgtk: Update to 2.12.0....* gnu/packages/webkit.scm (webkitgtk): Update to 2.12.0. Mark H Weaver 2016-03-22gnu: webkitgtk-2.4: Update to 2.4.10 [fixes many security flaws]....Fixes CVE-2014-1748, CVE-2015-1071, CVE-2015-1076, CVE-2015-1081, CVE-2015-1083, CVE-2015-1120, CVE-2015-1122, CVE-2015-1127, CVE-2015-1153, CVE-2015-1155, CVE-2015-3658, CVE-2015-3659, CVE-2015-3727, CVE-2015-3731, CVE-2015-3741, CVE-2015-3743, CVE-2015-3745, CVE-2015-3747, CVE-2015-3748, CVE-2015-3749, CVE-2015-3752, CVE-2015-5788, CVE-2015-5794, CVE-2015-5801, CVE-2015-5809, CVE-2015-5822, and CVE-2015-5928. * gnu/packages/patches/webkitgtk-2.4-sql-init-string.patch: Delete file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/webkit.scm (webkitgtk-2.4): Update to 2.4.10. [source]: Remove patch. Mark H Weaver 2016-03-11gnu: webkitgtk: Update to 2.10.8 [fixes CVE-2016-1726]....* gnu/packages/webkit.scm (webkitgtk): Update to 2.10.8. Mark H Weaver 2016-02-03gnu: webkitgtk: Update to 2.10.7....* gnu/packages/webkit.scm (webkitgtk): Update to 2.10.7. 宋文武 2016-01-25gnu: webkitgtk-2.4, webkitgtk/gtk+-2, qt: Disable parallel builds....* gnu/packages/webkit.scm (webkitgtk-2.4, webkitgtk/gtk+-2): Disable parallel builds as suggested in https://lists.gnu.org/archive/html/guix-devel/2016-01/msg00837.html . * gnu/packages/qt.scm (qt): Likewise. Andreas Enge 2016-01-13Merge branch 'master' into core-updatesLudovic Courtès 2016-01-08gnu: webkitgtk: Update to 2.10.4....* gnu/packages/webkit.scm (webkitgtk): Update to 2.10.4. 宋文武 2016-01-05gnu: Read 'C_INCLUDE_PATH' instead of 'CPATH'....This is a followup to 009b53fd. * gnu/packages/cmake.scm (cmake)[arguments]: Use (getenv "C_INCLUDE_PATH") instead of (getenv "CPATH"). * gnu/packages/package-management.scm (rpm)[arguments]: Likewise. * gnu/packages/video.scm (avidemux)[arguments]: Likewise. * gnu/packages/webkit.scm (webkitgtk)[arguments]: Likewise. * gnu/packages/cross-base.scm (cross-gcc-arguments): Likewise, and unset 'C_INCLUDE_PATH' and 'CPLUS_INCLUDE_PATH'. Ludovic Courtès 2015-10-07gnu: webkitgtk-2.4: Fix potential code execution vulnerability....* gnu/packages/patches/webkitgtk-2.4-sql-init-string.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/webkit.scm (webkitgtk-2.4)[source]: Add patch. Mark H Weaver 2015-08-13gnu: webkitgtk: Update to 2.8.5....* gnu/packages/webkit.scm (webkitgtk): Update to 2.8.5. [arguments]: Add 'add-gst-plugins-base-include-path' phase. Mark H Weaver 2015-08-13gnu: webkitgtk/gtk+-2: Change name field to "webkitgtk-gtk2"....* gnu/packages/webkit.scm (webkitgtk/gtk+-2)[name]: Change to "webkitgtk-gtk2". Mark H Weaver 2015-07-05gnu: Rename module gnutls to tls....* gnu/packages/gnutls.scm: Rename to... * gnu/packages/tls.scm: ... this. Change module name accordingly. * gnu/packages/{admin.scm, cups.scm, curl.scm, dc.scm, dns.scm, emacs.scm, ftp.scm, gnome.scm, gnunet.scm, gnupg.scm, gsasl.scm, lynx.scm, mail.scm, messaging.scm, package-management.scm, shishi.scm, task-management.scm, version-control.scm, video.scm, vpn.scm, webkit.scm, weechat.scm, wget.scm, wine.scm, xml.scm}: Adapt module import to new name. * gnu-system.am (GNU_SYSTEM_MODULES): Rename gnutls module to tls. Andreas Enge 2015-05-29gnu: webkitgtk: Update to 2.8.3....The version (2.8.9) mentioned in the previous commit (e7e8ea0) message was wrong. Should be '2.4.9'. * gnu/packages/webkit.scm (webkitgtk): Update to 2.8.3. 宋文武 2015-05-29gnu: webkitgtk-2.4: Update to 2.8.9, build with gtk3....* gnu/packages/webkit.scm (webkitgtk-2.4): Update to 2.8.9, build with gtk3. Move flex and which to 'native-inputs'. Remove #:configure-flags. (webkitgtk/gtk+-2): New variable. * gnu/packages/gnucash.scm (gnucash): Use webkitgtk/gtk+-2. * gnu/packages/patches/webkitgtk-2.4.8-gmutexlocker.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. Co-authored-by: Feng Shu <tumashu@163.com> 宋文武 2015-05-07gnu: Add WebkitGTK 2.4.8....* gnu/packages/webkit.scm (webkitgtk-2.4): New variable. * gnu/packages/patches/webkitgtk-2.4.8-gmutexlocker.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. Ricardo Wurmus 2015-05-06gnu: webkitgtk: Remove unnecessary make flag....* gnu/packages/webkit.scm (webkitgtk): Remove make-flags. Signed-off-by: Ludovic Courtès <ludo@gnu.org> David Hashe 2015-05-05gnu: webkitgtk: Fix compilation on x86_64....* gnu/packages/webkit.scm (webkitgtk): Move library install path from lib64 to lib. Signed-off-by: Ludovic Courtès <ludo@gnu.org> David Hashe 2015-04-20gnu: Add WebKitGTK+....* gnu/packages/webkit.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. 宋文武