aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages marst)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (gnu packages compression)
  #:use-module (guix build-system gnu))

(define-public marst
  (package
    (name "marst")
    (version "2.7")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/" name "/" name "-" version
             ".tar.gz"))
       (sha256
        (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/marst/")
    (synopsis "Algol-to-C translator")
    (description
     "GNU MARST is an Algol-to-C translator.  The package consists of the
translator itself, a library that contains the necessary Algol 60 procedures,
and a converter that converts existing Algol 60 programs from other
representations to the MARST representation.")
    (license gpl3+)))
scm?id=526a0066ac243f9b740cd2df9e6bb56bcd51e378'>gnu: diffoscope: Update to 147....* gnu/packages/diffoscope (diffoscope): Update to 147. Vagrant Cascadian 2020-06-05gnu: diffoscope: Update to 146....* gnu/packages/diffoscope.scm (diffoscope): Update to 146. Tobias Geerinckx-Rice 2020-06-05gnu: diffoscope: Remove redundant let binding....* gnu/packages/diffoscope.scm (diffoscope): Unbind VERSION. Tobias Geerinckx-Rice 2020-05-25gnu: diffoscope: Update to 145....* gnu/packages/diffoscope (diffoscope): Update to 145. Vagrant Cascadian 2020-04-30gnu: diffoscope: Update to 143....* gnu/packages/diffoscope (diffoscope): Update to 143. [native-inputs]: Add openssl and python-h5py. [arguments] Add openssl to add-known-tools phase. [arguments] Remove hdf5 from add-known-tools phase, added upstream. Vagrant Cascadian 2020-04-17gnu: diffoscope.scm: Add missing import....This follows on from 2d9886f7e8838d6aeb0cfb20a2a49fc7d8fb233c. * gnu/packages/diffoscope.scm: Import (gnu packages maths). Christopher Baines 2020-04-16gnu: diffoscope: Update to 141....* gnu/packages/diffoscope (diffoscope): Update to 141. [arguments]: Add phase add-known-tools. [native-inputs]: Add hdf5. Vagrant Cascadian 2020-04-13gnu: diffoscope: Update to 139....* gnu/packages/diffoscope.scm (diffoscope): Update to 139. Tobias Geerinckx-Rice 2020-03-30gnu: reprotest: Update to 0.7.14....* gnu/packages/diffoscope (reprotest): Update to 0.7.14. * gnu/packages/patches/reprotest-support-guix.patch: Remove file. * gnu/local.mk [dist_patch_DATA]: Update accordingly. Vagrant Cascadian 2020-03-30gnu: diffoscope: Update to 138....* gnu/packages/diffoscope (diffoscope): Update to 138. Vagrant Cascadian 2020-02-23gnu: diffoscope: Update to 137....* gnu/packages/diffoscope.scm (diffoscope): Update to 137. Tobias Geerinckx-Rice 2020-02-07gnu: Add reprotest....Added to diffoscope, to avoid triggering #37346. * gnu/packages/diffoscope (reprotest): New variable. * gnu/packages/patches/reprotest-support-guix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch. Vagrant Cascadian 2020-02-06gnu: diffoscope: Update description....* gnu/packages/diffoscope (diffoscope)[description]: Mention optional dependencies. Vagrant Cascadian 2020-02-01gnu: diffoscope: Update to 136....* gnu/packages/diffoscope (diffoscope): Update to 136. Vagrant Cascadian 2020-01-17gnu: diffoscope: Update to 135....* gnu/packages/diffoscope (diffoscope): Update to 135. Vagrant Cascadian 2019-12-29gnu: diffoscope: Update to 134....* gnu/packages/diffoscope (diffoscope): Update to 134. [arguments] Remove phase adding support for zstd. Vagrant Cascadian 2019-12-15gnu: diffoscope: Add support for zstd compression....* gnu/packages/diffoscope (diffoscope)[native-inputs]: Add zstd. [arguments]: Add add-known-tools phase with support for zstd. Vagrant Cascadian 2019-12-15gnu: diffoscope: Update to 133....* gnu/packages/diffoscope (diffoscope): Update to 133. Vagrant Cascadian