aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages marst)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (gnu packages compression)
  #:use-module (guix build-system gnu))

(define-public marst
  (package
    (name "marst")
    (version "2.7")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/" name "/" name "-" version
             ".tar.gz"))
       (sha256
        (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/marst/")
    (synopsis "Algol-to-C translator")
    (description
     "GNU MARST is an Algol-to-C translator.  The package consists of the
translator itself, a library that contains the necessary Algol 60 procedures,
and a converter that converts existing Algol 60 programs from other
representations to the MARST representation.")
    (license gpl3+)))
adf57df58'>gnu: diffoscope: Update to 247....* gnu/packages/diffoscope.scm (diffoscope): Update to 247. Tobias Geerinckx-Rice 2023-07-23gnu: diffoscope: Update to 246....* gnu/packages/diffoscope.scm (diffoscope): Update to 246. Tobias Geerinckx-Rice 2023-07-16gnu: diffoscope: Update to 245....* gnu/packages/diffoscope.scm (diffoscope): Update to 245. Tobias Geerinckx-Rice 2023-07-16gnu: diffoscope: Don't embed build-time references....* gnu/packages/diffoscope.scm (diffoscope)[arguments]: Avoid using WHICH in the 'embed-tool-references phase. Tobias Geerinckx-Rice 2023-07-16gnu: diffoscope: Use G-expressions....* gnu/packages/diffoscope.scm (diffoscope)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-07-16gnu: diffoscope: Update to 244....* gnu/packages/diffoscope.scm (diffoscope): Update to 244. Tobias Geerinckx-Rice 2023-05-13gnu: diffoscope: Update to 242....* gnu/packages/diffoscope.scm (diffoscope): Update to 242. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Vagrant Cascadian 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer