aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2024 normally_js <normally_js@posteo.net>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 TakeV <takev@disroot.org>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages magic-wormhole)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system pyproject)
  #:use-module ((guix build-system python) #:select (pypi-uri))
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (gnu packages check)
  #:use-module (gnu packages python-build)
  #:use-module (gnu packages python-compression)
  #:use-module (gnu packages python-crypto)
  #:use-module (gnu packages python-web)
  #:use-module (gnu packages python-xyz))

(define-public magic-wormhole-mailbox-server
  (package
    (name "magic-wormhole-mailbox-server")
    (version "0.4.1")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "magic-wormhole-mailbox-server" version))
       (sha256
        (base32
         "1yw8i8jv5iv1kkz1aqimskw7fpichjn6ww0fq0czbalwj290bw8s"))))
    (build-system pyproject-build-system)
    (native-inputs
     (list python-mock
           python-pytest
           python-setuptools
           python-wheel))
    (propagated-inputs
     (list python-attrs
           python-autobahn
           python-idna
           python-service-identity
           python-six
           python-treq
           python-twisted))
    (home-page "https://github.com/magic-wormhole/magic-wormhole-mailbox-server")
    (synopsis "Magic-Wormhole central mailbox server")
    (description
     "This package provides the main server that Magic-Wormhole clients
connect to.  The server performs store-and-forward delivery for small
key-exchange and control messages.  Bulk data is sent over a direct TCP
connection, or through a transit-relay.")
    (license license:expat)))

(define-public magic-wormhole-transit-relay
  (package
    (name "magic-wormhole-transit-relay")
    (version "0.2.1")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "magic-wormhole-transit-relay" version))
       (sha256
        (base32
         "0ppsx2s1ysikns1h053x67z2zmficbn3y3kf52bzzslhd2s02j6b"))))
    (build-system pyproject-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'install 'install-docs
            (lambda _
              (let* ((out #$output)
                     (docs (string-append out "/share/doc/magic-wormhole-transit-relay")))
                (for-each (lambda (file)
                            (install-file file docs))
                          (find-files "docs/"))))))))
    (native-inputs
     (list python-mock
           python-pytest
           python-setuptools
           python-wheel))
    (propagated-inputs
     (list python-twisted))
    (home-page "https://github.com/magic-wormhole/magic-wormhole-transit-relay")
    (synopsis "Magic-Wormhole relay server")
    (description
     "This package provides the Magic-Wormhole Transit Relay server, which
helps clients establish bulk-data transit connections even when both are
behind NAT boxes.  Each side makes a TCP connection to this server and
presents a handshake.  Two connections with identical handshakes are glued
together, allowing them to pretend they have a direct connection.")
    (license license:expat)))

(define-public magic-wormhole
  (package
    (name "magic-wormhole")
    (version "0.16.0")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "magic-wormhole" version))
       (sha256
        (base32
         "1jcldlyj6bdd9bb39r77cd9ra6cllqijc9lhs6kaggcdi53c3rhl"))))
    (build-system pyproject-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          ;; XXX I can't figure out how to build the docs properly.
          ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34515#101
          (add-after 'install 'install-docs
            (lambda _
              (install-file "docs/wormhole.1"
                            (string-append #$output "/share/man/man1")))))))
    (native-inputs
     (list python-mock
           python-pytest
           python-setuptools
           python-wheel
           magic-wormhole-mailbox-server
           magic-wormhole-transit-relay))
    (propagated-inputs
     (list python-attrs
           python-autobahn
           python-click
           python-hkdf
           python-humanize
           python-iterable-io
           python-noiseprotocol
           python-pynacl
           python-spake2
           python-tqdm
           python-twisted
           python-txtorcon
           python-zipstream-ng))
    (home-page "https://github.com/magic-wormhole/magic-wormhole")
    (synopsis "Securely transfer data between computers")
    (description
     "Magic-Wormhole is a library and a command-line tool named wormhole,
which makes it possible to securely transfer arbitrary-sized files and
directories (or short pieces of text) from one computer to another.  The two
endpoints are identified by using identical \"wormhole codes\": in general,
the sending machine generates and displays the code, which must then be typed
into the receiving machine.

The codes are short and human-pronounceable, using a phonetically-distinct
wordlist.  The receiving side offers tab-completion on the codewords, so
usually only a few characters must be typed.  Wormhole codes are single-use
and do not need to be memorized.")
   (license license:expat)))
scm guix/packages.scm Marius Bakke 2021-09-13gnu: cuirass: Update to 1.1.0-4.6019040....* gnu/packages/ci.scm (cuirass): Update to 1.1.0-4.6019040. Mathieu Othacehe 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-08-12gnu: cuirass: Update to 1.1.0-3.91e8b2e....* gnu/packages/ci.scm (cuirass): Update to 1.1.0-3.91e8b2e. Mathieu Othacehe 2021-08-12gnu: cuirass: Update to 1.1.0-2.830817a....* gnu/packages/ci.scm (cuirass): Update to 1.1.0-2.830817a. Mathieu Othacehe 2021-06-19Merge branch 'master' into core-updates...Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm Marius Bakke 2021-06-13gnu: cuirass: Update to 1.1.0-1.f9a5dbd....* gnu/packages/ci.scm (cuirass): Update to 1.1.0-1.f9a5dbd. Mathieu Othacehe 2021-06-06Merge branch 'master' into core-updates... Conflicts: gnu/local.mk gnu/packages/algebra.scm gnu/packages/bioinformatics.scm gnu/packages/curl.scm gnu/packages/docbook.scm gnu/packages/emacs-xyz.scm gnu/packages/maths.scm gnu/packages/plotutils.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/radio.scm gnu/packages/readline.scm gnu/packages/tls.scm gnu/packages/xml.scm gnu/packages/xorg.scm Marius Bakke 2021-06-04gnu: ci: Use 'inputs' in build phases instead of '%build-inputs'....In build phases, the former is preferred. * gnu/packages/ci.scm (cuirass)[arguments]<#:phases>{wrap-program}: Use 'inputs' argument instead of '%build-inputs'. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Maxime Devos 2021-05-30gnu: cuirass: Update to 1.0.0-25.2120276....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-25.2120276. Mathieu Othacehe 2021-05-30gnu: cuirass: Update to 1.0.0-24.f0be14a....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-24.f0be14a. Mathieu Othacehe 2021-05-29gnu: cuirass: Update to 1.0.0-23.58e3551....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-23.58e3551. Mathieu Othacehe 2021-05-28gnu: cuirass: Update to 1.0.0-22.3ac739b....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-22.3ac739b. Mathieu Othacehe 2021-05-28gnu: cuirass: Update to 1.0.0-21.65ae16b....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-21.65ae16b. Mathieu Othacehe 2021-05-26gnu: cuirass: Update to 1.0.0-20.524b81d....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-20.524b81d. Mathieu Othacehe 2021-05-25gnu: cuirass: Update to 1.0.0-19.e1382f0....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-19.e1382f0. Mathieu Othacehe 2021-05-25gnu: cuirass: Update to 1.0.0-18.b1abb44....* gnu/packages/ci.scm (cuirass): Update to 1.0.0-18.b1abb44. Mathieu Othacehe