aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages m4)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils))

(define-public m4
  (package
   (name "m4")
   (version "1.4.19")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/m4/m4-"
                                version ".tar.xz"))
            (sha256
             (base32
              "15mghcksh11saylpm86h1zkz4in0rbi0pk8i6nqxkdikdmfdxbk3"))))
   (build-system gnu-build-system)
   (arguments
    `(;; Explicitly disable tests when cross-compiling, otherwise 'make check'
      ;; proceeds and fails, unsurprisingly.
      #:tests? ,(not (%current-target-system))
      #:phases
      (modify-phases %standard-phases
        (add-after 'unpack 'disable-test
          (lambda _
            ;; Test 5 raises SIGINT from a child and immediately returns
            ;; code 71, and tests whether the child was killed by a signal.
            ;; Since there is no signal handler for SIGINT in the build
            ;; container, the parent sees the return code, and fails.
            ;; XXX: For some reason adding signal handlers in Guile before
            ;; running tests has no effect.
            (substitute* "tests/test-execute.sh"
              (("4 5 6")
               "4 6"))))
        ,@(if (target-hurd?)
              '((add-after 'unpack 'skip-stack-overflow-tests
                  (lambda _
                    (substitute* '("tests/test-sigsegv-catch-stackoverflow1.c"
                                   "tests/test-sigsegv-catch-stackoverflow2.c")
                      (("(^| )main *\\(.*" all)
                       (string-append all "{\n  exit (77);//"))))))
              '())
        (add-after 'unpack 'configure-shell
          (lambda* (#:key native-inputs inputs #:allow-other-keys)
            (let ((/bin/sh (search-input-file (or native-inputs inputs)
                                              "/bin/sh")))
              ;; Adjust hard-coded /bin/sh for tests.
              (substitute* "lib/config.hin"
                (("\"/bin/sh\"")
                 (format #f "\"~a\"" /bin/sh)))))))))
   (synopsis "Macro processor")
   (description
    "GNU M4 is an implementation of the M4 macro language, which features
some extensions over other implementations, some of which are required by GNU
Autoconf.  It is used as a macro processor, which means it processes text,
expanding macros as it encounters them.  It also has some built-in functions,
for example to run shell commands or to do arithmetic.")
   (license gpl3+)
   (home-page "https://www.gnu.org/software/m4/")))
vail'>...Mathieu Othacehe 2020-05-20bootloader: grub: Allow booting from a Btrfs subvolume....Maxim Cournoyer 2020-05-05Merge branch 'master' into core-updatesMarius Bakke 2020-05-05image: Add a new API....Mathieu Othacehe 2020-05-03tests: install: Test a F2FS root file system....Danny Milosavljevic 2020-04-30Merge branch 'master' into core-updates...Marius Bakke 2020-04-29tests: install: Fix device usage....Mathieu Othacehe 2020-04-29tests: install: Fix gui-installed-os test....Mathieu Othacehe 2020-04-29tests: install: Increase virtual machine RAM....Mathieu Othacehe 2020-04-26tests: Add 'guile-final' to the installation test GC roots....Marius Bakke 2020-04-10tests: Run guided installation tests from an ISO image....Ludovic Courtès 2020-04-08tests: Mark VM images as non-substitutable....Ludovic Courtès 2020-03-26tests: install: Add %test-gui-installed-desktop-os-encrypted....Mathieu Othacehe 2020-03-22tests: install: Abort when one installation step fails....Mathieu Othacehe 2020-03-19tests: Accept manual installation scripts that exit with SIGTERM....Ludovic Courtès 2020-03-05tests: install: Add %test-gui-installed-os-encrypted....Mathieu Othacehe 2020-03-05tests: install: Add "gui-installed-os"....Ludovic Courtès 2020-02-22tests: Factorize LUKS passphrase....Ludovic Courtès 2020-01-19tests: install: "raid-root-os" test uses RAID-1 instead of RAID-0....Ludovic Courtès 2020-01-03tests: install: Test a JFS root file system....Tobias Geerinckx-Rice 2019-11-18tests: install: Fix typo....Maxim Cournoyer 2019-11-06tests: install: Increase root partition size....Ludovic Courtès 2019-07-06tests: encrypted-root-os: Increase root partition size....Ludovic Courtès 2019-06-24tests: Import (guix build utils) in the marionette....Ludovic Courtès 2019-05-15system: Add 'operating-system-with-gc-roots'....Ludovic Courtès 2019-04-14tests: separate-store-os: Increase root partition size....Ludovic Courtès 2019-03-25accounts: Add default value for the 'home-directory' field of <user-account>....Ludovic Courtès 2019-03-13Remove traces of "GuixSD"....Ludovic Courtès