aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages m4)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils))

(define-public m4
  (package
   (name "m4")
   (version "1.4.19")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/m4/m4-"
                                version ".tar.xz"))
            (sha256
             (base32
              "15mghcksh11saylpm86h1zkz4in0rbi0pk8i6nqxkdikdmfdxbk3"))))
   (build-system gnu-build-system)
   (arguments
    `(;; Explicitly disable tests when cross-compiling, otherwise 'make check'
      ;; proceeds and fails, unsurprisingly.
      #:tests? ,(not (%current-target-system))
      ,@(if (system-hurd64?)
            (list #:configure-flags
                  `'(,(string-append
                       "CFLAGS=-g -O2"
                       " -Wno-implicit-function-declaration")))
            '())
      #:phases
      (modify-phases %standard-phases
        (add-after 'unpack 'disable-test
          (lambda _
            ;; Test 5 raises SIGINT from a child and immediately returns
            ;; code 71, and tests whether the child was killed by a signal.
            ;; Since there is no signal handler for SIGINT in the build
            ;; container, the parent sees the return code, and fails.
            ;; XXX: For some reason adding signal handlers in Guile before
            ;; running tests has no effect.
            (substitute* "tests/test-execute.sh"
              (("4 5 6")
               "4 6"))))
        ,@(if (target-hurd?)
              '((add-after 'unpack 'skip-stack-overflow-tests
                  (lambda _
                    (substitute* '("tests/test-sigsegv-catch-stackoverflow1.c"
                                   "tests/test-sigsegv-catch-stackoverflow2.c")
                      (("(^| )main *\\(.*" all)
                       (string-append all "{\n  exit (77);//"))))))
              '())
        ,@(if (target-hurd64?)
              '((add-after 'unpack 'patch-sigsegv
                  (lambda _
                    ;; Stack overflow recovery does not compile
                    (substitute* "lib/sigsegv.in.h"
                      (("__GNU__") "__XGNU__")))))
              '())
        (add-after 'unpack 'configure-shell
          (lambda* (#:key native-inputs inputs #:allow-other-keys)
            (let ((/bin/sh (search-input-file (or native-inputs inputs)
                                              "/bin/sh")))
              ;; Adjust hard-coded /bin/sh for tests.
              (substitute* "lib/config.hin"
                (("\"/bin/sh\"")
                 (format #f "\"~a\"" /bin/sh)))))))))
   (synopsis "Macro processor")
   (description
    "GNU M4 is an implementation of the M4 macro language, which features
some extensions over other implementations, some of which are required by GNU
Autoconf.  It is used as a macro processor, which means it processes text,
expanding macros as it encounters them.  It also has some built-in functions,
for example to run shell commands or to do arithmetic.")
   (license gpl3+)
   (home-page "https://www.gnu.org/software/m4/")))
: Oleg Pykhalov <go.wigust@gmail.com> 2020-04-25doc: cookbook: Fix quotes.Nicolas Goaziou * doc/guix-cookbook.texi (Basic setup with manifests): (Default profile): (The benefits of manifests): Use proper quotes in regular texts. 2020-04-24doc: cookbook: Use @file for file names and extensions.Nicolas Goaziou * doc/guix-cookbook.texi (@samp{GUIX_PACKAGE_PATH}): (Extended example): (Setting up a bind mount): (Basic setup with manifests): (Default profile): Use @file instead of @samp or @code for file names and extensions. 2020-04-24doc: cookbook: Fix misuses of double spacing.Nicolas Goaziou * doc/guix-cookbook.texi (Extended example): (StumpWM): (Basic setup with manifests): Prevent Texinfo from ending a sentence where it should not. (Setting up a bind mount): Add two spaces where needed. 2020-04-22doc: cookbook: Explain how to use bind mounts.Matthew Brooks * doc/guix-cookbook.texi (Setting up a bind mount): Add example. Signed-off-by: Leo Famulari <leo@famulari.name> 2020-03-30gnu: Add sbcl-stumpwm-ttf-fonts.Oleg Pykhalov * gnu/packages/wm.scm (sbcl-stumpwm-ttf-fonts): New variable. * doc/guix-cookbook.texi (Customizing a Window Manager): Document SBCL-STUMPWM-TTF-FONTS installation and configuration. 2020-01-17doc: cookbook: Avoid URL reference to the manual.Ludovic Courtès * doc/guix-cookbook.texi (Other build systems): Use @xref instead of @uref, and remove section number. 2019-11-26doc: cookbook: Add cross-references to the Guile manual.Ludovic Courtès * doc/guix-cookbook.texi (A Scheme Crash Course): Add cross-reference to the Guile manual. 2019-11-26doc: cookbook: Use @result{} & co. instead of a '>' prompt.Ludovic Courtès * doc/guix-cookbook.texi (A Scheme Crash Course) (Extended example): Use @result{}, @print{}, and @error{}. 2019-11-26doc: cookbook: Use Texinfo quotes.Ludovic Courtès * doc/guix-cookbook.texi: Use Texinfo quotes ``like this'' instead of straight quotes or curly quotes. 2019-11-26doc: cookbook: Add cross-reference about ./pre-inst-env.Ludovic Courtès * doc/guix-cookbook.texi (Direct checkout hacking): Refer to "Running Guix Before It Is Installed". 2019-11-26doc: cookbook: Use @lisp for Scheme snippets.Ludovic Courtès * doc/guix-cookbook.texi: Use @lisp instead of @example where appropriate. 2019-10-30doc: Explain how to switch profile from empty shell in "Profiles in Practice".Pierre Neidhardt * doc/guix-cookbook.texi (Profiles in Practice): Add example. 2019-10-28doc: Link to SICP Info page in "A Scheme Crash Course".Pierre Neidhardt * doc/guix-cookbook.texi (Scheme tutorials): Replace Emacs Info reader hint with more useful interactive link to SICP Info page. 2019-10-28doc: Finish importing the "Packaging Tutorial".Pierre Neidhardt * doc/guix-cookbook.texi (Packaging Tutorial): Import all sections after the Scheme crash course. 2019-10-28doc: Fix some typos in "Guix Profiles in Practice".Pierre Neidhardt * doc/guix-cookbook.texi (Guix Profiles in Practice): Fix typos. 2019-10-25doc: cookbook: Use "@lisp" for Scheme snippets.Ludovic Courtès * doc/guix-cookbook.texi: Use @lisp for Scheme snippets instead of "@example scheme". This allows for syntax highlighting of the HTML output. 2019-10-24doc: Add "Guix Profiles in Practice" to the cookbook.Pierre Neidhardt * doc/guix-cookbook.texi (Advanced package management): New chapter. * doc/guix-cookbook.texi (Guix Profiles in Practice): New section. 2019-09-18doc: Add Guix Cookbook.Ricardo Wurmus * .gitignore: Update ignore list. * Makefile.am (assert-no-store-file-names): Exclude the cookbook. * bootstrap: Generate po files for cookbook translations. * doc/guix-cookbook.texi: New file. * doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook translations. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable. (EXTRA_DIST): Add cookbook pot file and po files. (doc-po-update-cookbook-%): New target. (doc-pot-update): Also update cookbook pot file. (doc-po-update): Also update cookbook po files.