aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lsof)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages linux))

(define-public lsof
  (package
    (name "lsof")
    (version "4.99.3")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/lsof-org/lsof")
                    (commit version)))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1v32407al4j0hhcph95lv4xvr9h012lii29iyq41iwj39zwfavax"))
              (patches (search-patches "lsof-compat-linux-6.9.patch"))))
    (build-system gnu-build-system)
    (native-inputs (list automake
                         autoconf
                         groff ;for soelim
                         libtool
                         perl
                         pkg-config
                         procps ;for ps
                         util-linux)) ;for unshare
    (arguments
     (list #:phases
           #~(modify-phases %standard-phases
               (add-after 'unpack 'fix-configure-ac-version
                 ;; see https://github.com/lsof-org/lsof/commit/932a0b3b1992497e23fd9b8d31116b9ca9b0f98d
                 ;; to fix tests/case-01-version.bash test fail.
                 (lambda _
                   (substitute* "configure.ac"
                     (("4\\.99\\.0")
                      "4.99.3"))))
               (add-before 'bootstrap 'disable-failing-tests
                 (lambda _
                   (substitute* "Makefile.am"
                     ;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
                     (("(TESTS \\+=.*) tests/LTsock" _ prefix)
                      prefix)
                     ;; Fails because /proc not mounted in sandbox
                     (("\tdialects/linux/tests/case-20-epoll.bash \\\\")
                      "\\")))))))
    (synopsis "Display information about open files")
    (description
     "Lsof stands for LiSt Open Files, and it does just that.
It lists information about files that are open by the processes running
on the system.")
    (license (license:fsf-free
              "file://00FAQ"
              "License inspired by zlib, see point 1.9 of 00FAQ in the distribution."))
    (home-page "https://people.freebsd.org/~abe/")))
patch_DATA): Register it. Maxim Cournoyer 2022-10-27gnu: python-mypy-protobuf: Switch to pyproject-build-system....* gnu/packages/protobuf.scm (python-mypy-protobuf)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD. Marius Bakke 2022-08-31gnu: Add python-mypy-protobuf....* gnu/packages/protobuf.scm (python-mypy-protobuf): New variable. Maxim Cournoyer 2022-08-31gnu: Add python-nanopb....* gnu/packages/protobuf.scm (python-nanopb): New variable. Maxim Cournoyer 2022-08-31gnu: Add nanopb....* gnu/packages/protobuf.scm (nanopb): New variable. Maxim Cournoyer 2022-07-24gnu: fstrm: Refer to HPND licence by name....* gnu/packages/protobuf.scm (fstrm)[license]: Use license:hpnd directly. Tobias Geerinckx-Rice 2022-07-24gnu: fstrm: Omit static library....* gnu/packages/protobuf.scm (fstrm)[arguments]: Add "--disable-static" to #:configure-flags. Tobias Geerinckx-Rice 2022-07-24gnu: fstrm: Update to 0.6.1....* gnu/packages/protobuf.scm (fstrm): Update to 0.6.1. [license]: Update too. Tobias Geerinckx-Rice 2022-07-12gnu: protobuf-2: Fix build....Partially fixes <https://issues.guix.gnu.org/51093>. * gnu/packages/protobuf.scm (protobuf-2) [phases]{disable-broken-tests}: Delete phase. Maxim Cournoyer 2022-05-31gnu: Remove python2-protobuf....* gnu/packages/protobuf.scm (python2-protobuf): Delete variable. Maxim Cournoyer 2022-05-27gnu: python-protobuf-3.6: Add missing input....This was removed from python-protobuf in 5f8491ea95d7ba88801aa28b6d2b98f30b033186. * gnu/packages/protobuf.scm (python-protobuf-3.6)[inputs]: Add python-six. Christopher Baines 2022-05-20gnu: Add python-proto-plus....* gnu/packages/protobuf.scm (python-proto-plus): New variable. Ricardo Wurmus 2022-05-20gnu: python-protobuf: Update to 3.20.1....* gnu/packages/protobuf.scm (python-protobuf): Update to 3.20.1. [native-inputs]: Remove python-wheel. [propagated-inputs]: Remove python-six. Ricardo Wurmus