aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lsof)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages perl))

(define-public lsof
  (package
    (name "lsof")
    (version "4.94.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/lsof-org/lsof")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "0yxv2jg6rnzys49lyrz9yjb4knamah4xvlqj596y6ix3vm4k3chp"))
       (patches (search-patches "lsof-fatal-test-failures.patch"))))
    (build-system gnu-build-system)
    (native-inputs
     (list groff ; for soelim
           perl))
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda _
             (setenv "LSOF_CC" ,(cc-for-target))
             ,@(if (%current-target-system)
                   '((setenv "LINUX_CONF_CC" "gcc"))
                   '())
             (setenv "LSOF_MAKE" "make")

             ;; By default, the makefile captures the output of 'uname -a'.
             ;; Provide a fixed output instead to make builds reproducible.
             (setenv "LSOF_SYSINFO"
                     (string-append "GNU/" (utsname:sysname (uname))
                                    " (GNU Guix)"))

             (invoke "./Configure" "linux")))
         (add-after 'configure 'patch-timestamps
           (lambda _
             (substitute* "Makefile"
               (("`date`") "`date --date=@1`"))))
         (add-after 'build 'build-man-page
           (lambda _
             (with-output-to-file "lsof.8"
               (lambda _ (invoke "soelim" "Lsof.8")))))
         (add-before 'check 'disable-failing-tests
           (lambda _
             (substitute* "tests/Makefile"
               ;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
               (("(STDTST=.*) LTsock" _ prefix) prefix)
               ;; LTnfs fails without access to a remote NFS server, and LTlock
               ;; fails when run on a Btrfs file system (see:
               ;; https://github.com/lsof-org/lsof/issues/152).
               (("OPTTST=[[:space:]]*LTbigf LTdnlc LTlock LTnfs")
                "OPTTST = LTbigf LTdnlc"))))
         (replace 'check
           (lambda* (#:key tests? #:allow-other-keys)
             (when tests?
               (with-directory-excursion "tests"
                 ;; Tests refuse to run on ‘unvalidated’ platforms.
                 (make-file-writable "TestDB")
                 (invoke "./Add2TestDB")

                 ;; The ‘standard’ tests suggest running ‘optional’ ones as well.
                 (invoke "make" "standard" "optional")))))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (install-file "lsof" (string-append out "/bin"))
               (install-file "lsof.8" (string-append out "/share/man/man8"))))))))
    (synopsis "Display information about open files")
    (description
     "Lsof stands for LiSt Open Files, and it does just that.
It lists information about files that are open by the processes running
on the system.")
    (license (license:fsf-free
              "file://00FAQ"
              "License inspired by zlib, see point 1.9 of 00FAQ in the distribution."))
    (home-page "https://people.freebsd.org/~abe/")))
n>Merge branch 'master' into core-updatesMarius Bakke 2020-05-06gnu: ungoogled-chromium: Update to 81.0.4044.138-0.c2a89fb [security fixes]....Marius Bakke 2020-04-30Merge branch 'master' into core-updates...Marius Bakke 2020-04-28gnu: ungoogled-chromium: Update to 81.0.4044.129-0.c2a89fb [security fixes]....Marius Bakke 2020-04-23Merge branch 'master' into core-updates...Marius Bakke 2020-04-22gnu: ungoogled-chromium: Update to 81.0.4044.122-0.31d6e60 [security fixes]....Marius Bakke 2020-04-19Merge branch 'master' into core-updatesMarius Bakke 2020-04-17gnu: ungoogled-chromium: Update to 81.0.4044.113-0.b484ad4 [fixes CVE-2020-64......Marius Bakke 2020-04-13gnu: icu4c: Remove redundant icu4c-66.1 variable....Marius Bakke 2020-04-13Merge branch 'master' into core-updatesMarius Bakke 2020-04-12gnu: ungoogled-chromium: Update to 81.0.4044.92-0.b484ad4 [security fixes]....Marius Bakke 2020-04-08Merge branch 'master' into core-updates...Marius Bakke 2020-04-03gnu: ungoogled-chromium: Update to 80.0.3987.163-0.516e2d9....Marius Bakke 2020-04-01gnu: ungoogled-chromium: Update to 80.0.3987.162-0.516e2d9 [security fixes]....Marius Bakke 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-19gnu: ungoogled-chromium: Update to 80.0.3987.149-0.516e2d9 [security fixes]....Marius Bakke 2020-03-10Merge branch 'master' into core-updatesMarius Bakke 2020-03-06gnu: ungoogled-chromium: Increase max-silent-time....Marius Bakke 2020-03-05gnu: Remove ld-wrapper-next....Marius Bakke 2020-03-04gnu: ungoogled-chromium: Update to 80.0.3987.132-0.7e68f18 [fixes CVE-2020-64......Marius Bakke 2020-02-25gnu: ungoogled-chromium: Update to 80.0.3987.122-0.bb952f1 [security fixes]....Marius Bakke 2020-02-25gnu: ungoogled-chromium-wayland: Fix build....Marius Bakke 2020-02-25gnu: ungoogled-chromium: Add license information about preserved files....Marius Bakke 2020-02-24gnu: ungoogled-chromium: Update to 80.0.3987.116-0.bb952f1....Marius Bakke 2020-02-24gnu: Add ld wrapper variant that supports quotes in response files....Marius Bakke 2020-02-10gnu: chromium.scm: Remove use of CADR....Marius Bakke 2020-01-21gnu: ungoogled-chromium: Update to 79.0.3945.130-0.e2fae99....Marius Bakke 2020-01-07gnu: ungoogled-chromium: Lower resource limits....Marius Bakke 2020-01-07gnu: ungoogled-chromium: Do not set LD_LIBRARY_PATH in wrapper....Marius Bakke 2019-11-21gnu: ungoogled-chromium: Update to 78.0.3904.108-0.8f06513 [security fixes]....Marius Bakke 2019-11-21gnu: ungoogled-chromium: Increase resource limits in separate phase....Marius Bakke 2019-11-15gnu: ungoogled-chromium: Update to 78.0.3904.97-0.acaf163....Marius Bakke 2019-11-03gnu: Deprecate ungoogled-chromium....Marius Bakke