aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages loko)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages package-management)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages guile-xyz)
  #:use-module (gnu packages chez))

(define-public loko-scheme
  (package
    (name "loko-scheme")
    (version "0.12.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://gitlab.com/weinholt/loko")
             (commit (string-append "v" version))))
       (sha256
        (base32 "12xp82z91qkp9q8lfp46s4sda8qgs472jic3js1kbykn4jzy7399"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (arguments
     (list
      ;; r7rs tests are a work in progress as of 0.7.0.
      #:tests? #f
      #:strip-binaries? #f
      #:make-flags
      #~(list (string-append "PREFIX=" #$output))
      #:phases
      #~(modify-phases %standard-phases
          (delete 'configure)
          (add-before 'build 'akku-fixes
            (lambda _
              (delete-file "Akku.lock")
              (substitute* "Akku.manifest"
                (("\\(depends.*") "(depends)"))
              (invoke "akku" "install")
              (let ((dest "./.akku/lib/")
                    (source "/share/guile/site/3.0/"))
                (for-each
                 (lambda (name prefix)
                   ;; Symlink the scheme libraries so that Akku can find them
                   (symlink (string-append prefix source name)
                            (string-append dest name)))
                 '("struct" "laesare" "pfds" "machine-code")
                 (list #$(this-package-native-input "guile-struct-pack")
                       #$(this-package-native-input "guile-laesare")
                       #$(this-package-native-input "guile-pfds")
                       #$(this-package-native-input "guile-machine-code"))))
              (substitute* ".akku/env"
                (("/bin/sh") (which "sh")))
              #t)))))
    (native-inputs
     (list akku
           chez-scheme
           guile-struct-pack
           guile-laesare
           guile-pfds
           guile-machine-code))
    (home-page "https://scheme.fail")
    (synopsis "Implementation of the algorithmic language Scheme")
    (description
     "Loko Scheme is intended to be a platform for application and operating
system development.  It is written purely in Scheme and some assembler
(i.e. no C code at the bottom).  Both the R6RS and the R7RS standards are
supported.")
    (license license:agpl3+)))
ckages/freedesktop.scm (weston)[inputs]: Add freerdp, gstreamer and gst-plugins-base. [configure-flags](backend-rdp,remoting): Remove flags. (backend-default): New flag. Raghav Gururajan 2021-07-25gnu: weston: Fix package inputs....The newly added inputs are referenced by the package but was missing in the package definition. Some of these inputs might have been used by the package indirectly via propagation from other inputs. The moved inputs are referenced in pkg-config files. * gnu/packages/freedesktop.scm (weston)[inputs]: Add glib, libdrm, libpng, libx11 and libxcb. Move libxkbcommon and wayland to ... [propagated-inputs]: ... here. Add pixman. Raghav Gururajan 2021-07-25gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly....* gnu/packages/freedesktop.scm (weston)[version]: Update to 9.0.0. [configure-flags](c_link_args): New flag. (simple-dmabuf-drm): Remove flag. [native-inputs]: Add mscgen. [inputs]: Add pipewire. Raghav Gururajan 2021-07-24gnu: Simplify "Xvbf" invocation in pre-check phases....* gnu/packages/geo.scm (qgis)[arguments]: Simplify invocation of 'Xvfb' in 'check' phase, assuming 'Xvfb' is in $PATH. * gnu/packages/graphics.scm (opensubdiv)[arguments]: Likewise. * gnu/packages/java-graphics.scm (java-piccolo2d-extras)[arguments]: Likewise. * gnu/packages/kde-frameworks.scm (kcontacts)[arguments]: Likewise. (kdeclarative)[arguments]: Likewise. * gnu/packages/kde-multimedia.scm (elisa)[arguments]: Likewise. * gnu/packages/kde-plasma.scm (kscreenlocker)[arguments]: Likewise. * gnu/packages/radio.scm (gnuradio)[arguments]: Likewise. * gnu/packages/education.scm (gcompris-qt)[arguments]: Likewise. * gnu/packages/freedesktop.scm (weston)[arguments]: Likewise. Ludovic Courtès 2021-06-19Merge branch 'master' into core-updates...Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm Marius Bakke 2021-06-18gnu: xdg-desktop-portal-wlr: Update to 0.4.0....* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr): Update to 0.4.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andrew Tropin 2021-06-18gnu: xdg-desktop-portal: Update to 1.8.1 and honor XDG_DESKTOP_PORTAL_DIR....* gnu/packages/freedesktop.scm (xdg-desktop-portal): Update to 1.8.1. [arguments, native-search-paths]: New field. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andrew Tropin 2021-05-15Merge branch 'master' into core-updatesLudovic Courtès 2021-05-14gnu: Add seatd....* gnu/packages/freedesktop.scm (seatd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> pineapples 2021-05-14gnu: Add xdg-desktop-portal-wlr....* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Giacomo Leidi 2021-05-13gnu: elogind: Fix build failure with GCC 10....* gnu/packages/freedesktop.scm (elogind)[arguments]: Adjust substitution so that the disabled test does not return from a void, which is not allowed in newer GCC. Marius Bakke 2021-05-09Merge branch 'master' into core-updates... Conflicts: gnu/local.mk gnu/packages/bioinformatics.scm gnu/packages/django.scm gnu/packages/gtk.scm gnu/packages/llvm.scm gnu/packages/python-web.scm gnu/packages/python.scm gnu/packages/tex.scm guix/build-system/asdf.scm guix/build/emacs-build-system.scm guix/profiles.scm Marius Bakke 2021-05-02gnu: libxdg-basedir: Omit static library....* gnu/packages/freedesktop.scm (libxdg-basedir)[arguments]: Add ‘--disable-static’ to #:configure-flags. Tobias Geerinckx-Rice 2021-05-02gnu: libxdg-basedir: Update to 1.2.3....* gnu/packages/freedesktop.scm (libxdg-basedir): Update to 1.2.3. Tobias Geerinckx-Rice 2021-04-16Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: gnu/local.mk gnu/packages/boost.scm gnu/packages/chez.scm gnu/packages/compression.scm gnu/packages/crates-io.scm gnu/packages/docbook.scm gnu/packages/engineering.scm gnu/packages/gcc.scm gnu/packages/gl.scm gnu/packages/gtk.scm gnu/packages/nettle.scm gnu/packages/python-check.scm gnu/packages/python-xyz.scm gnu/packages/radio.scm gnu/packages/rust.scm gnu/packages/sqlite.scm guix/build-system/node.scm Efraim Flashner 2021-04-09gnu: Add python-cchardet....* gnu/packages/freedesktop.scm (python-cchardet): New variable. Brendan Tildesley 2021-03-27gnu: Use 'gtk-doc/stable' in native-inputs of selected packages....* gnu/packages/calendar.scm (libical), gnu/packages/check.scm (umockdev), gnu/packages/fontutils.scm (libraqm), gnu/packages/freedesktop.scm (appstream, farstream, libglib-testing) (udisks, libfprint, libportal), gnu/packages/geo.scm (memphis, osm-gps-map), gnu/packages/glib.scm (template-glib), gnu/packages/gnome.scm (gupnp-igd, libcloudproviders, libgrss, seed) (gtx, dee, zeitgeist, phodav, gssdp, gupnp, gupnp-dlna, gupnp-av, rygel) (libnma, gdl, libnotify, vte-ng, dconf, libxklavier, libsoup, colord) (geoclue, geocode-glib, amtk, grilo, gvfs, gusb, network-manager) (network-manager-applet, gfbgraph, libunique, cheese, libhandy) (gnome-latex, libgda), gnu/packages/gstreamer.scm (orc), gnu/packages/gtk.scm (at-spi2-core, goocanvas), gnu/packages/language.scm (nimf), gnu/packages/networking.scm (libnice), gnu/packages/video.scm (schroedinger), gnu/packages/virtualization.scm (libosinfo), gnu/packages/webkit.scm (wpewebkit, webkitgtk), gnu/packages/xml.scm (libxmlb)[native-inputs]: Replace 'gtk-doc' with 'gtk-doc/stable'. Mark H Weaver 2021-03-26gnu: wayland-protocols: Update description....* gnu/packages/freedesktop.scm (wayland-protocols) [description]: Modify. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net> Raghav Gururajan 2021-03-26gnu: wayland: Update synopsis, description and license....* gnu/packages/freedesktop.scm (wayland) [synopsis]: Modify. [description]: Modify. [license]: Change from x11 to expat. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net> Raghav Gururajan 2021-03-26gnu: wayland: Fix and move documentation....* gnu/packages/freedesktop.scm (wayland) [outputs]: New output "doc". [arguments]<#:phases>['patch-docbook-xml]: New phase. ['move-doc]: New phase. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net> Raghav Gururajan 2021-03-26gnu: wayland: Update to 1.19.0....* gnu/packages/freedesktop.scm (wayland)[version]: Update to 1.19.0. [build-system]: Change from gnu to meson. [native-inputs]: Move here docbook-xml and docbook-xsl from ... [inputs]: ... here. Move libffi to ... [propagated-inputs]: ... here. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net> Raghav Gururajan 2021-03-17gnu: Use PACKAGE/INHERIT in more places....* gnu/packages/algebra.scm (fftwf, fftw-openmpi), gnu/packages/audio.scm (ztoolkit-rsvg), gnu/packages/bioinformatics.scm (python2-dendropy), gnu/packages/boost.scm (boost-with-python2), gnu/packages/check.scm (python2-mock, python2-pytest-mock), gnu/packages/cups.scm (hplip-minimal), gnu/packages/freedesktop.scm (libinput-minimal), gnu/packages/gettext.scm (gnu-gettext), gnu/packages/glib.scm (python2-pygobject), gnu/packages/gnome.scm (gdl-minimal, libsoup-minimal, python2-pyatspi), gnu/packages/groff.scm (groff-minimal), gnu/packages/jami.scm (ffmpeg-jami), gnu/packages/libcanberra.scm (libcanberra/gtk+-2), gnu/packages/lirc.scm (python2-lirc), gnu/packages/llvm.scm (clang-runtime-3.5), gnu/packages/mpi.scm (java-openmpi, openmpi-thread-multiple), gnu/packages/node.scm (libnode), gnu/packages/onc-rpc.scm (libtirpc/hurd), gnu/packages/python-compression.scm (bitshuffle-for-snappy), gnu/packages/python-crypto.scm (python2-pycrypto, python2-cryptography) (python2-cryptography, python2-m2crypto), gnu/packages/python-web.scm (python2-html2text, python2-tornado) (python2-terminado, python2-ndg-httpsclient, python2-websocket-client) (python2-rauth, python2-url, python2-s3transfer), gnu/packages/python-xyz.scm (python2-psutil, python2-serpent) (python2-humanfriendly, python2-empy, python2-parse-type, python2-polib) (python2-jsonschema, python2-pystache, python2-cython, python2-numpydoc) (python2-ipyparallel, python2-traitlets, python2-dbus) (python2-beautifulsoup4, python2-pep517, python2-flake8, python2-llfuse) (python2-tlsh, python-file, python2-notebook, python-jupyter-console-minimal) (python2-contextlib2, python2-promise, python2-anyjson, python2-amqp) (python2-kombu, python2-billiard, python2-celery, python2-whoosh) (python2-jellyfish, python-rope, ptpython-2, python2-binaryornot) (python2-setproctitle, python2-argcomplete, python2-xopen, python2-isort) (python2-radon, python2-rfc6555, python2-activepapers, python2-send2trash) (python2-cloudpickle, python2-reparser), gnu/packages/python.scm (python2-called-python), gnu/packages/qt.scm (python2-sip, python-pyqt-without-qtwebkit, python2-pyqt) (python-qscintilla, python-pyqt+qscintilla), gnu/packages/scanner.scm (sane-backends), gnu/packages/sdl.scm (guile3.0-sdl2), gnu/packages/selinux.scm (checkpolicy, libselinux, libsemanage, secilc) (python-sepolgen, policycoreutils), gnu/packages/serialization.scm (lua5.1-libmpack, lua5.2-libmpack), gnu/packages/simulation.scm (fenics), gnu/packages/statistics.scm (python2-statsmodels), gnu/packages/texinfo.scm (info-reader), gnu/packages/wxwidgets.scm (wxwidgets-gtk2, wxwidgets-gtk2-3.1), gnu/packages/xml.scm (xmlsec-nss), gnu/packages/xorg.scm (uim-gtk, uim-qt), guix/build-system/python.scm (package-with-explicit-python) (strip-python2-variant): Use PACKAGE/INHERIT. Mark H Weaver 2021-03-10gnu: Add appstream....* gnu/packages/freedesktop.scm (appstream): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at> Raghav Gururajan 2021-02-15gnu: python-pyxdg: Update to 0.27....* gnu/packages/freedesktop.scm (python-pyxdg): Update to 0.27. [arguments]: Adjust custom 'check phase. Efraim Flashner 2021-02-01Merge branch 'staging'Leo Famulari 2021-01-31gnu: libappindicator: Propagate some inputs as per .pc file....* gnu/packages/freedesktop.scm (libappindicator) [inputs]: Move gtk+ and libdbusmenu to ... [propagated-inputs]: ... here. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at> Raghav Gururajan 2021-01-28gnu: libfprint: Update to 1.90.7....* gnu/packages/freedesktop.scm (libfprint): Update to 1.90.7. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Vincent Legoll 2020-12-29Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-28gnu: desktop-file-utils: Update to 0.26....* gnu/packages/freedesktop.scm (desktop-file-utils): Update to 0.26. (native-inputs): Add autoconf & automake. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Vincent Legoll 2020-12-23gnu: libfprint: Update to 1.90.6....* gnu/packages/freedesktop.scm (libfprint): Update to 1.90.6. Tobias Geerinckx-Rice 2020-12-13gnu: libinput: Update to 1.16.4....* gnu/packages/freedesktop.scm (libinput): Update to 1.16.4. Marius Bakke 2020-11-30gnu: libfprint: Update to 1.90.4....* gnu/packages/freedesktop.scm (libfprint): Update to 1.90.4. Tobias Geerinckx-Rice 2020-11-15Merge branch 'master' into stagingMarius Bakke 2020-11-11gnu: telepathy-idle: Update to 0.2.2....* gnu/packages/freedesktop.scm (telepathy-idle): Update to 0.2.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf, automake, and libootl. Tobias Geerinckx-Rice 2020-11-07Merge branch 'master' into staging... Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm Marius Bakke 2020-10-20gnu: Add farstream....* gnu/packages/freedesktop.scm (farstream): New variable. * gnu/packages/patches/farstream-make.patch: New file. * gnu/local.mk (dist_PATCH_DATA): Add it. Signed-off-by: Julien Lepiller <julien@lepiller.eu> Raghav Gururajan 2020-10-13gnu: elogind: Update to 243.7....* gnu/packages/freedesktop.scm (elogind): Update to 243.7. [arguments]: Remove obsolete phase. Marius Bakke 2020-10-13gnu: libinput: Update to 1.16.2....* gnu/packages/freedesktop.scm (libinput): Update to 1.16.2. Marius Bakke 2020-10-05Merge branch 'master' into stagingGuillaume Le Vaillant 2020-09-29gnu: wev: Use version tag instead of commit....* gnu/packages/freedesktop.scm (wev): Update to the 1.0.0 version tag, which happens to be the same commit anyway. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Brendan Tildesley 2020-09-19gnu: libfprint: Update to 1.90.3....* gnu/packages/freedesktop.scm (libfprint): Update to 1.90.3. Tobias Geerinckx-Rice 2020-09-15gnu: waylandpp: Update to 0.2.8....* gnu/packages/freedesktop.scm (waylandpp): Update to 0.2.8. Tobias Geerinckx-Rice