aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages loko)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages package-management)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages guile-xyz)
  #:use-module (gnu packages chez))

(define-public loko-scheme
  (package
    (name "loko-scheme")
    (version "0.12.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://gitlab.com/weinholt/loko")
             (commit (string-append "v" version))))
       (sha256
        (base32 "12xp82z91qkp9q8lfp46s4sda8qgs472jic3js1kbykn4jzy7399"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (arguments
     (list
      ;; r7rs tests are a work in progress as of 0.7.0.
      #:tests? #f
      #:strip-binaries? #f
      #:make-flags
      #~(list (string-append "PREFIX=" #$output))
      #:phases
      #~(modify-phases %standard-phases
          (delete 'configure)
          (add-before 'build 'akku-fixes
            (lambda _
              (delete-file "Akku.lock")
              (substitute* "Akku.manifest"
                (("\\(depends.*") "(depends)"))
              (invoke "akku" "install")
              (let ((dest "./.akku/lib/")
                    (source "/share/guile/site/3.0/"))
                (for-each
                 (lambda (name prefix)
                   ;; Symlink the scheme libraries so that Akku can find them
                   (symlink (string-append prefix source name)
                            (string-append dest name)))
                 '("struct" "laesare" "pfds" "machine-code")
                 (list #$(this-package-native-input "guile-struct-pack")
                       #$(this-package-native-input "guile-laesare")
                       #$(this-package-native-input "guile-pfds")
                       #$(this-package-native-input "guile-machine-code"))))
              (substitute* ".akku/env"
                (("/bin/sh") (which "sh")))
              #t)))))
    (native-inputs
     (list akku
           chez-scheme
           guile-struct-pack
           guile-laesare
           guile-pfds
           guile-machine-code))
    (home-page "https://scheme.fail")
    (synopsis "Implementation of the algorithmic language Scheme")
    (description
     "Loko Scheme is intended to be a platform for application and operating
system development.  It is written purely in Scheme and some assembler
(i.e. no C code at the bottom).  Both the R6RS and the R7RS standards are
supported.")
    (license license:agpl3+)))
ommit/gnu/packages/containers.scm?id=8fe6d3e8446944294856950ef192cac83e03e58b'>gnu: yajl: Drop custom ‘lib-’ prefix....* gnu/packages/web.scm (yajl): New variable, renamed from… (libyajl): …this one, which is now a DEPRECATED-PACKAGE alias of yajl. Adjust all users. Tobias Geerinckx-Rice 2022-09-27gnu: podman: Update to 4.2.1....* gnu/packages/containers.scm (podman): Update to 4.2.1. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Hilton Chain 2022-09-14gnu: podman: Install shell completions....* gnu/packages/containers.scm (podman)[arguments]: Add 'install-completions phase to install shell completions. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Michael Rohleder 2022-09-11gnu: slirp4netns: Update to 1.2.0....* gnu/packages/containers.scm (slirp4netns): Update to 1.2.0. Marius Bakke 2022-09-11gnu: libslirp: Update to 4.7.0....* gnu/packages/containers.scm (libslirp): Update to 4.7.0. [inputs]: Move GLIB ... [propagated-inputs]: ... here. Marius Bakke 2022-09-08gnu: podman: Update to 4.2.0....* gnu/packages/containers.scm (podman): Update to 4.2.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zhu Zihao 2022-09-08gnu: podman: Use G-expressions....* gnu/packages/containers.scm (podman)[arguments]: Use G-expressions. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zhu Zihao 2022-05-29gnu: crun: Update to 1.4.5....* gnu/packages/containers.scm (crun): Update to 1.4.5. Tobias Geerinckx-Rice 2022-01-11gnu: conmon: Use G-expressions....* gnu/packages/containers.scm (conmon)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2022-01-11gnu: conmon: Update to 2.0.31....* gnu/packages/containers.scm (conmon): Update to 2.0.31. Tobias Geerinckx-Rice 2022-01-01gnu: Add podman....* gnu/packages/containers.scm (podman): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timmy Douglas 2022-01-01gnu: Add cni-plugins....* gnu/packages/containers.scm (cni-plugins): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Timmy Douglas 2022-01-01gnu: Add slirp4netns....* gnu/packages/containers.scm (slirp4netns): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timmy Douglas 2022-01-01gnu: Add libslirp....* gnu/packages/containers.scm (libslirp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timmy Douglas 2022-01-01gnu: Add conmon....* gnu/packages/containers.scm (conmon): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Timmy Douglas 2022-01-01gnu: Add crun....* gnu/packages/containers.scm (crun): New variable. * gnu/local.mk: add containers.scm Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timmy Douglas