aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages logo)
  #:use-module (gnu packages qt)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix build-system gnu))

(define-public qlogo
  (package
    (name "qlogo")
    (version "0.92")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://qlogo.org/assets/sources/QLogo-"
                           version ".tgz"))
       (sha256
        (base32
         "0cpyj1ji6hjy7zzz05672f0j6fr0mwpc1y3sq36hhkv2fkpidw22"))))
    (build-system gnu-build-system)
    (inputs
     (list qtbase-5))
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
             (substitute* "QLogo.pro"
               (("target\\.path = /usr/bin")
                (string-append "target.path = "
                               (assoc-ref outputs "out") "/bin")))
             (invoke "qmake" "QLogo.pro")))
         ;; The check phase rebuilds the source for tests. So, it needs to be
         ;; run after the install phase has installed the outputs of the build
         ;; phase.
         (delete 'check)
         (add-after 'install 'check
           (lambda _
             ;; Clean files created by the build phase.
             (invoke "make" "clean")
             ;; QLogo tries to create its "dribble file" in the home
             ;; directory. So, set HOME.
             (setenv "HOME" "/tmp")
             ;; Build and run tests.
             (invoke "qmake" "TestQLogo.pro")
             (invoke "make" "-j" (number->string (parallel-job-count)))
             (invoke "./testqlogo"))))))
    (home-page "https://qlogo.org")
    (synopsis "Logo interpreter using Qt and OpenGL")
    (description "QLogo is an interpreter for the Logo language written in C++
using Qt and OpenGL.  Specifically, it mimics, as reasonably as possible, the
UCBLogo interpreter.")
    (license license:gpl2+)))
c940c20bb79bca3281003836eaf5ed7a0e'>gnu: uchardet: Update to 0.0.7....* gnu/packages/freedesktop.scm (uchardet): Update to 0.0.7. Tobias Geerinckx-Rice 2020-08-18gnu: Add malcontent....* gnu/packages/freedesktop.scm (malcontent): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Raghav Gururajan 2020-08-18gnu: Add libglib-testing....* gnu/packages/freedesktop.scm (libglib-testing): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Raghav Gururajan 2020-07-27gnu: Add xdg-desktop-portal-gtk....* gnu/packages/freedesktop.scm (xdg-desktop-portal-gtk): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Anders Thuné 2020-07-27gnu: Add xdg-desktop-portal....* gnu/packages/freedesktop.scm (xdg-desktop-portal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Anders Thuné 2020-07-27gnu: Add libportal....* gnu/packages/freedesktop.scm (libportal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Anders Thuné 2020-07-25gnu: wayland: Update to 1.18.0....* gnu/packages/freedesktop.scm (wayland): Update to 1.18.0. Marius Bakke 2020-07-25gnu: wayland-protocols: Update to 1.20....* gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.20. Marius Bakke 2020-07-25gnu: libinput: Update to 1.15.6....* gnu/packages/freedesktop.scm (libinput): Update to 1.15.6. Marius Bakke 2020-06-27gnu: exempi: Delete the static library....* gnu/packages/freedesktop.scm (exempi)[arguments]: Add phase to delete libexempi.a. Marius Bakke 2020-06-27gnu: exempi: Update to 2.5.2....* gnu/packages/freedesktop.scm (exempi): Update to 2.5.2. Marius Bakke 2020-06-08Merge branch 'master' into stagingMarius Bakke 2020-06-06gnu: libqmi: Update to 1.24.14....* gnu/packages/freedesktop.scm (libqmi): Update to 1.24.14. Tobias Geerinckx-Rice 2020-06-06Merge branch 'master' into stagingMarius Bakke 2020-06-06gnu: libqmi: Update to 1.24.12....* gnu/packages/freedesktop.scm (libqmi): Update to 1.24.12. Tobias Geerinckx-Rice 2020-05-26Merge branch 'master' into stagingMarius Bakke 2020-05-26gnu: libinput: Update to 1.15.5....* gnu/packages/freedesktop.scm (libinput): Update to 1.15.5. Marius Bakke 2020-05-22gnu: modem-manager: Update to 1.12.10....* gnu/packages/freedesktop.scm (modem-manager): Update to 1.12.10. [arguments]: Remove arguments '--disable-more-warnings'. Brice Waegeneire 2020-05-14gnu: Add libappindicator....* gnu/packages/freedesktop.scm (libappindicator): New variable. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz> Nicolò Balzarotti 2020-05-14gnu: Add libindicator....* gnu/packages/freedesktop.scm (libindicator): New variable. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz> Nicolò Balzarotti 2020-05-14gnu: udisks: Appease guix lint....The line is too long and HTML docs are build fine without it. * gnu/packages/freedesktop.scm (udisks)[arguments]: Remove configure flag '--enable-gtk-doc'. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Brice Waegeneire 2020-05-14gnu: udisks: Update to 2.8.4....* gnu/packages/freedesktop.scm (udisks): Update to 2.8.4. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Brice Waegeneire 2020-05-11gnu: waylandpp: Update to 0.2.7....* gnu/packages/freedesktop.scm (waylandpp): Update to 0.2.7. Marius Bakke 2020-05-08Merge branch 'core-updates'Marius Bakke 2020-05-07gnu: Add plymouth....* gnu/packages/freedesktop.scm (plymouth): New variable. Co-authored-by: Nikita <nikita@n0.is> Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Ricardo Wurmus 2020-04-13Merge branch 'master' into core-updatesMarius Bakke 2020-04-12gnu: udiskie: Fix grammar of "allows to manage" to "manages"....* gnu/packages/freedesktop (udiskie): Fix grammar. Vagrant Cascadian