aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages logo)
  #:use-module (gnu packages qt)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix download)
  #:use-module (guix packages)
  #:use-module (guix build-system gnu))

(define-public qlogo
  (package
    (name "qlogo")
    (version "0.92")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://qlogo.org/assets/sources/QLogo-"
                           version ".tgz"))
       (sha256
        (base32
         "0cpyj1ji6hjy7zzz05672f0j6fr0mwpc1y3sq36hhkv2fkpidw22"))))
    (build-system gnu-build-system)
    (inputs
     (list qtbase-5))
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'configure
           (lambda* (#:key outputs #:allow-other-keys)
             (substitute* "QLogo.pro"
               (("target\\.path = /usr/bin")
                (string-append "target.path = "
                               (assoc-ref outputs "out") "/bin")))
             (invoke "qmake" "QLogo.pro")))
         ;; The check phase rebuilds the source for tests. So, it needs to be
         ;; run after the install phase has installed the outputs of the build
         ;; phase.
         (delete 'check)
         (add-after 'install 'check
           (lambda _
             ;; Clean files created by the build phase.
             (invoke "make" "clean")
             ;; QLogo tries to create its "dribble file" in the home
             ;; directory. So, set HOME.
             (setenv "HOME" "/tmp")
             ;; Build and run tests.
             (invoke "qmake" "TestQLogo.pro")
             (invoke "make" "-j" (number->string (parallel-job-count)))
             (invoke "./testqlogo"))))))
    (home-page "https://qlogo.org")
    (synopsis "Logo interpreter using Qt and OpenGL")
    (description "QLogo is an interpreter for the Logo language written in C++
using Qt and OpenGL.  Specifically, it mimics, as reasonably as possible, the
UCBLogo interpreter.")
    (license license:gpl2+)))
>gnu: poppler-next: Delete variable....Maxim Cournoyer 2023-04-14Merge branch 'master' into core-updates....Maxim Cournoyer 2023-04-10gnu: qpdf: Fix cross-building....Efraim Flashner 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-19gnu: Add a4pdf....Liliana Marie Prikler 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Christopher Baines 2023-02-24gnu: qpdfview: Use new package style....Timotej Lazar 2023-02-24gnu: qpdfview: Update to 0.5.0....Timotej Lazar 2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice 2023-02-17gnu: Make nothing depend on QtWebKit....Leo Famulari 2023-02-16gnu: Remove unneeded module imports....Efraim Flashner 2023-02-12gnu: zathura: Update to 0.5.2....Efraim Flashner 2023-02-12gnu: zathura-pdf-poppler: Update to 0.3.1....Efraim Flashner 2023-02-12gnu: zathura-pdf-mupdf: Update to 0.4.0....Efraim Flashner 2023-02-12gnu: zathura-ps: Update to 0.2.7....Efraim Flashner 2023-02-12gnu: zathura-cb: Update to 0.1.10....Efraim Flashner 2023-02-01gnu: mupdf: Update to 1.21.1....Timotej Lazar 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner 2023-01-22gnu: Add python-pypdf....Vagrant Cascadian 2023-01-03gnu: flyer-composer: Don't depend on QtWebKit....Marius Bakke 2022-12-28gnu: Add pdfcrack....Petr Hodina 2022-12-11gnu: pdfarranger: Update to 1.9.2....Tobias Geerinckx-Rice 2022-12-14gnu: xournalpp: Update to 1.1.3....Nicolas Goaziou