aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lirc)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system python)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-xyz))

(define-public lirc
  (package
    (name "lirc")
    (version "0.10.2")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/lirc/LIRC/" version
                                  "/lirc-" version ".tar.bz2"))
              (sha256
               (base32
                "0ai27l6hxfgkwvkqa3fy1b1gqzw2y10md030y5ig4748fj1fqi1x"))
              (patches (search-patches "lirc-localstatedir.patch"
                                       "lirc-reproducible-build.patch"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags
       '("--localstatedir=/var"
         ;; "configure" script fails to enable "devinput" driver as it
         ;; checks for "/dev/input" directory (which is not available),
         ;; so enable it explicitly.
         "--enable-devinput")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'disable-kernel-sniffing
           (lambda _
             ;; Correct the faulty assumption that systemd support should be
             ;; hard-wired when a build host's /proc/version contains "Ubuntu".
             (substitute* "configure"
               (("kernelversion=.*") "kernelversion=irrelevant\n"))))
         (add-after 'unpack 'patch-lirc-make-devinput
           (lambda* (#:key inputs #:allow-other-keys)
             ;; 'lirc-make-devinput' script assumes that linux headers
             ;; are placed in "/usr/...".
             (let ((headers (assoc-ref inputs "kernel-headers")))
               (substitute* "tools/lirc-make-devinput"
                 (("/usr/include") (string-append headers "/include"))))))
         (add-after 'unpack 'patch-doc/Makefile.in
           (lambda _
             ;; Lirc wants to install several images and a useless html page
             ;; to "$(localstatedir)/lib/lirc/".  This makes 'install' phase
             ;; fail as localstatedir is "/var", so do not install these
             ;; files there (the same images are installed in
             ;; "share/doc/lirc/images/" anyway).
             (substitute* "doc/Makefile.in"
               (("^vardocs_DATA =.*") "vardocs_DATA =\n")
               (("^varimage_DATA =.*") "varimage_DATA =\n"))))
         (add-after 'unpack 'omit-pip-sourceball
           ;; ‘make install’ invokes ’setup.py sdist’, which has no known (to
           ;; nckx) way to enforce mtimes.  The utility of this is questionable,
           ;; IMO: let's disable it entirely & listen for complaints, if any.
           (lambda _
             (substitute* "Makefile.in"
               (("(PYTHON_TARBALL.*=).*" _ tarball=)
                (string-append tarball= "\n")))))
         (add-before 'configure 'build-reproducibly
           (lambda _
             (setenv "LIRC_IRDB_CACHE_ID" "build time"))))))
    (native-inputs
     (list pkg-config libxslt))
    (inputs
     `(("libx11" ,libx11)
       ("libusb-compat" ,libusb-compat)
       ("alsa-lib" ,alsa-lib)
       ("python" ,python)))
    (home-page "https://www.lirc.org/")
    (synopsis "Linux Infrared Remote Control")
    (description
     "LIRC allows computers to send and receive IR signals of many commonly
used remote controls.  The most important part of LIRC is the @code{lircd}
daemon that decodes IR signals received by the device drivers.  The second
daemon program @code{lircmd} translates IR signals to mouse movements.
The user space applications allow you to control your computer with a remote
control: you can send X events to applications, start programs and much more
on just one button press.")
    (license license:gpl2+)))

(define-public python-lirc
  (let ((commit "c28708bbeb6e02d85f13dd7e0b24e8e86abc215b")
        (revision "2"))
    (package
      (name "python-lirc")
      (version (git-version "1.2.1" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://github.com/tompreston/python-lirc")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32
           "13s9zqyfh871ls1aha47rhmk13b4mcyfckcn2sw70bvc26832gk6"))))
      (build-system python-build-system)
      (inputs
       (list lirc))
      (native-inputs
       (list python-cython))
      (arguments
       `(#:tests? #f         ; the only tests that exist are interactive
         #:phases
         (modify-phases %standard-phases
           (add-before 'build 'build-from-cython-files
             (lambda _ (invoke "make" "py3"))))))
      (home-page "https://github.com/tompreston/python-lirc")
      (synopsis "Python bindings for LIRC")
      (description "@code{lirc} is a Python module which provides LIRC bindings.")
      (license license:gpl3))))
tible-systems): Add aarch64-linux. (linux-libre-4.14): Limit to x86_64-linux, i686-linux and armhf-linux. * gnu/packages/aux-files/linux-libre/4.16-arm64.conf: New file. * Makefile.am (AUX_FILES): Add 4.16-arm64.conf. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Vagrant Cascadian 2018-05-11pack: Relocatable wrapper now properly maps the current UID/GID....* gnu/packages/aux-files/run-in-namespace.c (write_id_map) (disallow_setgroups): New functions. (main): Use 'clone' via 'syscall' instead of 'fork' followed by 'unshare'. Add calls to 'disallow_setgroups' and 'write_id_map' in the parent process. Ludovic Courtès 2018-05-10pack: Add '--relocatable'....* gnu/packages/aux-files/run-in-namespace.c: New file. * Makefile.am (AUX_FILES): Add it. * guix/scripts/pack.scm (<c-compiler>): New record type. (c-compiler, bootstrap-c-compiler, c-compiler-compiler): New procedures. (self-contained-tarball): Use 'relative-file-name' for the SOURCE -> TARGET symlink. (docker-image): Add 'defmod' to please Geiser. (wrapped-package, map-manifest-entries): New procedures. (%options, show-help): Add --relocatable. (guix-pack): Honor it. Ludovic Courtès 2018-04-11gnu: linux-libre: Update to 4.16.1....* gnu/packages/linux.scm (%linux-libre-version): Update to 4.16.1. (%linux-libre-hash): Update hash. * gnu/packages/aux-files/linux-libre/4.15-arm.conf, gnu/packages/aux-files/linux-libre/4.15-i686.conf, gnu/packages/aux-files/linux-libre/4.15-x86_64.conf: Delete files. * gnu/packages/aux-files/linux-libre/4.16-arm.conf, gnu/packages/aux-files/linux-libre/4.16-i686.conf, gnu/packages/aux-files/linux-libre/4.16-x86_64.conf: New files. * Makefile.am (AUX_FILES): Update accordingly. Mark H Weaver 2018-01-30gnu: linux-libre: Update to 4.15, while retaining 4.14 LTS....* gnu/packages/linux.scm (%linux-libre-version): Update to 4.15. (%linux-libre-hash): Update hash. (%linux-libre-arm-generic-4.14, %linux-libre-arm-omap2plus-4.14) (%linux-libre-4.1-version, %linux-libre-4.1-hash): New variables. * gnu/packages/aux-files/linux-libre/4.15-arm.conf, gnu/packages/aux-files/linux-libre/4.15-i686.conf, gnu/packages/aux-files/linux-libre/4.15-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. Mark H Weaver 2018-01-30gnu: linux-libre: Update configuration files to latest releases....* gnu/packages/aux-files/linux-libre/4.14-i686.conf, gnu/packages/aux-files/linux-libre/4.14-x86_64.conf, gnu/packages/aux-files/linux-libre/4.9-i686.conf, gnu/packages/aux-files/linux-libre/4.9-x86_64.conf, gnu/packages/aux-files/linux-libre/4.4-i686.conf, gnu/packages/aux-files/linux-libre/4.4-x86_64.conf, gnu/packages/aux-files/linux-libre/4.1-i686.conf, gnu/packages/aux-files/linux-libre/4.1-x86_64.conf: Update using "make oldconfig" on the latest point releases. Mark H Weaver 2018-01-30gnu: linux-libre: NVME core support is now built-in....* gnu/system/linux-initrd.scm (base-initrd)[linux-modules]: Remove "nvme". * gnu/packages/aux-files/linux-libre/4.1-i686.conf, gnu/packages/aux-files/linux-libre/4.1-x86_64.conf, gnu/packages/aux-files/linux-libre/4.4-i686.conf, gnu/packages/aux-files/linux-libre/4.4-x86_64.conf: Set CONFIG_BLK_DEV_NVME=y. * gnu/packages/aux-files/linux-libre/4.9-i686.conf, gnu/packages/aux-files/linux-libre/4.9-x86_64.conf, gnu/packages/aux-files/linux-libre/4.14-arm.conf, gnu/packages/aux-files/linux-libre/4.14-i686.conf, gnu/packages/aux-files/linux-libre/4.14-x86_64.conf: Set CONFIG_BLK_DEV_NVME=y and CONFIG_NVME_CORE=y. Mark H Weaver 2017-12-26gnu: linux-libre: Adapt to renamed configuration options in 4.14.9....This is a followup to commit 95b969bc9cde419e9cfcf4299a7524381ae7a64d. * gnu/packages/aux-files/linux-libre/4.14-x86_64.conf, gnu/packages/aux-files/linux-libre/4.14-i686.conf: Adapt to the configuration options being renamed from CONFIG_*_UNWINDER to CONFIG_UNWINDER_* in version 4.14.9. Mark H Weaver 2017-11-23linux-libre: Adapt some arm options to match intel conf....* gnu/packages/aux-files/linux-libre/4.14-arm.conf: GuixSD base-initrd expects ext4 and fat filesystem to be built-in. Adapt configuration accordingly. Also set devtmpfs_mount to yes. Mathieu Othacehe 2017-11-18gnu: linux-libre: Remove Tegra DRM from arm configuration....The code fails to compile on armhf using our configuration. See <https://patchwork.kernel.org/patch/9688615/> for details. * gnu/packages/aux-files/linux-libre/4.14-arm.conf: Remove Tegra DRM support. Mark H Weaver 2017-11-18gnu: linux-libre: Remove Nouveau from arm configuration....The Nouveau code fails to compile on armhf with our configuration. * gnu/packages/aux-files/linux-libre/4.14-arm.conf: Disable Nouveau. Mark H Weaver 2017-11-16gnu: linux-libre: Update to 4.14....* gnu/packages/linux.scm (%linux-libre-version): Update to 4.14. (%linux-libre-hash): Update hash. * gnu/packages/aux-files/linux-libre/4.13-arm.conf, gnu/packages/aux-files/linux-libre/4.13-i686.conf, gnu/packages/aux-files/linux-libre/4.13-x86_64.conf: Delete files. * gnu/packages/aux-files/linux-libre/4.14-arm.conf, gnu/packages/aux-files/linux-libre/4.14-i686.conf, gnu/packages/aux-files/linux-libre/4.14-x86_64.conf: New files. * Makefile.am (AUX_FILES): Update accordingly. Mark H Weaver 2017-11-09gnu: linux: Add linux-libre arm kernel....* Makefile.am (AUX_FILES): Add arm config file. * gnu/packages/aux-files/linux-libre/4.13-arm.conf: New file. * gnu/packages/linux.scm (%intel-compatible-systems): Rename to %linux-compatible-systems and add "armhf-linux". (linux-libre): Adapt consequently. The config file for arm is taken from debian armmp kernel. It's a generic firmware for ARMv7 multiplatform compatible SoCs. Mathieu Othacehe