#pragma once #include "config.h" #include "types.hh" #include #include namespace nix { enum CompressionType { COMPRESSION_NONE = 0, COMPRESSION_GZIP = 1 #if HAVE_BZLIB_H , COMPRESSION_BZIP2 = 2 #endif }; struct Settings { typedef std::map SettingsMap; Settings(); void processEnvironment(); void set(const string & name, const string & value); string get(const string & name, const string & def); Strings get(const string & name, const Strings & def); bool get(const string & name, bool def); int get(const string & name, int def); void update(); string pack(); SettingsMap getOverrides(); /* The directory where we store sources and derived files. */ Path nixStore; /* The directory where we log various operations. */ Path nixLogDir; /* The directory where state is stored. */ Path nixStateDir; /* The directory where we keep the SQLite database. */ Path nixDBPath; /* The directory where configuration files are stored. */ Path nixConfDir; /* The directory where the main programs are stored. */ Path nixBinDir; /* File name of the socket the daemon listens to. */ Path nixDaemonSocketFile; /* Absolute file name of the 'guix' program. */ Path guixProgram; /* Whether to keep temporary directories of failed builds. */ bool keepFailed; /* Whether to keep building subgoals when a sibling (another subgoal of the same goal) fails. */ bool keepGoing; /* User and groud id of the client issuing the build request. Used to set the owner and group of the kept temporary directories of failed builds. */ uid_t clientUid; gid_t clientGid; /* Whether, if we cannot realise the known closure corresponding to a derivation, we should try to normalise the derivation instead. */ bool tryFallback; /* Verbosity l
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lighting)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages bison)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages gnunet)
  #:use-module (gnu packages flex)
  #:use-module (gnu packages libftdi)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages protobuf))

(define-public ola
  (package
    (name "ola")
    (version "0.10.9")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/OpenLightingProject/ola")
             (commit version)))
       (sha256
        (base32 "0mbf5dc309pqg9ckqgk2kh9p3mf9vqsjkxnwjzqw7yzzf17ij3zk"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs
     (list bison
           cppunit
           flex
           pkg-config
           ;; For git repository bootstrapping.
           autoconf
           automake
           libtool))
    (inputs
     (list libftdi
           libmicrohttpd
           libusb
           `(,util-linux "lib")
           zlib))
    (propagated-inputs
     (list protobuf))       ; for pkg-config --libs libola
    (arguments
     (list
      ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
      ;; build to fail on low memory systems.  We disable that with the
      ;; following configure flags.
      #:configure-flags #~(list "CXXFLAGS=-ftrack-macro-expansion=0")))
    (synopsis "Framework for controlling entertainment lighting equipment")
    (description "The Open Lighting Architecture is a framework for lighting
control information.  It supports a range of protocols and over a dozen USB
devices.  It can run as a standalone service, which is useful for converting
signals between protocols, or alternatively using the OLA API, it can be used
as the backend for lighting control software.  OLA runs on many different
platforms including ARM, which makes it a perfect fit for low cost Ethernet to
DMX gateways.")
    (home-page "https://www.openlighting.org/ola")
    (license license:lgpl2.1+)))
autoOptimiseStore; /* Whether to add derivations as a dependency of user environments (to prevent them from being GCed). */ bool envKeepDerivations; /* Whether to lock the Nix client and worker to the same CPU. */ bool lockCPU; /* Whether to show a stack trace if Nix evaluation fails. */ bool showTrace; private: SettingsMap settings, overrides; void _get(string & res, const string & name); void _get(bool & res, const string & name); void _get(StringSet & res, const string & name); void _get(Strings & res, const string & name); template void _get(N & res, const string & name); }; // FIXME: don't use a global variable. extern Settings settings; extern const string nixVersion; }