;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès ;;; Copyright © 2014, 2015, 2018 Mark H Weaver ;;; Copyright © 2014 Eric Bavier ;;; Copyright © 2016, 2018 Efraim Flashner ;;; Copyright © 2016 Jan Nieuwenhuizen ;;; Copyright © 2017 Kei Kebreau ;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice ;;; Copyright © 2019 Julien Lepiller ;;; Copyright © 2019 Mathieu Othacehe ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; with
aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lighting)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages bison)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages gnunet)
  #:use-module (gnu packages flex)
  #:use-module (gnu packages libftdi)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages protobuf))

(define-public ola
  (package
    (name "ola")
    (version "0.10.9")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/OpenLightingProject/ola")
             (commit version)))
       (sha256
        (base32 "0mbf5dc309pqg9ckqgk2kh9p3mf9vqsjkxnwjzqw7yzzf17ij3zk"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs
     (list bison
           cppunit
           flex
           pkg-config
           ;; For git repository bootstrapping.
           autoconf
           automake
           libtool))
    (inputs
     (list libftdi
           libmicrohttpd
           libusb
           `(,util-linux "lib")
           zlib))
    (propagated-inputs
     (list protobuf))       ; for pkg-config --libs libola
    (arguments
     (list
      ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
      ;; build to fail on low memory systems.  We disable that with the
      ;; following configure flags.
      #:configure-flags #~(list "CXXFLAGS=-ftrack-macro-expansion=0")))
    (synopsis "Framework for controlling entertainment lighting equipment")
    (description "The Open Lighting Architecture is a framework for lighting
control information.  It supports a range of protocols and over a dozen USB
devices.  It can run as a standalone service, which is useful for converting
signals between protocols, or alternatively using the OLA API, it can be used
as the backend for lighting control software.  OLA runs on many different
platforms including ARM, which makes it a perfect fit for low cost Ethernet to
DMX gateways.")
    (home-page "https://www.openlighting.org/ola")
    (license license:lgpl2.1+)))
append #$output "/libtmp")) (rename-file (string-append #$output "/libtmp") (string-append #$output "/lib"))))))) (native-inputs (list tcl)) (inputs (list tcllib)) (home-page "http://incrtcl.sourceforge.net/") (synopsis "Object Oriented programming (OOP) extension for Tcl") (description "[incr Tcl] is a widely used object-oriented system for Tcl. The name is a play on C++, and [incr Tcl] provides a similar object model, including multiple inheritance and public and private classes and variables.") (license license:public-domain))) (define-public expect (package (name "expect") (version "5.45.4") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/expect/Expect/" version "/expect" version ".tar.gz")) (sha256 (base32 "0d1cp5hggjl93xwc8h1y6adbnrvpkk0ywkd00inz9ndxn21xm9s9")))) (build-system gnu-build-system) (inputs (list ;; TODO: Add these optional dependencies. ;; ("libX11" ,libX11) ;; ("xorgproto" ,xorgproto) ;; ("tk" ,tk) tcl)) (arguments '(#:configure-flags (let ((out (assoc-ref %outputs "out")) (tcl (assoc-ref %build-inputs "tcl"))) (list (string-append "--with-tcl=" tcl "/lib") (string-append "--with-tclinclude=" tcl "/include") (string-append "--exec-prefix=" out) (string-append "--mandir=" out "/share/man"))) #:phases (modify-phases %standard-phases (add-before 'configure 'set-path-to-stty (lambda _ (substitute* "configure" (("STTY_BIN=/bin/stty") (string-append "STTY_BIN=" (which "stty")))) #t))) #:test-target "test")) (home-page "https://core.tcl-lang.org/expect/") (synopsis "Tool for automating interactive applications") (description "Expect is a tool for automating interactive applications such as telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect really makes this stuff trivial. Expect is also useful for testing these same applications. And by adding Tk, you can wrap interactive applications in X11 GUIs.") (license license:public-domain))) ; as written in `license.terms' (define-public tk (package (name "tk") (version "8.6.11.1") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/tcl/Tcl/" (version-prefix version 3) "/tk" version "-src.tar.gz")) (sha256 (base32 "1gh9k7l76qg9l0sb78ijw9xz4xl1af47aqbdifb6mjpf3cbsnv00")) (patches (search-patches "tk-find-library.patch")))) (build-system gnu-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-before 'configure 'pre-configure (lambda _ (chdir "unix"))) (add-after 'install 'create-wish-symlink (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (symlink (string-append out "/bin/wish" ,(version-major+minor (package-version tk))) (string-append out "/bin/wish"))))) (add-after 'install 'add-fontconfig-flag (lambda* (#:key inputs outputs #:allow-other-keys) ;; Add the missing -L flag for Fontconfig in 'tk.pc' and ;; 'tkConfig.sh'. (let ((out (assoc-ref outputs "out")) (fontconfig (assoc-ref inputs "fontconfig"))) (substitute* (find-files out "^(tkConfig\\.sh|tk\\.pc)$") (("-lfontconfig") (string-append "-L" fontconfig "/lib -lfontconfig"))))))) #:configure-flags (list (string-append "--with-tcl=" (assoc-ref %build-inputs "tcl") "/lib") ;; This is needed when cross-compiling, see: ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719247 ,@(if (%current-target-system) '("tcl_cv_strtod_buggy=1" "ac_cv_func_strtod=yes") '())) ;; The tests require a running X server, so we just skip them. #:tests? #f)) (native-inputs (list pkg-config)) (inputs `(("libxft" ,libxft) ("fontconfig" ,fontconfig) ("tcl" ,tcl))) ;; tk.h refers to X11 headers, hence the propagation. (propagated-inputs (list libx11 libxext)) (home-page "https://www.tcl.tk/") (synopsis "Graphical user interface toolkit for Tcl") (description "Tk is a graphical toolkit for building graphical user interfaces (GUIs) in the Tcl language.") (license (package-license tcl)))) (define-public perl-tk (package (name "perl-tk") (version "804.036") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/S/SR/SREZIC/Tk-" version ".tar.gz")) (sha256 (base32 "0pha40m97fzafjnq8vwkbi5sml6xv8jki6qi60rxrzmxlrqp5aij")))) (build-system perl-build-system) (native-inputs (list pkg-config)) (inputs `(("libx11" ,libx11) ("libpng" ,libpng) ("libjpeg" ,libjpeg-turbo))) (arguments `(#:make-maker-flags `(,(string-append "X11=" (assoc-ref %build-inputs "libx11"))) ;; Fails to build in parallel: . #:parallel-build? #f)) (synopsis "Graphical user interface toolkit for Perl") (description "Tk is a Graphical User Interface ToolKit.") (home-page "https://metacpan.org/release/Tk") ;; From the package README: "... you can redistribute it and/or modify it ;; under the same terms as Perl itself, with the exception of all the ;; files in the pTk sub-directory which have separate terms derived from ;; those of the orignal Tix4.1.3 or Tk8.4.* sources. See the files ;; pTk/license.terms, pTk/license.html_lib, and pTk/Tix.license for ;; details of this license." (license license:perl-license))) (define-public tcllib (package (name "tcllib") (version "1.19") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/tcllib/tcllib/" version "/tcllib-" version ".tar.gz")) (sha256 (base32 "173abxaazdmf210v651708ab6h7xhskvd52krxk6ifam337qgzh1")))) (build-system gnu-build-system) (native-inputs (list tcl)) (native-search-paths (list (search-path-specification (variable "TCLLIBPATH") (separator " ") (files (list (string-append "lib/tcllib" version)))))) (home-page "https://core.tcl.tk/tcllib/home") (synopsis "Standard Tcl Library") (description "Tcllib, the standard Tcl library, is a collection of common utility functions and modules all written in high-level Tcl.") (license (package-license tcl)))) (define-public tklib (package (name "tklib") (version "0.6") (source (origin (method url-fetch) (uri (string-append "https://core.tcl.tk/tklib/tarball/tklib-" version ".tar.gz?uuid=tklib-0-6")) (sha256 (base32 "03y0bzgwbh7nnyqkh8n00bbkq2fyblq39s3bdb6mawna0bbn0wwg")))) (build-system gnu-build-system) (native-inputs (list tcl)) (propagated-inputs (list tcllib tk)) ; for "wish" (native-search-paths (list (search-path-specification (variable "TCLLIBPATH") (separator " ") (files (list (string-append "lib/tklib" version)))))) (home-page "https://www.tcl.tk/software/tklib/") (synopsis "Tk utility modules for Tcl") (description "Tklib is a collection of common utility functions and modules for Tk, all written in high-level Tcl. Examples of provided widgets: @enumerate @item @code{chatwidget} @item @code{datefield} @item @code{tooltip} @item @code{cursor} @item @code{ipentry} @item @code{tablelist} @item @code{history} @item @code{tkpiechart} @item @code{ico} @item @code{crosshair} @item @code{ntext} @item @code{plotchart} @item @code{ctext} @item @code{autosscroll} @item @code{canvas} @end enumerate") (license (package-license tcl)))) (define-public tclxml (package (name "tclxml") (version "3.2") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/" name "/TclXML/" version "/" name "-" version ".tar.gz")) (sha256 (base32 "0ffb4aw63inig3aql33g4pk0kjk14dv238anp1scwjdjh1k6n4gl")) (patches (search-patches "tclxml-3.2-install.patch")))) (build-system gnu-build-system) (native-inputs (list tcl libxml2 libxslt)) (propagated-inputs (list tcllib)) ; uri (native-search-paths (list (search-path-specification (variable "TCLLIBPATH") (separator " ") (files (list (string-append "lib/Tclxml" version)))))) (arguments `(#:configure-flags (list (string-append "--exec-prefix=" (assoc-ref %outputs "out")) (string-append "--with-tclconfig=" (assoc-ref %build-inputs "tcl") "/lib") (string-append "--with-xml2-config=" (assoc-ref %build-inputs "libxml2") "/bin/xml2-config") (string-append "--with-xslt-config=" (assoc-ref %build-inputs "libxslt") "/bin/xslt-config")) #:test-target "test")) (home-page "http://tclxml.sourceforge.net/") (synopsis "Tcl library for XML parsing") (description "TclXML provides event-based parsing of XML documents. The application may register callback scripts for certain document features, and when the parser encounters those features while parsing the document the callback is evaluated.") (license (license:non-copyleft "file://LICENCE" "See LICENCE in the distribution.")))) (define-public tclx (package (name "tclx") (version "8.4.1") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/tclx/TclX/" version "/tclx" version ".tar.bz2")) (sha256 (base32 "1v2qwzzidz0is58fd1p7wfdbscxm3ip2wlbqkj5jdhf6drh1zd59")))) (build-system gnu-build-system) (arguments '(#:tests? #f ; a test named profile.test segfaults #:configure-flags (list (string-append "--with-tcl=" (assoc-ref %build-inputs "tcl") "/lib") (string-append "--libdir=" (assoc-ref %outputs "out") "/lib")))) (inputs (list tcl tk)) (home-page "http://tclx.sourceforge.net/") (synopsis "System programming extensions for Tcl") (description "Extended Tcl is oriented towards system programming tasks and large application development. TclX provides additional interfaces to the operating system, and adds many new programming constructs, text manipulation tools, and debugging tools.") (license license:tcl/tk))) (define-public tcl-tls (package (name "tcl-tls") (version "1.7.22") (source (origin (method url-fetch) (uri (string-append "https://core.tcl-lang.org/tcltls/uv/tcltls-" version ".tar.gz")) (sha256 (base32 "1d639gzngxp7zwwpb4ayh663br6vhsbiy6wxm952rj2y4xx2nkp8")))) (build-system gnu-build-system) (inputs (list tcl)) (propagated-inputs (list openssl)) (arguments (list #:configure-flags #~(let ((tcl #$(this-package-input "tcl"))) (list "--with-ssl=libressl" (string-append "-with-ssl-dir=" #$(this-package-input "openssl")) (string-append "--with-tcl=" tcl "/lib") (string-append "--with-tclinclude=" tcl "/include") (string-append "--exec-prefix=" #$output) (string-append "--mandir=" #$output "/share/man"))) #:test-target "test")) (search-paths (list (search-path-specification (variable "TCLLIBPATH") (separator " ") (files (list (string-append "lib/tcltls" version)))))) (home-page "https://core.tcl-lang.org/tcltls/index") (synopsis "Tcl binding to OpenSSL toolkit") (description "This extension provides a generic binding to OpenSSL, utilizing the @code{Tcl_StackChannel} API for Tcl 8.2 and higher. The sockets behave exactly the same as channels created using Tcl's built-in socket command with additional options for controlling the SSL session.") (properties '((release-monitoring-url . "https://core.tcl-lang.org/tcltls/wiki/Download") (upstream-name . "tcltls"))) (license license:public-domain))) (define-public go-github.com-nsf-gothic (let ((commit "97dfcc195b9de36c911a69a6ec2b5b2659c05652") (revision "0")) (package (name "go-github.com-nsf-gothic") (version (git-version "0.0.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/nsf/gothic") (commit commit))) (sha256 (base32 "1lrhbml6r4sh22rrn3m9bck70pv0g0c1diprg7cil90x0jidxczr")) (file-name (git-file-name name version)))) (build-system go-build-system) (arguments `(#:import-path "github.com/nsf/gothic")) (propagated-inputs (list tk tcl)) (home-page "https://github.com/nsf/gothic") (synopsis "Tcl/Tk Go bindings") (description "Gothic contains Go bindings for Tcl/Tk. The package contains only one type and one function that can be used to create a Tk interpreter.") (license license:expat))))