aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lighting)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages bison)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages gnunet)
  #:use-module (gnu packages flex)
  #:use-module (gnu packages libftdi)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages protobuf))

(define-public ola
  (package
    (name "ola")
    (version "0.10.9")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/OpenLightingProject/ola")
             (commit version)))
       (sha256
        (base32 "0mbf5dc309pqg9ckqgk2kh9p3mf9vqsjkxnwjzqw7yzzf17ij3zk"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs
     (list bison
           cppunit
           flex
           pkg-config
           ;; For git repository bootstrapping.
           autoconf
           automake
           libtool))
    (inputs
     (list libftdi
           libmicrohttpd
           libusb
           `(,util-linux "lib")
           zlib))
    (propagated-inputs
     (list protobuf))       ; for pkg-config --libs libola
    (arguments
     (list
      ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
      ;; build to fail on low memory systems.  We disable that with the
      ;; following configure flags.
      #:configure-flags #~(list "CXXFLAGS=-ftrack-macro-expansion=0")))
    (synopsis "Framework for controlling entertainment lighting equipment")
    (description "The Open Lighting Architecture is a framework for lighting
control information.  It supports a range of protocols and over a dozen USB
devices.  It can run as a standalone service, which is useful for converting
signals between protocols, or alternatively using the OLA API, it can be used
as the backend for lighting control software.  OLA runs on many different
platforms including ARM, which makes it a perfect fit for low cost Ethernet to
DMX gateways.")
    (home-page "https://www.openlighting.org/ola")
    (license license:lgpl2.1+)))
39e920e16045ebe0dade467992f527bc1'>gnu: gifsicle: Update to 1.94....* gnu/packages/image.scm (gifsicle): Update to 1.94. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2023-06-19gnu: libjxl: Update to 0.8.2....* gnu/packages/image.scm (libjxl): Update to 0.8.2. [source]: Remove lcms, libpng and zlib bundles in the snippet. [arguments]<#:configure-flags>: Add "-DJPEGXL_FORCE_SYSTEM_LCMS2=true" and "-DJPEGXL_BUNDLE_LIBPNG=false". [inputs]: Add lcms, zlib. Signed-off-by: Christopher Baines <mail@cbaines.net> Vinicius Monego 2023-06-14gnu: Add pngcheck....* gnu/packages/image.scm (pngcheck): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Artyom V. Poptsov 2023-06-05gnu: blurhash: Update to 0.2.0....* gnu/packages/image.scm (blurhash): Update to 0.2.0. [native-inputs]: Remove cmake. Add pkg-config. Efraim Flashner 2023-06-04gnu: jpegoptim: Fix cross-compiling to riscv64....* gnu/packages/image.scm (jpegoptim)[arguments]: When cross-compiling t riscv64, add phase to update-config-scripts. [native-inputs]: When cross-compiling to riscv64, add config. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Zheng Junjie 2023-06-04gnu: libicns: Fix cross-compiling to riscv64....* gnu/packages/image.scm (libicns)[arguments]: When cross-compiling to riscv64, add phase to update-config-scripts. [native-inputs]: When cross-compiling to riscv64, add config. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Zheng Junjie 2023-05-17gnu: slurp: Update to 1.4.0....* gnu/packages/image.scm (slurp): Update to 1.4.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Yovan Naumovski 2023-05-04gnu: exiv2: Adjust tests on riscv64-linux....* gnu/packages/image.scm (exiv2)[arguments]: Also use the custom 'adjust-tests phase when building for riscv64-linux. Efraim Flashner 2023-04-23gnu: swappy: Add gettext input....* gnu/packages/image.scm (swappy) [inputs]: Add gettext-minimal. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Brian Cully 2023-04-19gnu: Add converseen....* gnu/packages/image.scm (converseen): New variable. * gnu/packages/patches/converseen-hide-non-free-pointers.patch: * gnu/packages/patches/converseen-hide-updates-checks.patch: New files. * gnu/local.mk: Register files above. Nicolas Goaziou 2023-04-19gnu: libjpeg-turbo: Skip failing test on riscv64-linux....* gnu/packages/image.scm (libjpeg-turbo)[arguments]: Adjust configure-flags to skip a failing test also on riscv64-linux. Efraim Flashner 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-12gnu: Purge pre-1.3.0 deprecated packages....* gnu/packages/bioinformatics.scm (deeptools): Remove variable. * gnu/packages/efi.scm (efi_analyzer): Ditto. * gnu/packages/guile.scm (guile-2.2/bug-fix, guile-json): Ditto. * gnu/packages/image.scm (libjpeg): Ditto. * gnu/packages/kde.scm (kdevplatform): Ditto * gnu/packages/linphone.scm (linphoneqt): Ditto. * gnu/packages/maths.scm (blis-sandybridge, blis-haswell, blis-knl): Ditto. * gnu/packages/mpi.scm (hwloc-2.0): Ditto. * gnu/packages/music.scm (python-abjad, zlfo): Ditto. * gnu/packages/perl.scm (perl-base, perl-parent): Ditto. * gnu/packages/tryton.scm (python-trytond): Ditto. * gnu/packages/video.scm (gnome-mpv): Ditto. * tests/graph.scm: Use guile-json-1. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-04-12gnu: libjxr: Fix cross-compilation....* gnu/packages/image.scm (libjxr)[arguments]: Use cc-for-target. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Z572 2023-03-23Merge remote-tracking branch 'origin/master' into staging....With resolved conflicts in: gnu/packages/ibus.scm gnu/packages/image.scm gnu/packages/lisp.scm gnu/packages/virtualization.scm Maxim Cournoyer 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-17gnu: Add leptonica-1.80....* gnu/packages/image.scm (leptonica-1.80): New variable. Maxim Cournoyer