aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lighting)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages bison)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages gnunet)
  #:use-module (gnu packages flex)
  #:use-module (gnu packages libftdi)
  #:use-module (gnu packages libusb)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages protobuf))

(define-public ola
  (package
    (name "ola")
    (version "0.10.9")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/OpenLightingProject/ola")
             (commit version)))
       (sha256
        (base32 "0mbf5dc309pqg9ckqgk2kh9p3mf9vqsjkxnwjzqw7yzzf17ij3zk"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs
     (list bison
           cppunit
           flex
           pkg-config
           ;; For git repository bootstrapping.
           autoconf
           automake
           libtool))
    (inputs
     (list libftdi
           libmicrohttpd
           libusb
           `(,util-linux "lib")
           zlib))
    (propagated-inputs
     (list protobuf))       ; for pkg-config --libs libola
    (arguments
     (list
      ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
      ;; build to fail on low memory systems.  We disable that with the
      ;; following configure flags.
      #:configure-flags #~(list "CXXFLAGS=-ftrack-macro-expansion=0")))
    (synopsis "Framework for controlling entertainment lighting equipment")
    (description "The Open Lighting Architecture is a framework for lighting
control information.  It supports a range of protocols and over a dozen USB
devices.  It can run as a standalone service, which is useful for converting
signals between protocols, or alternatively using the OLA API, it can be used
as the backend for lighting control software.  OLA runs on many different
platforms including ARM, which makes it a perfect fit for low cost Ethernet to
DMX gateways.")
    (home-page "https://www.openlighting.org/ola")
    (license license:lgpl2.1+)))
s='msg-tooltip'>* gnu/packages/text-editors.scm (lem)[arguments]: Use cc-for-target. Change-Id: Ied9e7ec2f51c7b72470c99f0353df06354d9fc4d jgart 2024-10-02gnu: lem: Build included shared library....* gnu/packages/text-editors.scm (lem): Build shared library. [source]: Delete precompiled binaries. [arguments]: Patch libvterm and build shared library. [inputs]: Add libvterm. Change-Id: I296f139f93032ccbb380e112c9c1e4fd681ae1a7 jgart 2024-10-01gnu: Add lem....* gnu/packages/text-editors.scm (lem): New variable. Co-authored-by: Ada Stevenson <adanskana@gmail.com> Change-Id: I2946355068597e44b8699281647bcd8d98f47911 jgart 2024-09-06gnu: nano: Update to 8.2....* gnu/packages/text-editors.scm (nano): Update to 8.2. Change-Id: I72d3ead40cc5cabf52931567195d6bafd3e86d6e Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Andy Tai 2024-08-31gnu: texmacs: Add libxcrypt dependency....* gnu/packages/text-editors.scm (texmacs)[inputs]: Add libxcrypt. Change-Id: I746dde1dda33c7c8b23242442dc2c2cadade07ec 宋文武 2024-08-31gnu: ed: Update to 1.20.1....* gnu/packages/text-editors.scm (ed): Update to 1.20.1. Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org> Change-Id: I58ba1c8213a5ac2a126ecb58321859d64d0fcb01 Signed-off-by: Christopher Baines <mail@cbaines.net> Andy Tai 2024-08-31gnu: ed: Update to 1.19....* gnu/packages/text-editors.scm (ed): Update to 1.19. Change-Id: I69f4c9cbcf5c862cbffb6d82662c548591917d88 Ludovic Courtès 2024-08-31gnu: text-editors: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/text-editors.scm (vis)[inputs]: Add 'bash-minimal'. (jucipp)[inputs]: Likewise. (ghostwriter)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ic55d5602d0514029eba1f8d5313169570da3edb1 Maxime Devos 2024-08-31build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-mod......Until now users would have to cargo cult or inspect the private %default-modules variable of (guix build-systems gnu) to discover which modules to include when extending the used modules via the #:modules argument. The renaming was automated via the command: $ git grep -l %gnu-build-system-modules | xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i * guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to... (%default-gnu-imported-modules): ... this. (%default-modules): Rename to... (%default-gnu-modules): ... this. Export. (dist-package, gnu-build, gnu-cross-build): Adjust accordingly. Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee Maxim Cournoyer 2024-08-26gnu: scintilla: Update to 5.5.1....* gnu/packages/text-editors.scm (scintilla): Update to 5.5.1. Change-Id: I51b87c8095b97bd0b4dd51bc5f7558735fe9da73 Nicolas Goaziou 2024-08-11gnu: mg: Update to 20240709....* gnu/packages/text-editors.scm (mg): Update to 20240709. Change-Id: Id21e7ae99c2b9e66344e87bccb6165fa27cb22f1 Signed-off-by: Christopher Baines <mail@cbaines.net> Spencer King 2024-07-12gnu: nano: Update to 8.1....* gnu/packages/text-editors.scm (nano): Update to 8.1. Change-Id: Ib6bc2371393c0bd2a854a0437d27fe36cd76f871 Signed-off-by: jgart <jgart@dismail.de> Andy Tai 2024-06-24gnu: kakoune: Update to 2024.05.18....* gnu/packages/text-editors.scm (kakoune): Update to 2024.05.18. Change-Id: I4ca1f66e104a40f2d759c097c0548e6812ef6d16 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Ashish SHUKLA 2024-05-14gnu: kakoune: Update to 2024.05.09....* gnu/packages/text-editors.scm (kakoune): Update to 2024.05.09. Change-Id: If6c1ea02304880d5ffa818e57f922f9d81c1bf5a Signed-off-by: Christopher Baines <mail@cbaines.net> Ashish SHUKLA 2024-05-13gnu: mg: Update to 20230501....* gnu/packages/text-editors.scm (mg): Update to 20230501. Change-Id: Ie72901207562488f392d5877e1b41a41067893f4 Signed-off-by: Christopher Baines <mail@cbaines.net> kiasoc5 2024-05-12gnu: nano: Update to 8.0....* gnu/packages/text-editors.scm (nano): Update to 8.0. Change-Id: I2312dd5140fee4d8cc42f622f733c616d7b39550 Signed-off-by: Christopher Baines <mail@cbaines.net> Andy Tai