aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libunwind)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses))

(define-public libunwind
  (package
    (name "libunwind")
    (version "1.6.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://savannah/libunwind/libunwind-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "0xj9g6a9q7v7zz6lymf3f6011synibgawi4wi384bywid5kfqsja"))))
    (build-system gnu-build-system)
    (arguments
     `(;; Two tests are failing with newer toolchains:
       ;; https://github.com/libunwind/libunwind/issues/363
       #:make-flags
       '("XFAIL_TESTS=run-coredump-unwind run-coredump-unwind-mdi")
       ;; A different collection of tests fails for each architecture.
       #:tests? ,(and (not (%current-target-system))
                      (target-x86-64?))))
    (home-page "https://www.nongnu.org/libunwind")
    (synopsis "Determining the call chain of a program")
    (description
     "The primary goal of this project is to define a portable and efficient C
programming interface (API) to determine the call-chain of a program.  The API
additionally provides the means to manipulate the preserved (callee-saved)
state of each call-frame and to resume execution at any point in the
call-chain (non-local goto).  The API supports both local (same-process) and
remote (across-process) operation.  As such, the API is useful in a number of
applications.")
    ;; Do not believe <https://savannah.nongnu.org/projects/libunwind/>:
    ;; see <https://github.com/libunwind/libunwind/issues/372>.
    (license expat)))
-avail'>...These unversioned files were modified upstream. The result of $ openssl x509 -in <FILE> -text for each old/new pair remains the same, however. * gnu/packages/certs.scm (le-certs)[inputs]: Update hash for isrgrootx1.pem, letsencryptauthorityx3.pem, and letsencryptauthorityx4.pem. Tobias Geerinckx-Rice 2020-02-14gnu: nss, nss-certs: Update to 3.50....* gnu/packages/nss.scm (nss): Update to 3.50. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2020-01-19gnu: nss, nss-certs: Update to 3.49.1....* gnu/packages/certs.scm (nss-certs): Update to 3.49.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2020-01-12gnu: nss, nss-certs: Update to 3.49....* gnu/packages/certs.scm (nss-certs): Update to 3.49. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-10-08gnu: nss, nss-certs: Update to 3.46.1....* gnu/packages/nss.scm (nss): Update to 3.46.1. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-08-04gnu: nss, nss-certs: Update to 3.45....* gnu/packages/certs.scm (nss-certs): Update to 3.45. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-06-29gnu: nss, nss-certs: Update to 3.44.1....* gnu/packages/certs.scm (nss-certs): Update to 3.44.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-05-24gnu: nss, nss-certs: Update to 3.44....* gnu/packages/nss.scm (nss): Update to 3.44. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-05-02gnu: le-certs: Update hashes....They added the 3 missing '^M' to all pem certs. * gnu/packages/certs.scm (le-certs)[inputs]: Update the hashes of isrgrootx1.pem, letsencryptauthorityx3.pem, letsencryptauthorityx4.pem. 宋文武 2019-03-21gnu: nss, nss-certs: Update to 3.43....* gnu/packages/gnuzilla.scm (nss): Update to 3.43. * gnu/packages/certs.scm (nss-certs): Ditto. Marius Bakke 2019-02-10gnu: nss, nss-certs: Update to 3.42.1....* gnu/packages/certs.scm (nss-certs): Update to 3.42.1. * gnu/packages/gnuzilla.scm (nss): Likewise. Marius Bakke 2018-12-12gnu: nss, nss-certs: Update to 3.41....* gnu/packages/certs.scm (nss-certs): Update to 3.41. * gnu/packages/gnuzilla.scm (nss): Likewise. Marius Bakke 2018-12-08gnu: nss, nss-certs: Update to 3.40.1....* gnu/packages/certs.scm (nss-certs): Update to 3.40.1. * gnu/packages/gnuzilla.scm (nss): Likewise. [arguments]: Adjust DOMSUF variable to upstream changes. Marius Bakke 2018-09-01gnu: nss, nss-certs: Update to 3.39 [fixes CVE-2018-12384]....* gnu/packages/gnuzilla.scm (nss): Update to 3.39. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-06-26gnu: nss, nss-certs: Update to 3.38 [fixes CVE-2018-0495]....* gnu/packages/certs.scm (nss-certs): Update to 3.38. * gnu/packages/gnuzilla.scm (nss): Likewise. Marius Bakke 2018-06-19gnu: nss, nss-certs: Update to 3.37.3....* gnu/packages/gnuzilla.scm (nss): Update to 3.37. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-04-30Merge branch 'master' into core-updatesMark H Weaver 2018-04-15gnu: nss, nss-certs: Update to 3.36.1....* gnu/packages/gnuzilla.scm (nss): Update to 3.36.1. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-03-27gnu: Use invoke and return #t from all builders....* gnu/packages/admin.scm, gnu/packages/android.scm, gnu/packages/audio.scm, gnu/packages/avr.scm, gnu/packages/base.scm, gnu/packages/bioinformatics.scm, gnu/packages/certs.scm, gnu/packages/check.scm, gnu/packages/code.scm, gnu/packages/commencement.scm, gnu/packages/dictionaries.scm, gnu/packages/docbook.scm, gnu/packages/emacs.scm, gnu/packages/embedded.scm, gnu/packages/fonts.scm, gnu/packages/games.scm, gnu/packages/gnome.scm, gnu/packages/gnu-doc.scm, gnu/packages/guile.scm, gnu/packages/hurd.scm, gnu/packages/javascript.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/lisp.scm, gnu/packages/lxde.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/mate.scm, gnu/packages/pkg-config.scm, gnu/packages/qt.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/sdl.scm, gnu/packages/statistics.scm, gnu/packages/syncthing.scm, gnu/packages/tex.scm, gnu/packages/web.scm, gnu/packages/wine.scm, gnu/packages/xfce.scm: In the builders of packages using 'trivial-build-system', use invoke where appropriate, raise exceptions on errors, and otherwise return #t. Mark H Weaver 2018-03-23gnu: le-certs: Use invoke....* gnu/packages/certs.scm (le-certs)[arguments]: Use invoke in the builder. Mark H Weaver 2018-03-23gnu: nss-certs: Use invoke....* gnu/packages/certs.scm (nss-certs)[arguments]: Use invoke to detect errors while running 'certdata2pem.py'. Mark H Weaver 2018-03-12gnu: nss, nss-certs: Update to 3.36....* gnu/packages/gnuzilla.scm (nss): Update to 3.36. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2018-02-20Merge branch 'master' into stagingMarius Bakke 2018-02-20gnu: nss-certs: Update phase style....* gnu/packages/certs.scm (nss-certs)[arguments]: Use MODIFY-PHASES syntax, substitute INVOKE for SYSTEM*, and end phas with #t. Tobias Geerinckx-Rice 2018-01-22gnu: nss-certs: Update to 3.35....* gnu/packages/certs.scm (nss-certs): Update to 3.35. Tobias Geerinckx-Rice 2017-12-02gnu: nss-certs: Update to 3.34.1....* gnu/packages/certs.scm (nss-certs): Update to 3.34.1. Tobias Geerinckx-Rice 2017-11-19gnu: nss, nss-certs: Update to 3.34....* gnu/packages/certs.scm (nss-certs): Update to 3.34. * gnu/packages/gnuzilla.scm (nss): Update to 3.34. Marius Bakke 2017-09-20gnu: nss, nss-certs: Update to 3.33....* gnu/packages/gnuzilla.scm (nss): Update to 3.33. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke