aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libunwind)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses))

(define-public libunwind
  (package
    (name "libunwind")
    (version "1.6.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://savannah/libunwind/libunwind-"
                                 version ".tar.gz"))
             (sha256
              (base32
               "0xj9g6a9q7v7zz6lymf3f6011synibgawi4wi384bywid5kfqsja"))))
    (build-system gnu-build-system)
    (arguments
     `(;; Two tests are failing with newer toolchains:
       ;; https://github.com/libunwind/libunwind/issues/363
       #:make-flags
       '("XFAIL_TESTS=run-coredump-unwind run-coredump-unwind-mdi")
       ;; A different collection of tests fails for each architecture.
       #:tests? ,(and (not (%current-target-system))
                      (target-x86-64?))))
    (home-page "https://www.nongnu.org/libunwind")
    (synopsis "Determining the call chain of a program")
    (description
     "The primary goal of this project is to define a portable and efficient C
programming interface (API) to determine the call-chain of a program.  The API
additionally provides the means to manipulate the preserved (callee-saved)
state of each call-frame and to resume execution at any point in the
call-chain (non-local goto).  The API supports both local (same-process) and
remote (across-process) operation.  As such, the API is useful in a number of
applications.")
    ;; Do not believe <https://savannah.nongnu.org/projects/libunwind/>:
    ;; see <https://github.com/libunwind/libunwind/issues/372>.
    (license expat)))
gnu: f3d: Update to 2.2.1....* gnu/packages/graphics.scm (f3d): Update to 2.2.1. [snippet]: Update paths to delete and remove substitutions. [arguments]<#:configure-flags>: Remove obsolete options, update renamed options and add -DF3D_EXTERNAL_CXXOPTS, -DF3D_EXTERNAL_NLOHMANN_JSON and -DF3D_MODULE_EXR. [phases]: Add 'fix-cmake-rpath' phase. [inputs]: Add openexr. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2023-10-09gnu: povray: Update to 3.7.0.10....* gnu/packages/graphics.scm (povray): Update to 3.7.0.10. [source]: Simplify snippet. Ricardo Wurmus 2023-10-09gnu: povray: Drop input labels....* gnu/packages/graphics.scm (povray)[inputs]: Remove all input labels. [arguments]: Use G-expression to avoid the use of %build-inputs. Ricardo Wurmus 2023-09-14gnu: nanosvg: Add a patch for PrusaSlicer 2.6....* gnu/packages/graphics.scm (nanosvg): Add a patch that is required to build PrusaSlicer 2.6. * gnu/packages/patches/nanosvg-prusa-slicer.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Artyom V. Poptsov 2023-09-08gnu: Add asli....* gnu/packages/graphics.scm (asli): New variable. * gnu/packages/patches/asli-use-system-libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2023-09-05gnu: skia: Update to 112.0.6d0b938....* gnu/packages/graphics.scm (skia): Update to 112.0.6d0b938. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2023-09-05gnu: skia: Update to 110.0.0f3fb7a....* gnu/packages/graphics.scm (skia): Update to 110.0.0f3fb7a. [arguments](build-phases): Disable newly introduced libraries wuffs (general performance) and perfetto (running performance tests). Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2023-09-04gnu: gr-framework: Update to 0.69.1....* gnu/packages/graphics.scm (gr-framework): Update to 0.69.1. Efraim Flashner 2023-09-02gnu: skia: Activate tests....* gnu/packages/graphics.scm (skia): Activate tests. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2023-08-15gnu: openscenegraph: Build with librsvg-for-system....* gnu/packages/graphics.scm (openscenegraph)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-07-18gnu: Deprecate `texlive-tiny'....At this point, there are three equivalent TeX Live sub-systems: texlive-scheme-basic, texlive-tiny, and (texlive-updmap.cfg). It is confusing to keep so many around. * doc/contributing.texi (Submitting Patches): Remove reference to TEXLIVE-TINY. * gnu/packages/algebra.scm (pari-gp)[native-inputs]: (giac)[native-inputs]: * gnu/packages/chez.scm (chez-sockets)[native-inputs]: * gnu/packages/engineering.scm (fastcap)[native-inputs]: * gnu/packages/gettext.scm (po4a)[native-inputs]: * gnu/packages/maths.scm (cddlib)[native-inputs]: (gnuplot)[native-inputs]: (itpp)[native-inputs]: * gnu/packages/ocaml.scm (unison)[native-inputs]: * gnu/packages/pdf.scm (extractpdfmark)[native-inputs]: * gnu/packages/photo.scm (enblend-enfuse): Replace TEXLIVE-TINY with a call to TEXLIVE-UPDMAP.CFG. * gnu/packages/radio.scm (gnuradio)[native-inputs]: Remove unnecessary TEXLIVE-TINY. * gnu/packages/tex.scm (texlive-tiny): Deprecate it in favor of TEXLIVE-SCHEME-BASIC. (texlive-makecmds)[native-inputs]: Replace TEXLIVE-TINY with a call to TEXLIVE-UPDMAP.CFG. * guix/lint.scm (check-inputs-should-be-native): Check only for "texlive-updmap.cfg" input name. Nicolas Goaziou 2023-07-09gnu: brdf-explorer: Mark up description....* gnu/packages/graphics.scm (brdf-explorer)[synopsis, description]: Use @acronym{}. Tobias Geerinckx-Rice 2023-07-09gnu: brdf-explorer: Use Web Archived home page....* gnu/packages/graphics.scm (brdf-explorer)[home-page]: Refer to Web Archive. Tobias Geerinckx-Rice 2023-07-09gnu: imath: Skip tests when cross-compiling....* gnu/packages/graphics.scm (imath)[arguments]: Adjust #:tests? to skip tests when cross-compiling. Efraim Flashner 2023-07-07gnu: Add nanosvg....* gnu/packages/graphics.scm (nanosvg): New variable. Maxim Cournoyer 2023-06-25gnu: mmg: Update to 5.7.1....* gnu/packages/graphics.scm (mmg): Update to 5.7.1. [arguments]<#:configure-flags>: Set -DCMAKE_INSTALL_MANDIR. Add -DBUILD_DOC=ON and -DUSE_SCOTCH=ON, the defaults of which changed since the last version. Scotch is still autodetected, but explicitly enabling it causes the configuration to fail if it is not found. <#:phases>: Do not copy the manual pages, because the build now does it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2023-06-18gnu: openmw-openscenegraph: Update to Nov 2022 commit....* gnu/packages/graphics.scm (openmw-openscenegraph): Update to Nov 2022 commit. [arguments]: Sync the plugin flags with the mentioned wiki page. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Kaelyn Takata 2023-06-12gnu: directfb: Fix building on armhf-linux....* gnu/packages/graphics.scm (directfb)[arguments]: Add a phase when building for armhf-linux to apply a patch. [native-inputs]: Add patch, patch file. * gnu/packages/patches/directfb-davinci-glibc-228-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner 2023-05-18gnu: f3d: Update to 2.0.0....* gnu/packages/graphics.scm (f3d): Update to 2.0.0. [source]: Update substitute paths and add patch for breaking change to cxxopts. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-05-18gnu: discregrid: Fix for dependent updates....* gnu/packages/graphics.scm (discregrid)[source]: Add patch for breaking change to cxxopts. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-05-14gnu: Rename json-modern-cxx to nlohmann-json....* gnu/packages/cpp.scm (nlohmann-json): New variable. (json-modern-cxx): Mark as deprecated alias. (xtl, jsonnet)[inputs]: Use nlohmann-json. * gnu/packages/build-tools.scm (bear)[inputs]: Likewise. * gnu/packages/cybersecurity.scm (blacksmith)[inputs]: Likewise. * gnu/packages/databases.scm (sqlitebrowser)[inputs]: Adjust comment. * gnu/packages/games.scm (openrct2)[inputs]: Use nlohmann-json. * gnu/packages/graphics.scm (f3d)[native-inputs]: Likewise. * gnu/packages/hardware.scm (openrgb)[inputs]: Likewise. [arguments]: Adjust accordingly. * gnu/packages/image-processing.scm (paraview)[inputs]: Adjust comment. * gnu/packages/irods.scm (irods, irods-client-icommands)[inputs]: Use nlohmann-json. * gnu/packages/jupyter.scm (xeus)[inputs]: Likewise. * gnu/packages/messaging.scm (mtxclient, nheko)[inputs]: Likewise. * gnu/packages/text-editors.scm (jucipp)[inputs]: Likewise. * gnu/packages/video.scm (mktoolnix)[inputs]: Likewise. * gnu/packages/xdisorg.scm (nwg-launchers)[inputs]: Likewise. Liliana Marie Prikler 2023-04-23gnu: OpenImageIO: Use the correct source hash....This is a followup to commit 5fda088fb17f0f5ad5cbb47314bada5f25afdb68 * gnu/packages/graphics.scm (openimageio)[source]: Fix the hash. Leo Famulari 2023-04-23gnu: OpenImageIO: Update to 2.2.21.0....This fixes the build with GCC 11. * gnu/packages/graphics.scm (openimageio): Update to 2.2.21.0. Leo Famulari 2023-04-22gnu: embree: Update to 3.13.5....* gnu/packages/graphics.scm (embree): Update to 3.13.5. Guillaume Le Vaillant 2023-04-19gnu: openmw-scenegraph: Fix build....* gnu/packages/graphics.scm (openmw-scenegraph)[outputs]: Only use 'out' output. [arguments]: Delete inherited 'copy-plugins phase. Efraim Flashner 2023-04-19gnu: python-fonttools-full: Rename to python-fonttools....* gnu/packages/python-xyz.scm (python-fonttools): Rename to... (python-fonttools-minimal): ... this. (python-fonttools-full): Adjust references to base package. Rename to... (python-fonttools): ... this. (python-matplotlib): * gnu/packages/fontutils.scm (python-cu2qu) [propagated-inputs]: Rename python-fonttools-full to python-fonttools. (python-ufolib2, python-defcon-bootstrap): Likewise. * gnu/packages/pdf.scm (weasyprint): Likewise. * gnu/packages/fonts.scm (font-meera-inimai) Adjust for renamed python-fonttools-minimal. * gnu/packages/fontutils.scm (python-cffsubr): Likewise. (python-compreffor, python-cu2qu, python-fontmath, python-fontpens-bootstrap) (python-fontparts-bootstrap, python-glyphsets, python-mutatormath) (python-ufoprocessor, graphite2, python-ufolib2) (python-defcon-bootstrap): Likewise. * gnu/packages/graphics.scm (python-booleanoperations): Likewise. Maxim Cournoyer 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-03-31gnu: blender: Update to 3.3.5....* gnu/packages/graphics.scm (blender): Update to 3.3.5. Maxim Cournoyer 2023-03-31gnu: blender: Use ffmpeg 5....* gnu/packages/graphics.scm (blender) [inputs]: Replace ffmpeg with ffmpeg-5. Maxim Cournoyer 2023-03-31gnu: blender: Use gexps and remove labels....* gnu/packages/graphics.scm (blender) [arguments]: Use gexps. Replace the add-ilmbase-include-path phase by an added -I directive to the CMAKE_CXX_FLAGS configure flag. [inputs]: Remove labels. Maxim Cournoyer