aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libunistring)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages base))

(define-public libunistring
  (package
   (name "libunistring")
   (version "1.1")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "mirror://gnu/libunistring/libunistring-"
                  version ".tar.xz"))
            (sha256
             (base32
              "164vfbh3sf0qjcimjbnz4icqr9cai30dli8p2y5p6z3frfwiwz42"))))
   (propagated-inputs (libiconv-if-needed))
   (outputs '("out" "static"))
   (build-system gnu-build-system)
   (arguments
    ;; Work around parallel build issue whereby C files may be compiled before
    ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
    ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
    (list
      #:parallel-build? #f
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'install 'move-static-library
            (lambda* (#:key outputs #:allow-other-keys)
              (with-directory-excursion (string-append #$output "/lib")
                (install-file "libunistring.a"
                              (string-append #$output:static "/lib"))
                (delete-file "libunistring.a")))))))
   (synopsis "C library for manipulating Unicode strings")
   (description
    "GNU libunistring is a library providing functions to manipulate
Unicode strings and for manipulating C strings according to the Unicode
standard.")
   (home-page "https://www.gnu.org/software/libunistring/")
   (license (list lgpl3+ gpl2+))))
b1ac304c930c9311ce923'>gnu: imath: Skip tests when cross-compiling....* gnu/packages/graphics.scm (imath)[arguments]: Adjust #:tests? to skip tests when cross-compiling. Efraim Flashner 2023-07-07gnu: Add nanosvg....* gnu/packages/graphics.scm (nanosvg): New variable. Maxim Cournoyer 2023-06-25gnu: mmg: Update to 5.7.1....* gnu/packages/graphics.scm (mmg): Update to 5.7.1. [arguments]<#:configure-flags>: Set -DCMAKE_INSTALL_MANDIR. Add -DBUILD_DOC=ON and -DUSE_SCOTCH=ON, the defaults of which changed since the last version. Scotch is still autodetected, but explicitly enabling it causes the configuration to fail if it is not found. <#:phases>: Do not copy the manual pages, because the build now does it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2023-06-18gnu: openmw-openscenegraph: Update to Nov 2022 commit....* gnu/packages/graphics.scm (openmw-openscenegraph): Update to Nov 2022 commit. [arguments]: Sync the plugin flags with the mentioned wiki page. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Kaelyn Takata 2023-06-12gnu: directfb: Fix building on armhf-linux....* gnu/packages/graphics.scm (directfb)[arguments]: Add a phase when building for armhf-linux to apply a patch. [native-inputs]: Add patch, patch file. * gnu/packages/patches/directfb-davinci-glibc-228-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner 2023-05-18gnu: f3d: Update to 2.0.0....* gnu/packages/graphics.scm (f3d): Update to 2.0.0. [source]: Update substitute paths and add patch for breaking change to cxxopts. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-05-18gnu: discregrid: Fix for dependent updates....* gnu/packages/graphics.scm (discregrid)[source]: Add patch for breaking change to cxxopts. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-05-14gnu: Rename json-modern-cxx to nlohmann-json....* gnu/packages/cpp.scm (nlohmann-json): New variable. (json-modern-cxx): Mark as deprecated alias. (xtl, jsonnet)[inputs]: Use nlohmann-json. * gnu/packages/build-tools.scm (bear)[inputs]: Likewise. * gnu/packages/cybersecurity.scm (blacksmith)[inputs]: Likewise. * gnu/packages/databases.scm (sqlitebrowser)[inputs]: Adjust comment. * gnu/packages/games.scm (openrct2)[inputs]: Use nlohmann-json. * gnu/packages/graphics.scm (f3d)[native-inputs]: Likewise. * gnu/packages/hardware.scm (openrgb)[inputs]: Likewise. [arguments]: Adjust accordingly. * gnu/packages/image-processing.scm (paraview)[inputs]: Adjust comment. * gnu/packages/irods.scm (irods, irods-client-icommands)[inputs]: Use nlohmann-json. * gnu/packages/jupyter.scm (xeus)[inputs]: Likewise. * gnu/packages/messaging.scm (mtxclient, nheko)[inputs]: Likewise. * gnu/packages/text-editors.scm (jucipp)[inputs]: Likewise. * gnu/packages/video.scm (mktoolnix)[inputs]: Likewise. * gnu/packages/xdisorg.scm (nwg-launchers)[inputs]: Likewise. Liliana Marie Prikler