aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libunistring)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages base))

(define-public libunistring
  (package
   (name "libunistring")
   (version "1.1")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "mirror://gnu/libunistring/libunistring-"
                  version ".tar.xz"))
            (sha256
             (base32
              "164vfbh3sf0qjcimjbnz4icqr9cai30dli8p2y5p6z3frfwiwz42"))))
   (propagated-inputs (libiconv-if-needed))
   (outputs '("out" "static"))
   (build-system gnu-build-system)
   (arguments
    ;; Work around parallel build issue whereby C files may be compiled before
    ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
    ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
    (list
      #:parallel-build? #f
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'install 'move-static-library
            (lambda* (#:key outputs #:allow-other-keys)
              (with-directory-excursion (string-append #$output "/lib")
                (install-file "libunistring.a"
                              (string-append #$output:static "/lib"))
                (delete-file "libunistring.a")))))))
   (synopsis "C library for manipulating Unicode strings")
   (description
    "GNU libunistring is a library providing functions to manipulate
Unicode strings and for manipulating C strings according to the Unicode
standard.")
   (home-page "https://www.gnu.org/software/libunistring/")
   (license (list lgpl3+ gpl2+))))
to 3.4.2....* gnu/packages/bison.scm (bison): Update to 3.4.2. Efraim Flashner 2019-09-30gnu: xyce: Use Bison 3.0....Xyce requires Bison 3.0 at the latest. * gnu/packages/bison.scm (bison-3.0): New variable. * gnu/packages/engineering.scm (xyce-serial)[native-inputs]: Use BISON-3.0 instead of BISON. Ludovic Courtès 2019-06-17gnu: bison: Disable parallel tests, too....* gnu/packages/bison.scm (bison)[arguments]: Add #:parallel-tests?. Marius Bakke 2019-06-16gnu: bison: Disable parallel build....Fixes <https://bugs.gnu.org/36238. Reported by Carl Dong <contact@carldong.me>. * gnu/packages/bison.scm (bison)[arguments]: New field. Marius Bakke 2019-05-25gnu: bison: Update to 3.4.1....* gnu/packages/bison.scm (bison): Update to 3.4.1. Marius Bakke 2019-02-07gnu: bison: Update to 3.3.2....* gnu/packages/bison.scm (bison): Update to 3.3.2. Marius Bakke 2019-01-07gnu: bison: Update to 3.2.4....* gnu/packages/bison.scm (bison): Update to 3.2.4. Efraim Flashner 2018-12-11gnu: bison: Update to 3.2.2....* gnu/packages/bison.scm (bison): Update to 3.2.2. Marius Bakke 2018-08-25gnu: Remove bison@2.7....* gnu/packages/bison.scm (bison-2.7): Remove variable. Marius Bakke 2018-06-12gnu: bison: Update to 3.0.5....* gnu/packages/bison.scm (bison): Update to 3.0.5. Tobias Geerinckx-Rice 2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....All HTTP gnu.org (and supported subdomain) HOME-PAGEs changed to HTTPS. Tobias Geerinckx-Rice