aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libunistring)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages base))

(define-public libunistring
  (package
   (name "libunistring")
   (version "1.1")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "mirror://gnu/libunistring/libunistring-"
                  version ".tar.xz"))
            (sha256
             (base32
              "164vfbh3sf0qjcimjbnz4icqr9cai30dli8p2y5p6z3frfwiwz42"))))
   (propagated-inputs (libiconv-if-needed))
   (outputs '("out" "static"))
   (build-system gnu-build-system)
   (arguments
    ;; Work around parallel build issue whereby C files may be compiled before
    ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
    ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
    (list
      #:parallel-build? #f
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'install 'move-static-library
            (lambda* (#:key outputs #:allow-other-keys)
              (with-directory-excursion (string-append #$output "/lib")
                (install-file "libunistring.a"
                              (string-append #$output:static "/lib"))
                (delete-file "libunistring.a")))))))
   (synopsis "C library for manipulating Unicode strings")
   (description
    "GNU libunistring is a library providing functions to manipulate
Unicode strings and for manipulating C strings according to the Unicode
standard.")
   (home-page "https://www.gnu.org/software/libunistring/")
   (license (list lgpl3+ gpl2+))))
: Update upstream location....* gnu/packages/password-utils.scm (pass-rotate)[source]: Update to new source uri. [home-page]: Update to new home-page. Efraim Flashner 2020-01-22gnu: pass-rotate: Don't use unstable tarball....* gnu/packages/password-utils.scm (pass-rotate)[source]: Download using git-fetch. Reflow section. Efraim Flashner 2020-01-15gnu: keepassxc: Update to 2.5.2....* gnu/packages/password-utils.scm (keepassxc): Update to 2.5.2. Tobias Geerinckx-Rice 2019-12-28gnu: password-store: Make search path single-entry....* gnu/packages/password-utils.scm (password-store)[native-search-paths]: Add separator #f to search path specification. Alex Griffin 2019-12-01gnu: yapet: Update to 2.3....* gnu/packages/password-utils.scm (yapet): Update to 2.3. [inputs]: Add argon2. [native-inputs]: Add cppunit. Tobias Geerinckx-Rice 2019-11-22gnu: libpwquality: Update to 1.4.2....* gnu/packages/password-utils.scm (libpwquality): Update to 1.4.2. Tobias Geerinckx-Rice 2019-11-22gnu: libpwquality: Don't use NAME in source URI....* gnu/packages/password-utils.scm (libpwquality)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-11-16gnu: keepassxc: Update to 2.5.1....* gnu/packages/password-utils.scm (keepassxc): Update to 2.5.1. Efraim Flashner 2019-11-08gnu: packages: Add rofi-pass....* gnu/packages/password-utils.scm (rofi-pass): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com> Tanguy Le Carrour 2019-11-07gnu: john-the-ripper-jumbo: Enable tests....* gnu/packages/password-utils.scm (john-the-ripper-jumbo)[arguments]: Remove '#:tests? #f'. Add 'check' phase after 'install'. Eric Bavier 2019-11-07gnu: john-the-ripper-jumbo: Update to 1.9.0....* gnu/packages/password-utils.scm (john-the-ripper-jumbo): Update to 1.9.0. [source]: Remove patches. [native-inputs]: New field. [inputs]: Add python and ruby for script shebangs. Remove unused mit-krb5. [arguments]: In #:configure-flags use new "--with-systemwide" flag, fix typo in "--disable-native-macro", and pass "--enable-simd=..." based on system. Rename local "homedir" variable to "datadir" for clarity. Return #t from 'chdir-src phase. Create extension-less symlinks for many scripts in 'install phase. Eric Bavier 2019-10-27gnu: keepassxc: Don't use NAME in source URI....* gnu/packages/password-utils.scm (keepassxc)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-10-27gnu: keepassxc: Update to 2.5.0....* gnu/packages/password-utils.scm (keepassxc): Update to 2.5.0. [arguments]: Enable all extra features, except for update checking. [inputs]: Add libyubikey, quazip, readline, yubikey-personalization. Remove curl. [license]: Update comment. Efraim Flashner 2019-10-15gnu: pwsafe: Move googletest to native-inputs....* gnu/packages/password-utils.scm (pwsafe)[inputs]: Move googletest ... [native-inputs]: ... to here. Efraim Flashner 2019-10-15gnu: pwsafe: Update to 3.5.0...* gnu/packages/password-utils.scm (pwsafe): Update to 3.5.0. [source]: Use git-file-name. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Tim Gesthuizen 2019-08-29Merge branch 'master' into core-updatesMark H Weaver 2019-08-25gnu: shroud: Update to 0.1.2....* gnu/packages/password-utils.scm (shroud): Update to 0.1.2. Shroud now builds with Guile-2.2. Remove hardcoded '2.0' string. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Amar Singh 2019-07-19gnu: john-the-ripper-jumbo: Build against OpenSSL 1.0....* gnu/packages/password-utils.scm (john-the-ripper-jumbo): Change OPENSSL to OPENSSL-1.0. Rutger Helling 2019-07-04gnu: Add qtpass....* gnu/packages/password-utils.scm (qtpass): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jens Mølgaard 2019-06-16gnu: keepassxc: Update to 2.4.3....* gnu/packages/password-utils.scm (keepassxc): Update to 2.4.3. Efraim Flashner 2019-06-03gnu: cracklib: Install password dictionary....* gnu/packages/password-utils.scm (cracklib): Use `make dict`. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Florian Pelz 2019-06-02gnu: keepassxc: Update to 2.4.2....* gnu/packages/password-utils.scm (keepassxc): Update to 2.4.2. Nicolas Goaziou 2019-05-23gnu: keepassxc: Update to 2.4.1....* gnu/packages/password-utils.scm (keepassxc): Update to 2.4.1. [arguments]: Disable update checking. [inputs]: Add qrencode and qtsvg. Nicolas Goaziou 2019-04-22gnu: Add pass-otp....* gnu/packages/password-utils.scm (pass-otp): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Alex Griffin 2019-04-22gnu: password-store: Allow external packages to provide extensions....* gnu/packages/password-utils.scm (password-store): Add mechanism for providing pass extensions in separate packages. [arguments]: Add patch-system-extension-dir phase. [native-search-paths]: Add PASSWORD_STORE_SYSTEM_EXTENSION_DIR. Signed-off-by: Christopher Baines <mail@cbaines.net> Alex Griffin 2019-04-04gnu: Move nss & co. to nss.scm....* gnu/packages/gnuzilla.scm (nspr, nss): Move to... * gnu/packages/nss.scm: ... here. New file. * gnu/packages/chromium.scm, gnu/packages/disk.scm, gnu/packages/freedesktop.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/java.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/mate.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/password-utils.scm, gnu/packages/polkit.scm, gnu/packages/qt.scm, gnu/packages/sssd.scm, gnu/packages/storage.scm, gnu/packages/vpn.scm, gnu/packages/web.scm, gnu/packages/xml.scm: Adjust accordingly. * gnu/local.mk (GNU_SYSTEM_MODULES): Add nss.scm. Ludovic Courtès