aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libsigsegv)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu))

(define-public libsigsegv
  (package
   (name "libsigsegv")
   (version "2.14")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "mirror://gnu/libsigsegv/libsigsegv-"
                  version ".tar.gz"))
            (sha256
             (base32 "15d2r831xz94s7540nvb1gbfl062g7mrnj88m60wyr1kh10kkb6d"))))
   (build-system gnu-build-system)
   (home-page "https://www.gnu.org/software/libsigsegv/")
   (synopsis "Library for handling page faults")
   (arguments
    `(;; The shared library isn't built by default but some packages need it.
      #:configure-flags '("--enable-shared")
      ;; On some architectures 'struct sigcontext' gets redefined from
      ;; %linux-libre-headers/include/asm/sigcontext.h
      ,@(cond ((%current-target-system)
               `(#:phases (modify-phases %standard-phases
                            (add-before 'configure 'patch-asm-sigcontext-h
                              (lambda _
                                (substitute* (find-files "src" "^fault-.*-old\\.h$")
                                  (("#include <asm/sigcontext\\.h>") "")))))))
              (else '()))))
   (description
    "GNU libsigsegv is a library to handle page faults, which occur when a
program tries to access an unavailable region of memory, in user mode.  By
catching and handling page faults, the program can implement pageable virtual
memory, stack overflow handlers, and so on.")
   (license gpl2+)))
/a>...Leo Famulari 2021-02-04gnu: guile-cairo: Update to 1.11.2....Ludovic Courtès 2021-01-10Merge branch 'master' into stagingEfraim Flashner 2021-01-03gnu: guile-rsvg: Compile Scheme files....Ricardo Wurmus 2021-01-03gnu: guile-cairo: Compile Scheme sources....Ricardo Wurmus 2020-12-29Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-29Merge branch 'master' into ungraftingMarius Bakke 2020-12-27gnu: gtksheet: Update to 4.3.5....Ricardo Wurmus 2020-12-13gnu: GTK+: Update to 3.24.24....Marius Bakke 2020-12-10gnu: pango@1.42: Disable layout test....Marius Bakke 2020-11-26Merge branch 'master' into stagingMarius Bakke 2020-11-25gnu: perl-cairo: Update to 1.108....Tobias Geerinckx-Rice 2020-11-07Merge branch 'master' into staging...Marius Bakke 2020-10-20gnu: poppler: Always use the same 'cairo-sans-poppler' variant....Ludovic Courtès 2020-10-19Merge branch 'master' into stagingMarius Bakke 2020-10-16gnu: spread-sheet-widget: Update to 0.7....Tobias Geerinckx-Rice 2020-10-13gnu: GTK+: Update to 3.24.3....Marius Bakke 2020-10-05Merge branch 'master' into stagingGuillaume Le Vaillant 2020-10-05gnu: libsigc++: Remove duplicate definition....Efraim Flashner 2020-09-05Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner 2020-09-01gnu: guile-cairo: Update to 1.11.1....Efraim Flashner 2020-08-29gnu: libdatrie: Update to 0.2.12....Tobias Geerinckx-Rice 2020-08-19gnu: graphene: Update package definition....Raghav Gururajan 2020-08-18gnu: Add pangomm-2.42....Raghav Gururajan 2020-08-18gnu: Add cairomm-1.13....Raghav Gururajan 2020-08-18gnu: Add libthai....Raghav Gururajan 2020-08-18gnu: Add libdatrie....Raghav Gururajan 2020-08-16gnu: spread-sheet-widget: Update to 0.6....Efraim Flashner 2020-07-30gnu: spread-sheet-widget: Update to 0.5....Tobias Geerinckx-Rice 2020-07-25gnu: check: Update to 0.15.1....Marius Bakke 2020-07-25gnu: GTK+: Update to 3.24.21....Marius Bakke 2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Ludovic Courtès 2020-06-11Merge branch 'master' into stagingMarius Bakke