aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libsigsegv)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu))

(define-public libsigsegv
  (package
   (name "libsigsegv")
   (version "2.14")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "mirror://gnu/libsigsegv/libsigsegv-"
                  version ".tar.gz"))
            (sha256
             (base32 "15d2r831xz94s7540nvb1gbfl062g7mrnj88m60wyr1kh10kkb6d"))))
   (build-system gnu-build-system)
   (home-page "https://www.gnu.org/software/libsigsegv/")
   (synopsis "Library for handling page faults")
   (arguments
    `(;; The shared library isn't built by default but some packages need it.
      #:configure-flags '("--enable-shared")
      ;; On some architectures 'struct sigcontext' gets redefined from
      ;; %linux-libre-headers/include/asm/sigcontext.h
      ,@(cond ((%current-target-system)
               `(#:phases (modify-phases %standard-phases
                            (add-before 'configure 'patch-asm-sigcontext-h
                              (lambda _
                                (substitute* (find-files "src" "^fault-.*-old\\.h$")
                                  (("#include <asm/sigcontext\\.h>") "")))))))
              (else '()))))
   (description
    "GNU libsigsegv is a library to handle page faults, which occur when a
program tries to access an unavailable region of memory, in user mode.  By
catching and handling page faults, the program can implement pageable virtual
memory, stack overflow handlers, and so on.")
   (license gpl2+)))
FIG argument instead of two separate SERVICES and SHEPHERD, respect DAEMONIZE?. (ensure-shepherd-gexp, launch-shepherd-gexp, shepherd-xdg-configuration-files): Adjust according to arguments changes in HOME-SHEPHERD-CONFIGURATION-FILE. Andrew Tropin 2022-09-12home: shepherd: Add shepherd/init.scm to XDG_CONFIG_HOME....* gnu/home/services/shepherd.scm (shepherd-xdg-configuration-files): New variable. (home-shepherd-service-type)[extensions]: Add HOME-XDG-CONFIGURATION-FILES-SERVICE-TYPE extension. Andrew Tropin del tool. [inputs]: Add cpuinfo, eigen, fp16, mesa-header, opencl, pthreadpool, ruy, vulkan and xnnpack as explicit inputs. [native-inputs]: Remove local setup of neon2ssl and ruy as we now use Guix's packages of these as explicit dependencies. * gnu/packages/serialization.scm (flatbuffers-next-shared): New variable, flatbuffers-next built with -fPIC as needed by tensorflow-lite. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Andy Tai 2023-09-07gnu: Add python-fasttext....* gnu/packages/machine-learning.scm (python-fasttext): New variable. Ricardo Wurmus 2023-09-07gnu: Add fasttext....* gnu/packages/machine-learning.scm (fasttext): New variable. Ricardo Wurmus 2023-09-02gnu: python-deepxde: Update to 1.9.3....* gnu/packages/machine-learning.scm (python-deepxde): Update to 1.9.3. Vinicius Monego 2023-08-27gnu: gemmlowp: Update to 0.1-1.08e4bb3....* gnu/packages/machine-learning.scm (gemmlowp): Update to 0.1-1.08e4bb3. Signed-off-by: Christopher Baines <mail@cbaines.net> Andy Tai 2023-08-15gnu: llama-cpp: Update to 0.0.0-0.f31b539....* gnu/packages/machine-learning.scm (llama-cpp): Update to 0.0.0-0.f31b539. [#:phases](install-python-scripts): Adapt python scripts. (install): Remove deleted quantize script installation. Co-authored-by: Andy Tai <atai@atai.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org> Nicolas Graves 2023-08-12gnu: python-pyro-ppl: Update to 1.8.6....* gnu/packages/machine-learning.scm (python-pyro-ppl): Update to 1.8.6. Vinicius Monego 2023-07-29gnu: Add python-deepxde....* gnu/packages/machine-learning.scm (python-deepxde): New variable. Vinicius Monego 2023-07-16gnu: rxcpp: Update to 4.1.1....* gnu/packages/machine-learning.scm (rxcpp): Update to 4.1.1. Tobias Geerinckx-Rice 2023-07-10gnu: Add python-captum....* gnu/packages/machine-learning.scm (python-captum): New variable. Ricardo Wurmus 2023-07-07gnu: Add python-tslearn....* gnu/packages/machine-learning.scm (python-tslearn): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>. Navid Afkhami 2023-06-29gnu: python-threadpoolctl: Update to 3.1.0....* gnu/packages/machine-learning.scm (python-threadpoolctl): Update to 3.1.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. [native-inputs]: Add python-flit-core. Ricardo Wurmus 2023-06-25gnu: oneapi-dnnl: Fix building on riscv64-linux....'CMake Error at src/cpu/rv64/CMakeLists.txt:36 (message): Only sequential runtime is now supported for a RISC-V CPU'. * gnu/packages/machine-learning.scm (oneapi-dnnl)[arguments]: Adjust configure-flags when building for riscv64-linux to fix build. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Z572 2023-06-20gnu: python-keras: Update to 2.3.1....* gnu/packages/patches/python-keras-integration-test.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/machine-learning.scm (python-keras): Update to 2.3.1. [source]: Remove patch; update snippet. [arguments]: Add build phase 'tf-compatibility; add phase 'hdf5-compatibility; rename phase 'remove-tests-for-unavailable-features to 'delete-unavailable-backends; update 'check phase to disable tests that cannot be repaired or are flaky. [native-inputs]: Add python-flaky, python-markdown, and python-pyux. Ricardo Wurmus 2023-06-20gnu: tensorflow: Patch one more instance of "collections"....* gnu/packages/machine-learning.scm (tensorflow)[arguments]: Add one more patch of "collections" to "collections.abc" to the 'python3.10-compatibility phase. Ricardo Wurmus 2023-06-20gnu: tensorflow: Drop trailing #T from build phase....* gnu/packages/machine-learning.scm (tensorflow)[arguments]: Remove #T from 'set-source-file-times-to-1980 phase. Ricardo Wurmus 2023-06-20gnu: tensorflow: Patch for numpy >= 1.23....* gnu/packages/machine-learning.scm (tensorflow)[arguments]: Remove np.asscalar in 'python3.10-compatibility phase. Ricardo Wurmus 2023-06-20gnu: tensorflow: Drop package labels from propagated-inputs....* gnu/packages/machine-learning.scm (tensorflow)[propagated-inputs]: Drop labels. Ricardo Wurmus 2023-06-14gnu: python-keras: Fix building with newer python....* gnu/packages/machine-learning.scm (python-keras)[source]: Add snippet to adjust for newer versions of python. Efraim Flashner 2023-06-11svn-download: Do not expand keywords....Subversion keyword expansion is potentially non-reproducible as some of them expand time strings relative to the local time zone: https://issues.guix.gnu.org/43442#18 In practice this is not a problem in Guix since Subversion checkouts happen in an isolated environment using the "default timezone" (UTC). However, Software Heritage disables keyword expansion for this very reason. By following suit, we make sure content can be retrieved from there. * guix/build/svn.scm (svn-fecth): Pass "--ignore-keywords" to Subversion. * guix/build-system/texlive.scm (%texlive-date): New variable. * gnu/packages/java.scm (java-geronimo-xbean-reflect) (java-geronimo-genesis-2.1): Update the source hash. * gnu/packages/machine-learning.scm (ghmm): Likewise. * gnu/packages/video.scm (libsmpeg, libsmpeg-with-sdl1): Likewise. * gnu/packages/tex.scm (texlive-bin): Update the hash of the "texlive-scripts" input, and a add a new phase that imitates Subversion keyword expansion for scripts that need it. (texlive-latex-base): Update the hash of the "texlive-luatexconfig" native input. (texlive-hyphen-base, texlive-dvipdfmx, texlive-dvips, texlive-cm) (texlive-tex-plain, texlive-kpathsea, texlive-latexconfig) (texlive-tetex, texlive-pdftex, texlive-xetex): Update the source hash. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Timothy Sample 2023-06-09gnu: Add python-sacrebleu....* gnu/packages/machine-learning.scm (python-sacrebleu): New variable. Ricardo Wurmus 2023-06-08gnu: Add python-spacy....* gnu/packages/machine-learning.scm (python-spacy): New variable. Ricardo Wurmus 2023-06-08gnu: Add python-thinc....* gnu/packages/machine-learning.scm (python-thinc): New variable. Ricardo Wurmus 2023-06-08gnu: Add python-spacy-loggers....* gnu/packages/machine-learning.scm (python-spacy-loggers): New variable. Ricardo Wurmus 2023-06-08gnu: Add python-spacy-legacy....* gnu/packages/machine-learning.scm (python-spacy-legacy): New variable. Ricardo Wurmus 2023-06-02gnu: Add r-rcppml/devel....* gnu/packages/machine-learning.scm (r-rcppml/devel): New variable. Ricardo Wurmus 2023-05-25gnu: Add python-tensorly....* gnu/packages/machine-learning.scm (python-tensorly): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net> Navid Afkhami 2023-05-25gnu: python-vosk: Update for Python 3.10....* gnu/packages/machine-learning.scm (python-vosk)[arguments]: Replace 3.9 with 3.10. Ricardo Wurmus 2023-05-25gnu: kaldi-for-vosk: Update to 0-0.a25f216....* gnu/packages/machine-learning.scm (kaldi-for-vosk): Update to 0-0.a25f216. [inputs]: Replace jack-1 with jack-2. [arguments]: Disable cu-array-test. Ricardo Wurmus 2023-05-25gnu: kaldi-for-vosk: Adjust style....* gnu/packages/machine-learning.scm (kaldi-for-vosk)[inputs]: Remove spurious semicolon. [arguments]: Use LIST instead of double quoting; replace LET* with LET; adjust indentation. Ricardo Wurmus 2023-05-14gnu: python-cmaes: Update to 0.9.1....* gnu/packages/machine-learning.scm (python-cmaes): Update to 0.9.1. [source, home-page]: Follow redirect. [build-system]: Switch to pyproject-build-system. [native-inputs]: Remove python-setuptools, python-wheel. Vinicius Monego 2023-05-14gnu: python-opentsne: Update to 0.7.1....* gnu/packages/machine-learning.scm (python-opentsne): Update to 0.7.1. Vinicius Monego 2023-05-12gnu: python-lightning-cloud: Use older version of fastapi....The variant of the fastapi package must match that of python-pytorch-lightning. * gnu/packages/machine-learning.scm (python-lightning-cloud) [propagated-inputs]: Replace python-fastapi with python-fastapi-for-pytorch-lightning. Ricardo Wurmus