aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libphidget)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages libusb))

(define-public libphidget
  (package
   (name "libphidget")
   (version "2.1.9.20190409")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "https://www.phidgets.com/downloads/phidget21/libraries/"
                  "linux/libphidget/libphidget_"
                  version ".tar.gz"))
            (sha256
             (base32 "07w54dmr75vq2imngfy66nk1sxlvkzhl2p6g362q0a02f099jy0f"))))
   (build-system gnu-build-system)
   (inputs (list libusb))
   (outputs '("out" "debug"))
   (home-page "https://www.phidgets.com/")
   (license lgpl3+)
   (synopsis "C library to manipulate Phidgets")
   (description synopsis)))
nx)[propagated-inputs]: Change from PYTHON2-DOCUTILS to PYTHON2-DOCUTILS-0.14. Marius Bakke 2020-03-09gnu: python-sphinxcontrib-websupport: Update to 1.2.0....* gnu/packages/sphinx.scm (python-sphinxcontrib-websupport): Update to 1.2.0. Tobias Geerinckx-Rice 2020-03-09gnu: python-sphinxcontrib-serializinghtml: Update to 1.1.4....* gnu/packages/sphinx.scm (python-sphinxcontrib-serializinghtml): Update to 1.1.4. Tobias Geerinckx-Rice 2020-03-09gnu: python-sphinxcontrib-qthelp: Update to 1.0.3....* gnu/packages/sphinx.scm (python-sphinxcontrib-qthelp): Update to 1.0.3. Tobias Geerinckx-Rice 2020-03-09gnu: python-sphinxcontrib-htmlhelp: Update to 1.0.3....* gnu/packages/sphinx.scm (python-sphinxcontrib-htmlhelp): Update to 1.0.3. Tobias Geerinckx-Rice 2020-03-09gnu: python-sphinxcontrib-devhelp: Update to 1.0.2....* gnu/packages/sphinx.scm (python-sphinxcontrib-devhelp): Update to 1.0.2. Tobias Geerinckx-Rice 2020-03-09gnu: python-sphinxcontrib-applehelp: Update to 1.0.2....* gnu/packages/sphinx.scm (python-sphinxcontrib-applehelp): Update to 1.0.2. Tobias Geerinckx-Rice 2020-03-01gnu: python-sphinx: Use HTTPS home page....* gnu/packages/sphinx.scm (python-sphinx)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2019-12-23gnu: python-sphinxcontrib-svg2pdfconverter: Fix license....* gnu/packages/sphinx.scm (python-sphinxcontrib-svg2pdfconverter)[license]: Change to BSD-2. Brett Gilio 2019-12-23gnu: python-sphinxcontrib-svg2pdfconverter: Reflow description....* gnu/packages/sphinx.scm (python-sphinxcontrib-svg2pdfconverter)[description]: Reflow description to fit 80-char width. Brett Gilio 2019-12-23gnu: python-sphinxcontrib-svg2pdfconverter: Fix home-page....* gnu/packages/sphinx.scm (python-sphinxcontrib-svg2pdfconverter)[home-page]: Do not use releases page for home-page URL. Brett Gilio 2019-12-23gnu: python-sphinxcontrib-svg2pdfconverter: Update to 1.0.1....* gnu/packages/sphinx.scm (python-sphinxcontrib-svg2pdfconverter): Update to 1.0.1. Brett Gilio 2019-12-23gnu: python-sphinxcontrib-programoutput: Fix home-page....* gnu/packages/sphinx.scm (python-sphinxcontrib-programoutput)[home-page]: Use the most recent Github URL. Brett Gilio 2019-12-23gnu: python-sphinxcontrib-programoutput: Update to 0.15....* gnu/packages/sphinx.scm (python-sphinxcontrib-programoutput): Update to 0.15. Brett Gilio 2019-12-23gnu: python-sphinxcontrib-jsmath: Fix license....* gnu/packages/sphinx.scm (python-sphinxcontrib-jsmath): Change to BSD-2. Brett Gilio 2019-12-23gnu: python-sphinx-copybutton: Update to 0.2.6....* gnu/packages/sphinx.scm (python-sphinx-copybutton): Update to 0.2.6. [arguments]: Disable tests. [propagated-inputs]: Add python-flit, python-setuptools, python-sphinx, python-wheel. Brett Gilio 2019-12-23gnu: python-sphinx: Fix license....* gnu/packages/sphinx.scm (python-sphinx)[license]: Change to BSD-2. Brett Gilio 2019-12-23gnu: python-sphinx: Use HTTP URI....* gnu/packages/sphinx.scm (python-sphinx)[home-page]: Use HTTP, HTTPS is not supported. Brett Gilio 2019-12-23gnu: python-sphinx: Alphabetize inputs....* gnu/packages/sphinx.scm (python-sphinx)[propagated-inputs]: Alphabetize. Brett Gilio 2019-12-23gnu: python-sphinx: Update to 2.3.1....* gnu/packages/sphinx.scm (python-sphinx): Update to 2.3.1. Brett Gilio 2019-12-15gnu: Add python-sphinx-intl...* gnu/packages/sphinx.scm (python-sphinx-intl): New variable. Signed-off-by: Brett Gilio <brettg@posteo.net> Alexandros Theodotou 2019-11-15Merge branch 'master' into stagingMarius Bakke 2019-11-13gnu: python-sphinx-gallery: Don't use unstable tarball....* gnu/packages/sphinx.scm (python-sphinx-gallery)[source]: Download using git-fetch. Efraim Flashner 2019-11-11gnu: Add python-breathe....* gnu/packages/sphinx.scm (python-breathe): New package. 宋文武 2019-10-12gnu: python-sphinx: Update to 2.2.0....* gnu/packages/sphinx.scm (python-sphinx): Update to 2.2.0. Marius Bakke 2019-09-23gnu: python-sphinxcontrib-htmlhelp: Fix typo....* gnu/packages/sphinx (python-sphinxcontrib-htmlhelp)[synopsis]: Fix spelling of "extension". Vagrant Cascadian 2019-09-13gnu: Add python-sphinx-copybutton....* gnu/packages/sphinx.scm (python-sphinx-copybutton): New variable. Ricardo Wurmus 2019-06-20gnu: python-sphinx: Update to 2.1.2....* gnu/packages/sphinx.scm (python-sphinx): Update to 2.1.2. Marius Bakke 2019-06-20Merge branch 'master' into stagingMarius Bakke 2019-06-20gnu: Use HTTPS for sphinx-doc.org....* gnu/packages/sphinx.scm (python-sphinx, python-sphinxcontrib-websupport)[home-page]: Use HTTPS. Marius Bakke 2019-06-18gnu: python-babel: Update to 2.7.0....* gnu/packages/python-xyz.scm (python-babel): Update to 2.7.0. (python2-babel-2.6): New variable. * gnu/packages/sphinx.scm (python2-sphinx)[propagated-inputs]: Change PYTHON2-BABEL to PYTHON2-BABEL-2.6. Marius Bakke 2019-06-14gnu: Sphinx: Update to 2.1.1....* gnu/packages/sphinx.scm (python-sphinx): Update to 2.1.1. Marius Bakke 2019-05-24gnu: python-sphinx: Update to 2.0.1....* gnu/packages/sphinx.scm (python-sphinx): Update to 2.0.1. [arguments]: Remove Python2 workaround. [propagated-inputs]: Remove PYTHON-SIX and PYTHON-SPHINXCONTRIB-WEBSUPPORT. Add PYTHON-SPHINXCONTRIB-APPLEHELP, PYTHON-SPHINXCONTRIB-DEVHELP, PYTHON-SPHINXCONTRIB-HTMLHELP, PYTHON-SPHINXCONTRIB-JSMATH, PYTHON-SPHINXCONTRIB-QTHELP, and PYTHON-SPHINXCONTRIB-SERIALIZINGHTML. (python2-sphinx)[source]: Stay on version 1.7.7. [arguments]: New field. [propagated-inputs]: Do not inherit from the Python 3 Sphinx variant. Marius Bakke 2019-05-24gnu: Add python-sphinxcontrib-qthelp....* gnu/packages/sphinx.scm (python-sphinxcontrib-qthelp): New public variable. Marius Bakke 2019-05-24gnu: Add python-sphinxcontrib-htmlhelp....* gnu/packages/sphinx.scm (python-sphinxcontrib-htmlhelp): New public variable. Marius Bakke 2019-05-24gnu: Add python-sphinxcontrib-jsmath....* gnu/packages/sphinx.scm (python-sphinxcontrib-jsmath): New public variable. Marius Bakke 2019-05-24gnu: Add python-sphinxcontrib-devhelp....* gnu/packages/sphinx.scm (python-sphinxcontrib-devhelp): New public variable. Marius Bakke 2019-05-24gnu: Add python-sphinxcontrib-applehelp....* gnu/packages/sphinx.scm (python-sphinxcontrib-applehelp): New public variable. Marius Bakke 2019-05-24gnu: Add python-sphinxcontrib-serializinghtml....* gnu/packages/sphinx.scm (python-sphinxcontrib-serializinghtml): New public variable. Marius Bakke 2019-05-24gnu: Move Sphinx and friends to (gnu packages sphinx)....* gnu/packages/python-xyz.scm (python-sphinxcontrib-websupport, python2-sphinxcontrib-websupport, python-sphinx, python2-sphinx, python-sphinx-gallery, python2-sphinx-gallery, python-sphinx-rtd-theme, python2-sphinx-rtd-theme, python-guzzle-sphinx-theme, python2-guzzle-sphinx-theme, python-sphinxcontrib-newsfeed, python-sphinxcontrib-programoutput, python2-sphinxcontrib-programoutput, python-sphinx-repoze-interface, python2-sphinx-repoze-interface, python-sphinx-cloud-sptheme, python2-sphinx-cloud-sptheme, python-sphinx-alabaster-theme, python2-sphinx-alabaster-theme, python-sphinx-me, python-sphinxcontrib-svg2pdfconverter): Move to ... (gnu): * gnu/packages/sphinx.scm: ... here. New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/packages/admin.scm, gnu/packages/bioinformatics.scm, gnu/packages/calendar.scm, gnu/packages/cluster.scm, gnu/packages/databases.scm, gnu/packages/dav.scm, gnu/packages/disk.scm, gnu/packages/django.scm, gnu/packages/elf.scm, gnu/packages/emacs-xyz.scm, gnu/packages/emulators.scm, gnu/packages/finance.scm, gnu/packages/image.scm, gnu/packages/libffi.scm, gnu/packages/mail.scm, gnu/packages/mpd.scm, gnu/packages/openstack.scm, gnu/packages/pdf.scm, gnu/packages/python-web.scm, gnu/packages/search.scm, gnu/packages/statistics.scm, gnu/packages/storage.scm, gnu/packages/sync.scm, gnu/packages/terminals.scm, gnu/packages/tls.scm, gnu/packages/web.scm: Adjust module imports. Marius Bakke