aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libphidget)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages libusb))

(define-public libphidget
  (package
   (name "libphidget")
   (version "2.1.9.20190409")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "https://www.phidgets.com/downloads/phidget21/libraries/"
                  "linux/libphidget/libphidget_"
                  version ".tar.gz"))
            (sha256
             (base32 "07w54dmr75vq2imngfy66nk1sxlvkzhl2p6g362q0a02f099jy0f"))))
   (build-system gnu-build-system)
   (inputs (list libusb))
   (outputs '("out" "debug"))
   (home-page "https://www.phidgets.com/")
   (license lgpl3+)
   (synopsis "C library to manipulate Phidgets")
   (description synopsis)))
stem_vulkan=enabled" and "-Dvulkan_datadir" from as they are no longer supported. <#:phases>: Add 'unbundle-vulkan-headers'. [inputs]: Add nlohmann-json. Replace vulkan-headers with origin for vulkan-headers@1.2.158. [native-inputs]: Add git-minimal/pinned. John Kehayias 2023-10-14gnu: f3d: Update to 2.2.1....* gnu/packages/graphics.scm (f3d): Update to 2.2.1. [snippet]: Update paths to delete and remove substitutions. [arguments]<#:configure-flags>: Remove obsolete options, update renamed options and add -DF3D_EXTERNAL_CXXOPTS, -DF3D_EXTERNAL_NLOHMANN_JSON and -DF3D_MODULE_EXR. [phases]: Add 'fix-cmake-rpath' phase. [inputs]: Add openexr. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2023-10-09gnu: povray: Update to 3.7.0.10....* gnu/packages/graphics.scm (povray): Update to 3.7.0.10. [source]: Simplify snippet. Ricardo Wurmus 2023-10-09gnu: povray: Drop input labels....* gnu/packages/graphics.scm (povray)[inputs]: Remove all input labels. [arguments]: Use G-expression to avoid the use of %build-inputs. Ricardo Wurmus 2023-09-14gnu: nanosvg: Add a patch for PrusaSlicer 2.6....* gnu/packages/graphics.scm (nanosvg): Add a patch that is required to build PrusaSlicer 2.6. * gnu/packages/patches/nanosvg-prusa-slicer.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Artyom V. Poptsov 2023-09-08gnu: Add asli....* gnu/packages/graphics.scm (asli): New variable. * gnu/packages/patches/asli-use-system-libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Paul A. Patience 2023-09-05gnu: skia: Update to 112.0.6d0b938....* gnu/packages/graphics.scm (skia): Update to 112.0.6d0b938. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2023-09-05gnu: skia: Update to 110.0.0f3fb7a....* gnu/packages/graphics.scm (skia): Update to 110.0.0f3fb7a. [arguments](build-phases): Disable newly introduced libraries wuffs (general performance) and perfetto (running performance tests). Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2023-09-04gnu: gr-framework: Update to 0.69.1....* gnu/packages/graphics.scm (gr-framework): Update to 0.69.1. Efraim Flashner 2023-09-02gnu: skia: Activate tests....* gnu/packages/graphics.scm (skia): Activate tests. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Nicolas Graves 2023-08-15gnu: openscenegraph: Build with librsvg-for-system....* gnu/packages/graphics.scm (openscenegraph)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner