aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libphidget)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses)
  #:use-module (gnu packages libusb))

(define-public libphidget
  (package
   (name "libphidget")
   (version "2.1.9.20190409")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "https://www.phidgets.com/downloads/phidget21/libraries/"
                  "linux/libphidget/libphidget_"
                  version ".tar.gz"))
            (sha256
             (base32 "07w54dmr75vq2imngfy66nk1sxlvkzhl2p6g362q0a02f099jy0f"))))
   (build-system gnu-build-system)
   (inputs (list libusb))
   (outputs '("out" "debug"))
   (home-page "https://www.phidgets.com/")
   (license lgpl3+)
   (synopsis "C library to manipulate Phidgets")
   (description synopsis)))
a1d73c3d7a55'>gnu: Add docbook-sgml-3.1....* gnu/packages/docbook.scm (docbook-sgml-3.1): New variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-dsssl....* gnu/packages/docbook.scm (docbook-dsssl): New variable. Maxim Cournoyer 2021-01-14gnu: Add docbook-sgml....* gnu/packages/docbook.scm (docbook-sgml): New variable. Maxim Cournoyer 2021-01-14gnu: Add iso-8879-entities....* gnu/packages/docbook.scm (iso-8879-entities): New private variable. Maxim Cournoyer 2020-11-09gnu: docbook: Update source URI....* gnu/packages/docbook.scm (docbook-xml-5)[source]: Update to new source URI. (docbook-xml, docbook-xml-4.4, docbook-xml-4.3, docbook-xml-4.2, docbook-xml-4.1.2)[source]: Same. Efraim Flashner 2020-06-14gnu: docbook: Add 5.0.1....* gnu/packages/docbook.scm (docbook-xml-5): New public variable. (docbook-xml): Inherit from it. While at it, remove trailing whitespace. Marius Bakke 2020-01-21Merge branch 'staging' into core-updatesMarius Bakke 2020-01-19gnu: Use HTTPS for docbook.org....* gnu/packages/docbook.scm (docbook-xml)[home-page, source]: Use HTTPS. (docbook-xml-4.4, docbook-xml-4.3, docbook-xml-4.2, docbook-xml-4.1.2) [source]: Likewise. (docbook-xsl)[home-page]: Likewise. Tobias Geerinckx-Rice 2020-01-11gnu: dblatex: Update to 0.3.11....* gnu/packages/docbook.scm (dblatex): Update to 0.3.11. Marius Bakke 2019-07-24gnu: Replace uses of texlive-*-amsfonts....* gnu/packages/algebra.scm (pari-gp)[native-inputs]: Replace texlive-fonts-amsfonts and texlive-latex-amsfonts with texlive-amsfonts in texlive-union. * gnu/packages/docbook.scm (dblatex)[inputs]: Same. * gnu/packages/plotutils.scm (asymptote)[native-inputs]: Same. * gnu/packages/python-xyz.scm (python-numpy-documentation, python-matplotlib-documentation, python-ipython-documentation) [native-inputs]: Same. * gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Same. * gnu/packages/tex.scm (teximpatient)[native-inputs]: Same. Ricardo Wurmus