aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libffcall)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libffcall
   (package
    (name "libffcall")
    (version "2.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
       (sha256
        (base32
         "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:configure-flags '("--disable-static")))
    (synopsis "Foreign function calls from interpreters")
    (description
     "GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
    (home-page "https://www.gnu.org/software/libffcall/")
    (license l:gpl2+)))
tes....Maxim Cournoyer 2023-04-14gnu: meson: Update to 1.1.0....Maxim Cournoyer 2023-04-12gnu: genie: Update to 1170....Juliana Sims 2023-04-12gnu: Add pdpmake....Jelle Licht 2023-04-10gnu: meson-python: Update to 0.12.1....Maxim Cournoyer 2023-04-09gnu: meson: Update to 1.0.1....Maxim Cournoyer 2023-04-09gnu: Remove extraneous #:meson build arguments....Maxim Cournoyer 2023-03-30gnu: Remove ucd-next....Maxim Cournoyer 2023-03-21gnu: gnulib: Depend on git-minimal/pinned....Josselin Poiret 2023-03-20gnu: gnulib: Depend on git-minimal/pinned....Josselin Poiret 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-17gnu: gnulib: Restore shebangs....Vivien Kraus 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Christopher Baines 2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice 2023-02-23gnu: gnulib: Allow only one directory name in GNULIB_SRCDIR....Vivien Kraus 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner 2023-01-19gnu: gnulib: Refer to "gcc" as provided via implicit package inputs....Ludovic Courtès 2023-01-15gnu: Add gnulib....Vivien Kraus 2022-12-02gnu: gn: Use G-expression....Marius Bakke 2022-12-02gnu: gn: Remove input labels....Marius Bakke 2022-12-02gnu: gn: Update to 0.0-2072.1c4151f....Marius Bakke 2022-11-11gnu: bear: Replace spdlog with spdlog-1.10....Greg Hogan 2022-11-06gnu: fmt: Update to 9.1.0....Maxim Cournoyer 2022-10-09gnu: Add genie....J. Sims