aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libffcall)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libffcall
   (package
    (name "libffcall")
    (version "2.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
       (sha256
        (base32
         "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:configure-flags '("--disable-static")))
    (synopsis "Foreign function calls from interpreters")
    (description
     "GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
    (home-page "https://www.gnu.org/software/libffcall/")
    (license l:gpl2+)))
/pcre.scm?id=dad7117c352ca4d8f91ae3235259a591d7b4f33f'>gnu: pcre2: Update to 10.40....* gnu/packages/pcre.scm (pcre2): Update to 10.40. [source](uri): Use new download location. Marius Bakke 2022-06-09gnu: pcre: Update with new source URI....* gnu/packages/pcre.scm (pcre)[source]: Download from sourceforge mirror. Efraim Flashner 2022-01-27gnu: pcre2: Fix building on riscv64-linux....* gnu/packages/pcre.scm (pcre2)[arguments]: Adjust configure-flags to not build with JIT when building for riscv64-linux. Efraim Flashner 2022-01-27gnu: pcre: Fix building on riscv64-linux....* gnu/packages/pcre.scm (pcre)[arguments]: Adjust configure-flags to not build with JIT when building for riscv64-linux. Efraim Flashner 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-10-04gnu: pcre: Don't enable jit on powerpc-linux....* gnu/packages/pcre.scm (pcre)[arguments]: When building for powerpc-linux don't enable jit. Efraim Flashner 2021-08-30gnu: pcre2: Build without JIT on powerpc-linux....* gnu/packages/pcre.scm (pcre2)[arguments]: On powerpc-linux don't enable JIT. Efraim Flashner 2021-08-18gnu: Remove pcre2-10.36....* gnu/packages/pcre.scm (pcre2-10.36): Remove variable. * gnu/packages/julia.scm (julia)[arguments]: Adjust 'adjust-test-suite phase for new pcre2 package. [inputs]: Replace pcre2-10.36 with pcre2. Efraim Flashner 2021-07-29Merge branch 'master' into core-updates-frozen... Conflicts: gnu/packages/bioinformatics.scm gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/emacs-xyz.scm gnu/packages/gpodder.scm gnu/packages/music.scm gnu/packages/patches/glibc-bootstrap-system.patch gnu/packages/python-xyz.scm gnu/packages/shells.scm gnu/packages/statistics.scm Marius Bakke 2021-07-28gnu: Add pcre2-10.36....* gnu/packages/pcre.scm (pcre2-10.36): New variable. Co-Authored-By: zimoun <zimoun.toutoune@gmail.com>. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jean-Baptiste Volatier 2021-07-23gnu: pcre2: Update to 10.37....* gnu/packages/pcre.scm (pcre2): Update to 10.37. [arguments]: Remove trailing #t. Marius Bakke 2021-07-23gnu: pcre: Update to 8.45....* gnu/packages/pcre.scm (pcre): Update to 8.45. [source](uri): Change to official mirror; remove defunct. [arguments]: Remove trailing #t. Marius Bakke