aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libffcall)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libffcall
   (package
    (name "libffcall")
    (version "2.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
       (sha256
        (base32
         "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:configure-flags '("--disable-static")))
    (synopsis "Foreign function calls from interpreters")
    (description
     "GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
    (home-page "https://www.gnu.org/software/libffcall/")
    (license l:gpl2+)))
='/guix/commit/gnu/packages/sdl.scm?id=27783023993f9272ce422868d14529159c4a5218'>Merge branch 'master' into core-updates... Conflicts: etc/news.scm gnu/local.mk gnu/packages/check.scm gnu/packages/cross-base.scm gnu/packages/gimp.scm gnu/packages/java.scm gnu/packages/mail.scm gnu/packages/sdl.scm gnu/packages/texinfo.scm gnu/packages/tls.scm gnu/packages/version-control.scm Marius Bakke 2020-04-02gnu: sdl2: Update to 2.0.12....* gnu/packages/patches/sdl2-mesa-compat.patch: Delete file. * gnu/packages/sdl.scm (sdl2): Update to 2.0.12. [source]: Drop patch that was included in this release. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Timotej Lazar 2020-04-02gnu: sdl2: Use udev to discover input devices....Without udev SDL falls back on custom detection code, which blocks every three seconds while checking for new devices. * gnu/packages/sdl.scm (sdl2)[inputs]: Add eudev. [arguments]<#:make-flags>: Add LDFLAGS to include eudev in rpath so that dlopen can find it. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Timotej Lazar 2020-03-18Merge branch 'master' into core-updatesMarius Bakke 2020-03-14gnu: Add guile3.0-sdl2....* gnu/packages/sdl.scm (guile3.0-sdl2): New variable. Ricardo Wurmus 2020-03-10Merge branch 'master' into core-updatesMarius Bakke 2020-03-06gnu: sdl-pango: Rename patch to fix guix lint warning about patch filename size....* gnu/packages/patches/sdl-pango-fix-explicit-SDLPango_CopyFTBitmapToSurface.patch: Rename to ... * gnu/packages/patches/sdl-pango-fix-explicit-SDLPango_CopyFTBitmapTo.patch: ... this. * gnu/local.mk: Update accordingly. * gnu/packages/sdl.scm: Update accordingly. Vagrant Cascadian 2020-02-10gnu: sdl2: Remove obsolete workaround....* gnu/packages/sdl.scm (sdl2)[arguments]: Remove #:make-flags. Marius Bakke 2020-02-03Merge branch 'staging' into core-updatesMarius Bakke 2020-02-02gnu: Add sdl-pango....* gnu/packages/sdl.scm (sdl-pango): New variable. * gnu/packages/patches/sdl-pango-api_additions.patch: New file. * gnu/packages/patches/sdl-pango-blit_overflow.patch: New file. * gnu/packages/patches/sdl-pango-fillrect_crash.patch: New file. * gnu/packages/patches/sdl-pango-fix-explicit-SDLPango_CopyFTBitmapToSurface.patch: New file. * gnu/packages/patches/sdl-pango-matrix_declarations.patch: New file. * gnu/packages/patches/sdl-pango-sans-serif.patch: New file. * gnu/local.mk (sdl-pango): Reference patches. add Nicolas Goaziou