aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libffcall)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libffcall
   (package
    (name "libffcall")
    (version "2.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
       (sha256
        (base32
         "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:configure-flags '("--disable-static")))
    (synopsis "Foreign function calls from interpreters")
    (description
     "GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
    (home-page "https://www.gnu.org/software/libffcall/")
    (license l:gpl2+)))
scm?id=ae08b8ab05264f4710405429d533a005d2fe8697'>gnu: docker-libnetwork-cmd-proxy: Improve package style....* gnu/packages/docker.scm (docker-libnetwork-cmd-proxy): Improve package style. Fix indentation. [arguments]: Apply list style, adjust order of the keys. [native-inputs]: Remove labels. [description]: Adjust it, place on a new line. Change-Id: I0cb59a3d9306291e4101f6c6d2e681ffd319ba9f Sharlatan Hellseher 2024-07-25gnu: go-netlink: Rename variable....* gnu/packages/linux.scm (go-netlink): Renamve variable to go-github-com-vishvananda-netlink to reflect go.mod import path. * gnu/packages/networking.scm (yggdrasil) [propagated-inputs]: Remove go-netlink, add go-github-com-vishvananda-netlink. (nebula): [inputs]: Remove go-netlink, add go-github-com-vishvananda-netlink. * gnu/packages/docker.scm (docker-libnetwork-cmd-proxy) [native-inputs]: Remove go-netlink, add go-github-com-vishvananda-netlink. Change-Id: I77658e6c7f5d57d8631b42c661466c6b7e08df50 Sharlatan Hellseher 2024-07-25gnu: go-netns: Rename varialbe....* gnu/packages/networking.scm (go-netns): Rename variable to go-github-com-vishvananda-netns to reflect go.mod import path. (yggdrasil) [propagated-inputs]: Remove go-netns, add go-github-com-vishvananda-netns. (nebula): [inputs]: Remove go-netns, add go-github-com-vishvananda-netns. * gnu/packages/docker.scm (docker-libnetwork-cmd-proxy) [native-inputs]: Remove go-netns, add go-github-com-vishvananda-netns. * gnu/packages/linux.scm (go-netlink) [native-inputs]: Remove go-netns, add go-github-com-vishvananda-netns. Change-Id: I49fb89a886134b0c768557ca4700c9be19c2c5d7 Sharlatan Hellseher 2024-06-29gnu: docker: Apply "-trimpath" flag....* gnu/packages/docker.scm (docker) [arguments]: <#:phases>: Remove 'remove-go-references phase. Set BUILDFLAGS=-trimpath to replace 'remove-go-references phase in 'build phase. Change-Id: Iada1a8764808d26e476ca8ca87a23061834f78be Sharlatan Hellseher 2024-04-02gnu: cqfd: Update to 5.5.0....* gnu/packages/docker.scm (cqfd): Update to 5.5.0. Change-Id: Ib8ba9ee06744869efc1489beb4e2d56fe0cc06e0 Maxim Cournoyer