aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libffcall)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libffcall
   (package
    (name "libffcall")
    (version "2.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
       (sha256
        (base32
         "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:configure-flags '("--disable-static")))
    (synopsis "Foreign function calls from interpreters")
    (description
     "GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
    (home-page "https://www.gnu.org/software/libffcall/")
    (license l:gpl2+)))
ents]: Disable building libscsynth. Efraim Flashner 2021-01-06gnu: lilv: Update to 0.24.10....* gnu/packages/audio.scm (lilv): Update to 0.24.10. Tobias Geerinckx-Rice 2021-01-02gnu: lsp-dsp-lib: Omit static library....* gnu/packages/audio.scm (lsp-dsp-lib)[arguments]: Add an 'omit-static-library phase. Tobias Geerinckx-Rice 2021-01-02gnu: lsp-dsp-lib: Update to 0.5.11....* gnu/packages/audio.scm (lsp-dsp-lib): Update to 0.5.11. Tobias Geerinckx-Rice 2020-12-30gnu: timidity++: Update to 2.15.0....* gnu/packages/audio.scm (timidity++): Update to 2.15.0. Signed-off-by: Leo Famulari <leo@famulari.name> Vincent Legoll 2020-12-27gnu: audacity: Update to 2.4.2....* gnu/packages/audio.scm (audacity): Update to 2.4.2. [source]: Add patch. Don't delete portaudio-v19, since only the bundled copy can be built. [build-system]: Switch to cmake-build-system. [inputs]: Remove portaudio. [arguments]: Adjust configure flags for CMake. Remove 'fix-sbsms-check phase. Add 'comment-out-revision-ident phase. * gnu/local.mk (dist_patch_DATA): Register patch. * gnu/packages/patches/audacity-add-include.patch: New file. Kei Kebreau 2020-12-27gnu: ir: Fix build....* gnu/packages/audio.scm (ir)[arguments]: Add phase "fix-type". Ricardo Wurmus 2020-12-26gnu: qjackctl: Update to 0.9.0....* gnu/packages/audio.scm (qjackctl): Update to 0.9.0. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Michael Rohleder