aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libffcall)
  #:use-module ((guix licenses) #:prefix l:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libffcall
   (package
    (name "libffcall")
    (version "2.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
       (sha256
        (base32
         "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f
       #:configure-flags '("--disable-static")))
    (synopsis "Foreign function calls from interpreters")
    (description
     "GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
    (home-page "https://www.gnu.org/software/libffcall/")
    (license l:gpl2+)))
s-services....Mathieu Othacehe 2021-02-22services: cuirass: Instantiate postgresql service....Mathieu Othacehe 2021-02-22services: cuirass: Add parameters support....Mathieu Othacehe 2021-02-19services: cuirass: Add "simple-cuirass-services"....Mathieu Othacehe 2021-02-12services: cuirass: Add server argument for the remote-worker....Mathieu Othacehe 2021-02-09services: cuirass: Move zabbix argument to the web process....Mathieu Othacehe 2021-02-08services: cuirass: Add Zabbix support....Mathieu Othacehe 2021-01-28services: cuirass: Create remote-server cache directory....Mathieu Othacehe 2021-01-28services: cuirass: Fix syntax error....Mathieu Othacehe 2021-01-28services: cuirass: Add log-file support....Mathieu Othacehe 2021-01-28services: cuirass: Fix workers argument....Mathieu Othacehe 2021-01-28services: cuirass: Add systems argument....Mathieu Othacehe 2021-01-28services: cuirass: Add remote build support.Mathieu Othacehe 2021-01-28service: cuirass: Update it.Mathieu Othacehe 2020-12-08services: cuirass: Add queue-size option....Mathieu Othacehe 2020-10-02services: cuirass: Fix activation....Mathieu Othacehe 2020-09-24services: cuirass: Create queries log files at activation....Mathieu Othacehe 2020-09-24services: cuirass: Add web SQL queries logging support....Mathieu Othacehe 2020-09-24services: cuirass: Add SQL queries logging support....Mathieu Othacehe 2020-03-08services: cuirass: Allow passing extra command line options....Christopher Baines 2020-01-06Adjust module autoloads....Ludovic Courtès 2019-10-23services: cuirass: Create /var/log/cuirass during activation....Ludovic Courtès 2019-09-23services: cuirass: Remove unneeded conditional....Ludovic Courtès 2019-08-29services: cuirass: Log web interface to separate file....Ricardo Wurmus 2019-08-26services: cuirass: Split into two separate services....Ricardo Wurmus 2019-03-04services: Use 'file-append' for user account shells....Ludovic Courtès