;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013, 2015, 2018, 2020, 2021, 2023 Ludovic Courtès ;;; Copyright © 2013, 2015 Andreas Enge ;;; Copyright © 2015, 2018 Ricardo Wurmus ;;; Copyright © 2016, 2017, 2019-2024 Efraim Flashner ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice ;;; Copyright © 2017, 2018 Clément Lassieur ;;; Copyright © 2017 Andy Wingo ;;; Copyright © 2018 Fis Trivial ;;; Copyright © 2018 Pierre Neidhardt ;;; Copyright © 2014 Eric Bavier ;;; Copyright © 2014 Mark H Weaver ;;; Copyright © 2019 Hartmut Goebel ;;; Copyright © 2020, 2022 Maxim Cournoyer ;;; Copyright © 2020, 2021, 2023 Marius Bakke ;;; Copyright © 2020 Julien Lepiller
aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2023 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libevent)
  #:use-module (gnu packages)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system perl)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages base)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages perl-check)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages tls))

(define-public libevent
  (package
    (name "libevent")
    (version "2.1.12")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/libevent/libevent/releases/download/release-"
                    version "-stable/libevent-" version "-stable.tar.gz"))
              (sha256
               (base32
                "1fq30imk8zd26x8066di3kpc5zyfc5z6frr3zll685zcx4dxxrlj"))))
    (build-system gnu-build-system)
    (outputs '("out" "bin"))
    (arguments
     ;; This skips some of the tests which fail on armhf and aarch64.
     '(#:configure-flags '("--disable-libevent-regress"
                           "--disable-openssl")))
    (inputs
     (list python-wrapper))             ;for 'event_rpcgen.py'
    (native-inputs
     (list which))
    (home-page "https://libevent.org/")
    (synopsis "Event notification library")
    (description
     "The libevent API provides a mechanism to execute a callback
function when a specific event occurs on a file descriptor or after a
timeout has been reached.  Furthermore, libevent also support callbacks
due to signals or regular timeouts.

libevent is meant to replace the event loop found in event driven
network servers.  An application just needs to call event_dispatch() and
then add or remove events dynamically without having to change the event
loop.")
    (license license:bsd-3)))

(define-public libevent-with-openssl
  (package/inherit libevent
    (name "libevent-with-openssl")
    (inputs (modify-inputs (package-inputs libevent)
              (prepend openssl)))
    (arguments
     ;; This skips some of the tests which fail on armhf and aarch64.
     '(#:configure-flags '("--disable-libevent-regress")))))

(define-public libev
  (package
    (name "libev")
    (version "4.33")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://dist.schmorp.de/libev/Attic/libev-"
                                  version
                                  ".tar.gz"))
              (sha256
               (base32
                "1sjs4324is7fp21an4aas2z4dwsvs6z4xwrmp72vwpq1s6wbfzjh"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("--disable-static")))
    (home-page "http://software.schmorp.de/pkg/libev.html")
    (synopsis "Event loop loosely modelled after libevent")
    (description
     "libev provides a full-featured and high-performance event loop that is
loosely modelled after libevent.  It includes relative timers, absolute timers
with customized rescheduling, synchronous signals, process status change
events, event watchers dealing with the event loop itself, file watchers, and
limited support for fork events.")
    (license (list license:bsd-2 license:gpl2+))))

(define-public libuv
  (package
    (name "libuv")
    (version "1.44.2")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.libuv.org/dist/v" version
                                  "/libuv-v" version ".tar.gz"))
              (sha256
               (base32
                "1d1wy1061cf2mfygr2j6jbm0da2mhsf0l9yq4rjkqrsmijbdrz6c"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("--disable-static")
       ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
       #:tests? #f))
    (native-inputs (list autoconf automake libtool
                         ;; libuv.pc is installed only when pkg-config is found.
                         pkg-config))
    (home-page "https://github.com/libuv/libuv")
    (synopsis "Library for asynchronous I/O")
    (description
     "libuv is a multi-platform support library with a focus on asynchronous
I/O.  Among other things, it supports event loops via epoll, kqueue, and
similar IOCP, and event ports, asynchronous TCP/UDP sockets, asynchronous DNS
resolution, asynchronous file system operations, and threading primitives.")

    ;; A few files fall under other non-copyleft licenses; see 'LICENSE' for
    ;; details.  Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
    (license (list license:expat license:cc-by4.0))))

(define-public libuv-for-node
  ;; When upgrading Node, also upgrade this. Get the version from
  ;; https://github.com/nodejs/node/blob/master/deps/uv/include/uv/version.h
  (package
    (inherit libuv)
    (name "libuv")
    (version "1.42.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.libuv.org/dist/v" version
                                  "/libuv-v" version ".tar.gz"))
              (sha256
               (base32
                "0wpb9pz3r8nksnrf4zbixj2kk9whr7abi45ydrwyv2js2ljrc4j3"))))
    (properties '((hidden? . #t)))))

(define-public libuv-for-node-lts
  ;; When upgrading Node, also upgrade this. Get the version from
  ;; https://github.com/nodejs/node/blob/main/deps/uv/include/uv/version.h
  (package
    (inherit libuv)
    (name "libuv")
    (version "1.46.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.libuv.org/dist/v" version
                                  "/libuv-v" version ".tar.gz"))
              (sha256
               (base32
                "1knxvp6bl3y0c87cch1id0z7m7rb6igx55ci93qnbp4zifaq67qi"))
       (modules '((guix build utils)))
       (snippet
        '(begin
           ;; Disable io_uring by default due to CVE-2024-22017. Can be removed once
           ;; https://github.com/libuv/libuv/issues/4468 is released and compatible
           ;; with Node.js
           (substitute* "src/unix/linux.c"
             (("val == NULL \\|\\|") "val != NULL &&"))))))
    (properties '((hidden? . #t)))))

(define-public libuv-for-r-httpuv
  ;; When upgrading r-httpuv, also upgrade this.
  (package
    (inherit libuv)
    (name "libuv")
    (version "1.43.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.libuv.org/dist/v" version
                                  "/libuv-v" version ".tar.gz"))
              (sha256
               (base32
                "194kwq3jfj9s628kzkchdca534rikjw0xiyas0cjbphqmsvjpmwh"))))
    (properties '((hidden? . #t)))))

(define-public libuv-julia
  (let ((commit "e6f0e4900e195c8352f821abe2b3cffc3089547b")
        (revision "4"))
    ;; When upgrading Julia, also upgrade this.  Get the commit from
    ;; https://github.com/JuliaLang/julia/blob/v1.8.2/deps/libuv.version
    (package
      (inherit libuv)
      (name "libuv-julia")
      (version (git-version "2.0.0" revision commit))
      (source (origin
                (method git-fetch)
                (uri (git-reference
                       (url "https://github.com/JuliaLang/libuv")
                       (commit commit)))
                (file-name (git-file-name name version))
                (sha256
                 (base32
                  "0ib2cprvbyviwrzm0fw6dqvlbm9akf2kj3vjzp82q3gii74cv3c9"))))
      (arguments
       '(#:configure-flags '("--with-pic")
         #:tests? #f))
      (home-page "https://github.com/JuliaLang/libuv")
      (properties '((hidden? . #t))))))

(define-public libuv-for-luv
  ;; When upgrading make-lua-luv, also upgrade this. Get the version from
  ;; https://github.com/luvit/luv/blob/master/CMakeLists.txt
  (package
    (inherit libuv)
    (name "libuv")
    (version "1.43.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.libuv.org/dist/v" version
                                  "/libuv-v" version ".tar.gz"))
              (sha256
               (base32
                "194kwq3jfj9s628kzkchdca534rikjw0xiyas0cjbphqmsvjpmwh"))))
    (properties '((hidden? . #t)))))

(define-public perl-anyevent
  (package
    (name "perl-anyevent")
    (version "7.17")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/"
                                  "AnyEvent-" version ".tar.gz"))
              (sha256
               (base32
                "11drlj8r02czhjgzkb39axnr8zzyp506r043xfmf93q9kilfmgjh"))))
    (build-system perl-build-system)
    (native-inputs
     (list perl-canary-stability))
    (propagated-inputs
     (list perl-async-interrupt
           perl-ev
           perl-guard
           perl-json
           perl-json-xs
           perl-net-ssleay
           perl-task-weaken))
    (home-page "https://metacpan.org/release/AnyEvent")
    (synopsis
     "API for I/O, timer, signal, child process and completion events")
    (description
     "This module allows using a variety of events without forcing module
authors to pick a specific event loop, and without noticeable overhead.
Currently supported event loops are EV, Event, Glib/Gtk2, Tk, Qt,
@code{Event::Lib}, Irssi, @code{IO::Async} and POE (and thus also WxWidgets
and Prima).  It also comes with a very fast Pure Perl event loop that does
not rely on XS.")
    (license license:perl-license)))

(define-public perl-ev
  (package
    (name "perl-ev")
    (version "4.31")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/EV-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "1jxlhnvrqim39977zwavjrcbdf9bifb46pwaxvm0s8klq121kjwb"))
              (modules '((guix build utils)))
              (snippet
               '(begin
                  ;; Drop bundled libev.
                  (delete-file-recursively "libev")
                  #t))))
    (build-system perl-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'unpack-libev
           ;; This package requires the libev *sources* in order
           ;; to build. Unpack system libev here...
           (lambda* (#:key inputs #:allow-other-keys)
             (mkdir "./libev")
             (invoke "tar" "-xf" (assoc-ref inputs "libev-source")
                     "-C" "./libev" "--strip-components=1"))))))
    (native-inputs
     `(("libev-source" ,(package-source libev))
       ("perl-canary-stability" ,perl-canary-stability)))
    (propagated-inputs
     (list perl-common-sense))
    (home-page "https://metacpan.org/release/EV")
    (synopsis "Perl interface to libev")
    (description
     "This module provides an interface to @code{libev}, a high performance
full-featured event loop.  It can be used through the @code{AnyEvent} module
and still be faster than other event loops currently supported in Perl.")
    (license license:perl-license)))

(define-public perl-rpc-epc-service
  (package
    (name "perl-rpc-epc-service")
    (version "0.0.11")
    (source
     (origin
       (method url-fetch)
       (uri (string-append
             "mirror://cpan/authors/id/K/KI/KIWANAMI/RPC-EPC-Service-"
             "v" version ".tar.gz"))
       (sha256
        (base32
         "1qwb284z4ig3xzy21m1b3w8bkb8k6l2ij6cjz93znn2j6qs42pwp"))))
    (build-system perl-build-system)
    (native-inputs
     (list perl-module-build perl-test-simple))
    (propagated-inputs
     (list perl-anyevent perl-data-sexpression))
    (arguments
     ;; Tests seem to fail because they try to start a server.
     `(#:tests? #f))
    (home-page "https://metacpan.org/release/RPC-EPC-Service")
    (synopsis "Asynchronous remote procedure stack")
    (description "RPC::EPC::Service enables to connect the other process with
the S-expression protocol, like the Swank protocol of the SLIME.")
    (license license:perl-license)))
e "https://github.com/AlDanial/cloc") (synopsis "Count source lines of code (SLOC) and other source code metrics") (description "cloc counts blank lines, comment lines, and physical lines of source code in many programming languages. Given two versions of a code base, cloc can compute differences in blank, comment, and source lines. cloc contains code from David Wheeler's SLOCCount. Compared to SLOCCount, cloc can handle a greater variety of programming languages.") (license license:gpl2+))) (define-public scc (package (name "scc") (version "3.3.5") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/boyter/scc") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0fvp9ab65vwn3dn0wm8l63rrp5fz1gpymcxs8yr0h4s5zmrsg9zf")))) (build-system go-build-system) (arguments (list #:install-source? #f #:import-path "github.com/boyter/scc")) (native-inputs (list go-github-com-dbaggerman-cuba go-github-com-json-iterator-go go-github-com-mattn-go-runewidth go-github-com-minio-blake2b-simd go-github-com-spf13-cobra go-golang-org-x-text go-gopkg-in-yaml-v2)) (home-page "https://github.com/boyter/scc") (synopsis "Fast code counter written in Go") (description "@command{scc} provides a lines-of-code counter similar to tools like @command{cloc} and @command{sloccount}. It aims to be fast as possible while supporting @acronym{COCOMO,Constructive Cost Model} calculation and code complexity estimation.") (license license:expat))) (define-public the-silver-searcher (package (name "the-silver-searcher") (version "2.2.0") (source (origin (method url-fetch) (uri (string-append "https://geoff.greer.fm/ag/releases/the_silver_searcher-" version ".tar.gz")) (sha256 (base32 "0w1icjqd8hd45rn1y6nbfznk1a6ip54whwbfbhxp7ws2hn3ilqnr")))) (build-system gnu-build-system) (arguments ;; Required since GCC 10, see: ;; https://gcc.gnu.org/gcc-10/porting_to.html. `(#:configure-flags (list "CFLAGS=-fcommon"))) (native-inputs (list pkg-config)) (inputs (list pcre xz zlib)) (home-page "https://geoff.greer.fm/ag/") (synopsis "Fast code searching tool") (description "The Silver Searcher (@command{ag}) is a tool for quickly searching large numbers of files. It's intended primarily for source code repositories, and respects files like @file{.gitignore} and @file{.hgignore}. It's also an order of magnitude faster than its inspiration, @command{ack}, and less specialised tools such as @command{grep}.") (license license:asl2.0))) (define-public trio (package (name "trio") (version "1.16") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/ctrio/trio/trio-" version ".tar.gz")) (sha256 (base32 "02pwd5m5vq7hbrffgm2na1dfc249z50yyr5jv73vdw15bd7ygl44")))) (build-system gnu-build-system) (home-page "https://daniel.haxx.se/projects/trio/") (synopsis "Portable and extendable printf and string functions") (description "Trio is a set of @code{printf} and string functions designed be used by applications with a focus on portability or with the need for additional features that are not supported by the standard @code{stdio} implementation.") ;; This license is very similar to the ISC license, but the wording is ;; slightly different. (license (license:non-copyleft "http://sourceforge.net/p/ctrio/git/ci/master/tree/README")))) (define-public universal-ctags (package (name "universal-ctags") (version "6.1.20240317.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/universal-ctags/ctags") (commit (string-append "p" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1bs48bickx04rdr2g60pppyb5r0rjhyslwr1gr05qdv0bsmwf61x")) (modules '((guix build utils))) (snippet '(begin ;; Remove the bundled PackCC and associated build rules. (substitute* "Makefile.am" (("^PACKCC = .*") "PACKCC = packcc\n") (("\\$\\(PACKCC_FILES\\)") "") (("\\$\\(PEG_SRCS\\) \\$\\(PEG_HEADS\\): \\$\\(PACKCC\\)") "$(PEG_SRCS) $(PEG_HEADS):")) (delete-file-recursively "misc/packcc"))))) (build-system gnu-build-system) (arguments '(;; Don't use the build-time TMPDIR (/tmp/guix-build-...) at runtime. #:configure-flags '("--enable-tmpdir=/tmp") #:test-target "units" #:phases (modify-phases %standard-phases (add-after 'unpack 'make-files-writable (lambda _ (for-each make-file-writable (find-files ".")))) (add-before 'bootstrap 'patch-misc (lambda _ ;; The autogen.sh script calls out to these scripts, so ;; we cannot wait for the patch-source-shebangs phase. (for-each patch-shebang (find-files "misc")))) (add-before 'check 'patch-tests (lambda _ (substitute* "misc/units" (("SHELL=/bin/sh") (string-append "SHELL=" (which "sh")))) (substitute* "Tmain/utils.sh" (("/bin/echo") (which "echo")))))))) (native-inputs (list autoconf automake packcc perl pkg-config python-docutils)) (inputs (list jansson libseccomp libxml2 libyaml pcre2)) (home-page "https://ctags.io/") (synopsis "Generate tag files for source code") (description "Universal Ctags generates an index (or tag) file of language objects found in source files for many popular programming languages. This index makes it easy for text editors and other tools to locate the indexed items. Universal Ctags improves on traditional ctags because of its multilanguage support, its ability for the user to define new languages searched by regular expressions, and its ability to generate emacs-style TAGS files.") (license license:gpl2+))) (define-public lcov (package (name "lcov") (version "1.16") (source (origin (method url-fetch) (uri (string-append "https://github.com/linux-test-project/lcov" "/releases/download/v" version "/lcov-" version ".tar.gz")) (sha256 (base32 "02r4wdl5d694aaxc5fgjw4nl3zmzq45khaxmsi3agj18annk2w4q")))) (build-system gnu-build-system) (arguments '(#:test-target "test" #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (add-after 'unpack 'patch-references-to-commands (lambda* (#:key inputs #:allow-other-keys) ;; Lift the requirement of having a shell and 'find' in PATH. (substitute* "bin/geninfo" (("qw/abs_path/") "qw/abs_path getcwd/")) (substitute* '("bin/lcov" "bin/geninfo") (("`pwd`") "getcwd()") (("`find ") (string-append "`" (search-input-file inputs "/bin/find") " "))))) (delete 'configure) ;no configure script (add-after 'install 'wrap (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (wrap-program (string-append out "/bin/geninfo") `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))))))) (inputs (list bash-minimal perl perl-io-compress perl-json)) (home-page "https://ltp.sourceforge.net/coverage/lcov.php") (synopsis "Code coverage tool that enhances GNU gcov") (description "LCOV is an extension of @command{gcov}, a tool part of the GNU@tie{}Binutils, which provides information about what parts of a program are actually executed (i.e., \"covered\") while running a particular test case. The extension consists of a set of Perl scripts which build on the textual @command{gcov} output to implement the following enhanced functionality such as HTML output.") (license license:gpl2+))) (define-public lcov-cobertura (package (name "python-lcov-cobertura") (version "1.6") (source (origin (method url-fetch) (uri (pypi-uri "lcov_cobertura" version)) (sha256 (base32 "02ar6yjazlxq4p64cz9gag08bvakmzjrp147jara9wlnlbc96j8g")))) (build-system python-build-system) (home-page "https://eriwen.github.io/lcov-to-cobertura-xml/") (synopsis "LCOV to Cobertura XML converter") (description "The lcov-to-cobertura Python module converts code coverage report files in the lcov format to the XML format of @uref{http://cobertura.github.io/cobertura/, Cobertura}, a Java code coverage tool. It allows continuous integration servers like Jenkins to aggregate results and determine build stability.") (license license:asl2.0))) (define-public kcov (package (name "kcov") (version "42") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/SimonKagstrom/kcov") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "14pyahpgadh845q2p1gjw2yrlqcan4n870icrn2yqdpf33cprzgk")))) (build-system cmake-build-system) (arguments `(#:tests? #f ; no test target #:phases (modify-phases %standard-phases (add-after 'unpack 'fix-/bin/bash-references (lambda* (#:key inputs #:allow-other-keys) (substitute* (find-files "src" ".*\\.cc?$") (("/bin/(bash|sh)" shell) (search-input-file inputs shell)))))))) (inputs (list curl elfutils libelf openssl zlib)) (native-inputs (list python)) (home-page "https://github.com/SimonKagstrom/kcov") (synopsis "Code coverage tester for compiled languages, Python and Bash") (description "Kcov is a code coverage tester for compiled languages, Python and Bash. It was originally a fork of Bcov, but has since evolved to support a large feature set in addition to that of Bcov. Kcov uses DWARF debugging information for compiled programs to make it possible to collect coverage information without special compiler switches.") (license license:gpl2+))) (define-public rtags (package (name "rtags") (version "2.18") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/Andersbakken/rtags") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (patches (search-patches "rtags-separate-rct.patch")) (modules '((guix build utils))) (snippet ;; Part of spliting rct with rtags. ;; Substitute #include "rct/header.h" with #include . '(with-directory-excursion "src" (delete-file-recursively "rct") ;remove bundled copy (let ((files (find-files "." ".*\\.cpp|.*\\.h"))) (substitute* files (("#include ?\"rct/(.*.h)\"" all header) (string-append "#include "))) #t))) (sha256 (base32 "0raqjbkl1ykga4ahgl9xw49cgh3cyqcf42z36z7d6fz1fw192kg0")))) (build-system cmake-build-system) (arguments '(#:build-type "RelWithDebInfo" #:configure-flags '("-DRTAGS_NO_ELISP_FILES=1" "-DBUILD_TESTING=FALSE") #:tests? #f)) (native-inputs (list pkg-config)) (inputs (list bash-completion clang llvm lua rct selene)) (home-page "https://github.com/Andersbakken/rtags") (synopsis "Indexer for the C language family with Emacs integration") (description "RTags is a client/server application that indexes C/C++ code and keeps a persistent file-based database of references, declarations, definitions, symbolnames etc. There’s also limited support for ObjC/ObjC++. It allows you to find symbols by name (including nested class and namespace scope). Most importantly we give you proper follow-symbol and find-references support.") (license license:gpl3+))) (define-public colormake (package (name "colormake") (version "0.9.20140503") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/pagekite/Colormake") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "1f9v5s0viq4yc9iv6701h3pv7j21zz1ckl37lpp9hsnliiizv03p")))) (build-system trivial-build-system) (native-inputs (list bash perl)) (arguments `(#:modules ((guix build utils)) #:builder (begin (use-modules (guix build utils)) (copy-recursively (assoc-ref %build-inputs "source") "source") (chdir "source") (patch-shebang "colormake.pl" (list (string-append (assoc-ref %build-inputs "perl") "/bin"))) (let* ((out (assoc-ref %outputs "out")) (bin (string-append out "/bin")) (doc (string-append out "/share/doc")) (install-files (lambda (files directory) (for-each (lambda (file) (install-file file directory)) files)))) (substitute* "colormake" (("colormake\\.pl") (string-append bin "/colormake.pl")) (("/bin/bash") (search-input-file %build-inputs "/bin/sh"))) (install-file "colormake.1" (string-append doc "/man/man1")) (install-files '("AUTHORS" "BUGS" "ChangeLog" "README") doc) (install-files '("colormake" "colormake-short" "clmake" "clmake-short" "colormake.pl") bin) #t)))) (home-page "https://bre.klaki.net/programs/colormake/") (synopsis "Wrapper around @command{make} to produce colored output") (description "This package provides a wrapper around @command{make} to produce colored output.") (license license:gpl2+))) (define-public makefile2graph (package (name "makefile2graph") (version "1.5.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/lindenb/makefile2graph") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1gjfk3d8qg3cla7qd2y7r9s03whlfwy83q8k76xfcnqrjjfavdgk")))) (build-system gnu-build-system) (arguments (list #:test-target "test" #:make-flags #~(list (string-append "CC=" #$(cc-for-target)) (string-append "prefix=" #$output)) #:phases #~(modify-phases %standard-phases (delete 'configure)))) (native-inputs (list graphviz)) (home-page "https://github.com/lindenb/makefile2graph") (synopsis "Creates a graph of dependencies from GNU Make") (description "@code{make2graph} creates a graph of dependencies from GNU Make. The output is a graphviz-dot file, a Gexf-XML file or a list of the deepest independent targets.") (license license:expat))) (define-public uncrustify (package (name "uncrustify") (version "0.77.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/uncrustify/uncrustify/") (commit (string-append name "-" version)))) (file-name (git-file-name name version)) (sha256 (base32 "17x9p5pqgzjchi9xhskp4kq7ag4chmsgbkvwym5m2b9zwm6qykpm")))) (build-system cmake-build-system) (native-inputs (list python-wrapper)) (arguments (list #:phases #~(modify-phases %standard-phases (add-after 'unpack 'unpack-etc (lambda* (#:key inputs outputs #:allow-other-keys) ;; Configuration samples are not installed by default. (let* ((output (assoc-ref outputs "out")) (etcdir (string-append output "/etc"))) (for-each (lambda (l) (install-file l etcdir)) (find-files "etc" "\\.cfg$")))))))) (home-page "https://uncrustify.sourceforge.net/") (synopsis "Code formatter for C and other related languages") (description "Beautify source code in many languages of the C family (C, C++, C#, Objective@tie{}C, D, Java, Pawn, and Vala). Features: @itemize @item Indent and align code. @item Reformat comments (a little bit). @item Fix inter-character spacing. @item Add or remove parens / braces. @item Supports embedded SQL @code{EXEC SQL} stuff. @item Highly configurable - More than 600 configurable options. @end itemize\n") (license license:gpl2+))) (define-public astyle (package (name "astyle") (version "3.5") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/astyle/astyle/astyle%20" version "/astyle-" version ".tar.bz2")) (sha256 (base32 "0g4jyp47iz97ld9ac4wb5k59j4cs8dbw4dp8f32bwqx8pyvirz6y")))) (build-system gnu-build-system) (arguments (list #:tests? #f ;no tests #:make-flags #~(list (string-append "prefix=" #$output) "INSTALL=install" "release" "shared") #:phases #~(modify-phases %standard-phases (add-after 'unpack 'patch-makefile (lambda _ (substitute* "build/gcc/Makefile" (("CBASEFLAGS = -Wall -Wextra -fno-rtti -fno-exceptions -std=c\\+\\+11") "CBASEFLAGS = -Wall -Wextra -fno-rtti -fno-exceptions -std=c++17")))) (replace 'configure (lambda _ (chdir "build/gcc"))) (add-after 'install 'install-more (lambda* (#:key outputs #:allow-other-keys) ;; Libraries and headers aren't installed by default. (let ((include (string-append #$output "/include")) (lib (string-append #$output "/lib"))) (mkdir-p include) (copy-file "../../src/astyle.h" (string-append include "/astyle.h")) (mkdir-p lib) (for-each (lambda (l) (copy-file l (string-append lib "/" (basename l)))) (find-files "bin" "^lib.*\\.so")))))))) (home-page "https://astyle.sourceforge.net/") (synopsis "Source code indenter, formatter, and beautifier") (description "Artistic Style is a source code indenter, formatter, and beautifier for the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.") (license license:lgpl3+))) (define-public indent (package (name "indent") (version "2.2.13") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/indent/indent-" version ".tar.gz")) (sha256 (base32 "15c0ayp9rib7hzvrcxm5ijs0mpagw5y8kf5w0jr9fryfqi7n6r4y")))) (build-system gnu-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-after 'unpack 'fix-docdir (lambda _ ;; Although indent uses a modern autoconf in which docdir ;; defaults to PREFIX/share/doc, the doc/Makefile.am ;; overrides this to be in PREFIX/doc. Fix this. (substitute* "doc/Makefile.in" (("^docdir = .*$") "docdir = @docdir@\n")) #t)) (add-after 'unpack 'fix-configure (lambda* (#:key inputs native-inputs #:allow-other-keys) ;; Replace outdated config.sub and config.guess: (with-directory-excursion "config" (for-each (lambda (file) (install-file (string-append (assoc-ref (or native-inputs inputs) "automake") "/share/automake-" ,(version-major+minor (package-version automake)) "/" file) ".")) '("config.sub" "config.guess"))) #t))))) (native-inputs (list texinfo automake)) ; For up to date 'config.guess' and 'config.sub'. (synopsis "Code reformatter") (description "Indent is a program that makes source code easier to read by reformatting it in a consistent style. It can change the style to one of several different styles such as GNU, BSD or K&R. It has some flexibility to deal with incomplete or malformed syntax. GNU indent offers several extensions over the standard utility.") (license license:gpl3+) (home-page "https://www.gnu.org/software/indent/"))) (define-public amalgamate (let* ((commit "c91f07eea1133aa184f652b8f1398eaf03586208") (revision "0") (version (git-version "1.1.1" revision commit))) (package (name "amalgamate") (version version) (home-page "https://github.com/edlund/amalgamate") (source (origin (method git-fetch) (uri (git-reference (url home-page) (commit commit))) (sha256 (base32 "0cllaraw8mxs8q2nr28nhgzkb417gj2wcklqg59w84f4lc78k3yb")) (file-name (git-file-name name version)) (modules '((guix build utils))) (snippet '(substitute* "test.sh" (("test_command \"cc -Wall -Wextra -o source.out source.c\"" all) "test_command \"gcc -Wall -Wextra -o source.out source.c\""))))) (build-system gnu-build-system) (inputs (list python-wrapper)) (arguments `(#:phases (modify-phases %standard-phases (delete 'configure) (delete 'build) (replace 'install (lambda* (#:key outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (bin (string-append out "/bin"))) (install-file "amalgamate.py" bin)))) (replace 'check (lambda _ (invoke "./test.sh")))))) (synopsis "Tool for amalgamating C source and header files") ;; The package is indeed a script file, and the term "amalgamate.py" is ;; used by upstream. (description "amalgamate.py aims to make it easy to use SQLite-style C source and header amalgamation in projects.") (license license:bsd-3)))) (define-public cdecl (package (name "cdecl") (version "2.5") (source (origin (method url-fetch) (uri (string-append "https://www.ibiblio.org/pub/linux/devel/lang/c/cdecl-" version ".tar.gz")) (sha256 (base32 "0dm98bp186r4cihli6fmcwzjaadgwl1z3b0zdxfik8h7hkqawk5p")))) (build-system gnu-build-system) (arguments `(#:make-flags ,#~(list "LIBS=-lreadline" (string-append "BINDIR=" #$output "/bin") (string-append "MANDIR=" #$output "/share/man/man1")) #:phases (modify-phases %standard-phases (delete 'configure) ; No configure script. (add-after 'unpack 'fix-build (lambda _ (substitute* "Makefile" (("lex cdlex.l") "flex cdlex.l")) (substitute* "cdecl.c" ;; Fix "error: conflicting types for ‘getline’". (("char \\* getline\\(\\)") "char * our_getline(void)") (("char \\* getline \\(\\)") "char * our_getline(void)") (("line = getline\\(\\)") "line = our_getline()") ;; Fix "error: conflicting types for ‘getopt’". (("int getopt\\(int,char \\*\\*,char \\*\\);") "") ;; Fix invalid use of "restrict" as a variable name. (("i, j, restrict") "i, j, restriction") (("restrict =") "restriction =") ;; Fix "warning: implicit declaration of function ‘add_history’". (("# include " all) (string-append all "\n# include ")) ;; Fix "warning: implicit declaration of function ‘dotmpfile_from_string’". (("void setprogname\\(char \\*\\);" all) (string-append all "\nint dotmpfile_from_string(char *);")) ;; Fix "warning: implicit declaration of function ‘completion_matches’". (("matches = completion_matches\\(text, command_completion\\);") "matches = rl_completion_matches(text, command_completion);") (("char \\* command_completion\\(char \\*, int\\);") "char * command_completion(const char *, int);") (("char \\* command_completion\\(char \\*text, int flag\\)") "char * command_completion(const char *text, int flag)") ;; Fix "warning: ‘CPPFunction’ is deprecated". (("rl_attempted_completion_function = \\(CPPFunction \\*\\)attempt_completion;") "rl_attempted_completion_function = (rl_completion_func_t *)attempt_completion;") ;; Fix "warning: ‘Function’ is deprecated". (("rl_completion_entry_function = \\(Function \\*\\)keyword_completion;") "rl_completion_entry_function = (rl_compentry_func_t *)keyword_completion;")) ;; Fix typo in man page. (substitute* "cdecl.1" (("\t::= auto \\| extern \\| register \\| auto") "\t::= auto | extern | register | static")))) (add-before 'install 'create-directories (lambda* (#:key outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (bin (string-append out "/bin")) (man (string-append out "/share/man/man1"))) (mkdir-p bin) (mkdir-p man))))) #:tests? #f)) ; No "check" target. (native-inputs (list bison flex)) (inputs (list readline)) (home-page "https://www.ibiblio.org/pub/linux/devel/lang/c/") (synopsis "Turn English phrases into C or C++ declarations and vice versa") (description "@code{cdecl} is a program that turns English-like phrases into C declarations. It can also translate C into pseudo-English. It also handles type casts and C++. It has command-line editing and history with the GNU Readline library.") (license license:public-domain))) (define-public cscope (package (name "cscope") (version "15.9") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/cscope/cscope/" "v" version "/cscope-" version ".tar.gz")) (sha256 (base32 "0ngiv4aj3rr35k3q3wjx0y19gh7i1ydqa0cqip6sjwd8fph5ll65")))) (build-system gnu-build-system) (inputs (list ncurses)) (arguments `(#:configure-flags ;; Specify the correct ncurses directory to prevent incorrect fallback ;; on SysV curses. (list (string-append "--with-ncurses=" (assoc-ref %build-inputs "ncurses"))))) (home-page "https://cscope.sourceforge.net") (synopsis "Tool for browsing source code") (description "Cscope is a text screen based source browsing tool. Although it is primarily designed to search C code (including lex and yacc files), it can also be used for C++ code. Using cscope, you can easily search for where symbols are used and defined.") (license license:bsd-3))) (define-public xenon (package (name "xenon") (version "0.9.0") (source (origin (method url-fetch) (uri (pypi-uri "xenon" version)) (sha256 (base32 "1f4gynjzfckm3rjfywwgz1c7icfx3zjqirf16aj73xv0c9ncpffj")))) (build-system python-build-system) (arguments (list #:tests? #f)) ;test suite not shipped with the PyPI archive (inputs (list python-pyyaml python-radon python-requests)) (home-page "https://xenon.readthedocs.org/") (synopsis "Monitor code metrics for Python on your CI server") (description "Xenon is a monitoring tool based on Radon. It monitors code complexity. Ideally, @code{xenon} is run every time code is committed. Through command line options, various thresholds can be set for the complexity of code. It will fail (i.e., it will exit with a non-zero exit code) when any of these requirements is not met.") (license license:expat))) (define-public python-xenon (deprecated-package "python-xenon" xenon))