aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libedit)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages ncurses))

(define-public libedit
  (package
    (name "libedit")
    (version "20191231-3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "https://thrysoee.dk/editline"
                          "/libedit-" version ".tar.gz"))
      (sha256
       (base32 "0wch48nml28jj6ild889745dsg2agm7mpvrmbl1gi98nw6vjrf6v"))))
    (build-system gnu-build-system)
    (inputs
     (list ncurses))
    (home-page "https://thrysoee.dk/editline/")
    (synopsis "NetBSD Editline library")
    (description
     "This is an autotool- and libtoolized port of the NetBSD Editline
library (libedit).  This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions, similar to
those found in GNU Readline.")
    (license bsd-3)))

(define-public editline
  (package
    (name "editline")
    (version "1.17.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append
            "https://ftp.troglobit.com/editline/editline-" version ".tar.xz"))
      (sha256
       (base32 "03pw3z6pz590v8xfnjx0yynnzij2sb9xwjbvqvdzsid56crkn8nz"))))
    (build-system gnu-build-system)
    (home-page "https://troglobit.com/projects/editline/")
    (synopsis "Line editing library")
    (description
     "@code{editline} is a small line editing library.  It can be linked into almost
any program to provide command line editing and history functions.  It is call
compatible with the GNU Readline library, but at a fraction of the size,
and as a result fewer features.")
    (license bsd-4)))
n title='2019-06-27 11:14:41 +0200'>2019-06-27derivations: <derivation-input> now aggregates a <derivation>....Ludovic Courtès 2019-06-27derivations: Rewrite and replace 'derivations-prerequisites-to-build'....Ludovic Courtès 2019-06-20Merge branch 'staging' into core-updatesMarius Bakke 2019-06-18tests: Avoid 'delete-paths' calls for 'derivation-prerequisites-to-build'....Ludovic Courtès 2019-06-14packages: Remove 'search-bootstrap-binary'....Ludovic Courtès 2019-06-10store: 'build-things' accepts derivation/output pairs....Ludovic Courtès 2019-02-04daemon: Rename 'NIX_STATE_DIR' and 'NIX_DB_DIR' environment variables....Ludovic Courtès 2019-01-21store: Rename '&nix-error' to '&store-error'....Ludovic Courtès 2018-11-28derivations: Add properties....Ludovic Courtès 2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès 2018-01-30derivations: Adjust tests for Stow environments....Ludovic Courtès 2017-10-12tests: Support multiple HTTP server instances....Ludovic Courtès 2017-06-02derivations: 'derivation-prerequisites-to-build' returns <substitutable>....Ludovic Courtès 2017-06-02derivations: 'substitution-oracle' returns a <substitutable>....Ludovic Courtès 2017-04-22derivations: Adjust builder encoding test....Ludovic Courtès 2017-04-21derivations: Restore UTF-8 encoding of build scripts....Ludovic Courtès 2017-03-28derivations: Do not fetch narinfos for non-substitutable items....Ludovic Courtès 2017-01-11daemon: Allow check builds of 'builtin:download' derivations....Ludovic Courtès 2016-11-16daemon: Add 'built-in-builders' RPC....Ludovic Courtès 2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès 2016-05-21derivations: 'derivation' sorts items in the resulting object....Ludovic Courtès 2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin 2016-03-23derivations: Raise an error when a module file is not found....Ludovic Courtès 2016-03-20derivations: Add #:disallowed-references....Ludovic Courtès 2016-03-06tests: Disable grafting by default for most tests....Ludovic Courtès 2016-02-22derivations: Move grafts to (guix grafts)....Ludovic Courtès 2016-01-19derivations: Add test in keep-going mode....Ludovic Courtès 2016-01-18derivations: Add test for #:leaked-env-vars....Ludovic Courtès 2015-12-09derivations: Determine what's built in 'check' mode....Ludovic Courtès 2015-10-06utils: Remove Nixpkgs helpers....Ludovic Courtès 2015-09-05tests: Fix typos....Ludovic Courtès