aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libedit)
  #:use-module (guix gexp)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages ncurses))

(define-public libedit
  (package
    (name "libedit")
    (version "20191231-3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "https://thrysoee.dk/editline"
                          "/libedit-" version ".tar.gz"))
      (sha256
       (base32 "0wch48nml28jj6ild889745dsg2agm7mpvrmbl1gi98nw6vjrf6v"))))
    (build-system gnu-build-system)
    (arguments
     (if (and (%current-target-system) (target-x86-32?))
         (list #:configure-flags
               #~(list "CFLAGS=-g -O2 -Wno-incompatible-pointer-types"))
         '()))
    (inputs
     (list ncurses))
    (home-page "https://thrysoee.dk/editline/")
    (synopsis "NetBSD Editline library")
    (description
     "This is an autotool- and libtoolized port of the NetBSD Editline
library (libedit).  This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions, similar to
those found in GNU Readline.")
    (license bsd-3)))

(define-public editline
  (package
    (name "editline")
    (version "1.17.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append
            "https://ftp.troglobit.com/editline/editline-" version ".tar.xz"))
      (sha256
       (base32 "03pw3z6pz590v8xfnjx0yynnzij2sb9xwjbvqvdzsid56crkn8nz"))))
    (build-system gnu-build-system)
    (home-page "https://troglobit.com/projects/editline/")
    (synopsis "Line editing library")
    (description
     "@code{editline} is a small line editing library.  It can be linked into almost
any program to provide command line editing and history functions.  It is call
compatible with the GNU Readline library, but at a fraction of the size,
and as a result fewer features.")
    (license bsd-4)))
libidn)[source]: Ditto. * gnu/packages/libunistring.scm (libunistring)[source]: Ditto. * gnu/packages/augeas.scm (augeas)[source]: Ditto. * gnu/packages/gsasl.scm (gsasl)[source]: Ditto. * gnu/packages/patches/findutils-gnulib-multi-core.patch, gnu/packages/patches/gettext-gnulib-multi-core.patch, gnu/packages/patches/gettext-multi-core.patch, gnu/packages/patches/libunistring-gnulib-multi-core.patch: Delete patches. * gnu/local.mk (DIST_PATCH_DATA): Remove them. Eric Bavier 2017-10-01Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2017-09-04gnu: libidn2: Replace with 2.0.4 [security fixes]....* gnu/packages/libidn.scm (libidn2)[replacement]: New field. (libidn2-2.0.4): New variable. Mark H Weaver 2017-08-30gnu: libidn2: Update to 2.0.4....* gnu/packages/libidn.scm (libidn2): Update to 2.0.4. [properties]: Add 'ftp-directory' to ease updates. Efraim Flashner 2017-05-22gnu: libidn2: Update to 2.0.2....* gnu/packages/libidn.scm (libidn2): Update to 2.0.2. [source]: The tarball is now ".lz" compressed. [native-inputs]: Add LZIP. Marius Bakke 2017-04-23gnu: libidn2: Update to 2.0.1....* gnu/packages/libidn.scm (libidn2): Update to 2.0.1. [source]: Download from main GNU server. [arguments]: Remove 'create-pkgconfig-file phase. Efraim Flashner 2017-03-30Merge branch 'master' into core-updates...Most conflicts are from 6fd52309b8f52c9bb59fccffac53e029ce94b698. Marius Bakke 2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....All HTTP gnu.org (and supported subdomain) HOME-PAGEs changed to HTTPS. Tobias Geerinckx-Rice 2017-03-14gnu: libidn2: Create 'pkg-config' file....* gnu/packages/libidn.scm (libidn2)[arguments]: Add phase creating libidn2.pc. Marius Bakke 2017-02-06gnu: libidn2: Update to 0.16....* gnu/packages/libidn.scm (libidn2): Update to 0.16. [inputs]: Add libunistring. Leo Famulari 2016-11-06Merge branch 'master' into core-updatesMark H Weaver 2016-11-05gnu: libidn: Distinguish from libidn2....* gnu/packages/libidn.scm (libidn)[description]: Add detail to help distinguish from libidn2. Leo Famulari 2016-11-05gnu: Add libidn2....* gnu/packages/libidn.scm (libidn2): New variable. Leo Famulari 2016-09-02gnu: libidn: Replace with 1.33 [fixes CVE-2015-8948 and CVE-2016-{6261,6263}]....* gnu/packages/libidn.scm (libidn)[replacement]: New field. (libidn-1.33): New variable. Leo Famulari 2016-08-14gnu: libidn: Update to 1.33....* gnu/packages/libidn.scm (libidn): Update to 1.33. Leo Famulari