aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 LuHui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libdaemon)
  #:use-module (gnu packages autotools)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libdaemon
  (package
    (name "libdaemon")
    (version "0.14")
    (source (origin
             (method url-fetch)
             (uri (list
                   (string-append
                    "mirror://debian/pool/main/libd/libdaemon/libdaemon_"
                    version ".orig.tar.gz")
                   "http://pkgs.fedoraproject.org/repo/pkgs/libdaemon/libdaemon-0.14.tar.gz/509dc27107c21bcd9fbf2f95f5669563/libdaemon-0.14.tar.gz"

                   ;; This used to be the canonical URL but it vanished.
                   ;; See <http://bugs.gnu.org/18639>.
                   ;; (string-append
                   ;;  "http://0pointer.de/lennart/projects/libdaemon/libdaemon-"
                   ;;  version ".tar.gz")
                   ))
             (sha256
              (base32
               "0d5qlq5ab95wh1xc87rqrh1vx6i8lddka1w3f1zcqvcqdxgyn8zx"))
             (file-name (string-append name "-" version ".tar.gz"))))
    (build-system gnu-build-system)
    (native-inputs
     (if (or (and=> (%current-target-system) target-aarch64?)
             (and=> (%current-target-system) target-riscv64?))
         `(("config" ,config)) ; for config.sub
         '()))
    (arguments
     `(,@(if (%current-target-system)
             ;; The 'setpgrp' test cannot provide an answer when cross-compiling,
             ;; so provide the right one for glibc.
             `(#:configure-flags (list "ac_cv_func_setpgrp_void=yes"

                                       ;; TODO: Move this globally on the next
                                       ;; rebuild cycle.
                                       ;; Set a valid localstatedir for the
                                       ;; benefit of the default
                                       ;; 'daemon_pid_file_proc', used by the
                                       ;; Hurd's console client.
                                       "--localstatedir=/var"))
             '())
       ,@(if (or (and=> (%current-target-system) target-aarch64?)
                 (and=> (%current-target-system) target-riscv64?))
             `(#:phases
               (modify-phases %standard-phases
                 (add-before 'configure 'update-config.sub
                   (lambda _
                     ;; Replace outdated config.sub such that aarch64
                     ;; will be recognised as an architecture.
                     (delete-file "config.sub")
                     (symlink (which "config.sub") "config.sub")))))
             '())))
    ;; XXX: Stale URL, missing replacement.  See <http://bugs.gnu.org/18639>.
    (home-page "https://0pointer.de/lennart/projects/libdaemon/")

    (synopsis "Lightweight C library that eases the writing of UNIX daemons")
    (description
     "Libdaemon is a lightweight C library that eases the writing of UNIX
daemons.  It consists of the following parts:

  • A wrapper around fork() which does the correct daemonization procedure of
    a process

  • A wrapper around syslog() for simpler and compatible log output to Syslog
    or STDERR

  • An API for writing PID files

  • An API for serializing UNIX signals into a pipe for usage with select() or
    poll()

  • An API for running subprocesses with STDOUT and STDERR redirected to
    syslog.

APIs like these are used in most daemon software available.  It is not that
simple to get it done right and code duplication is not a goal.")
    (license lgpl2.1+)))
r> 2023-08-25image: Add mbr-raw-image-type and use by default....Josselin Poiret 2023-08-17doc: cookbook: Document how to disable the Yubikey OTP application....Maxim Cournoyer 2023-08-16doc: cookbook: Document a dynamic DNS update mcron job....Maxim Cournoyer 2023-08-16doc: Update Cookbook Texinfo menus....Maxim Cournoyer 2023-08-15doc: cookbook: Mention common SRFI-1 procedures....Ludovic Courtès 2023-08-15doc: cookbook: Add 'use-modules' in gexp example....Ludovic Courtès 2023-08-15doc: cookbook: Link to "Package Modules"....Ludovic Courtès 2023-07-14doc: Mention gexps in the "Scheme Crash Course"....Ludovic Courtès 2023-06-05doc: cookbook: Update example my-libgit2 package....Efraim Flashner 2023-06-04services: screen-locker-service-type: Configurable PAM and setuid....muradm 2023-05-31nls: Update translations....Florian Pelz 2023-05-06doc: cookbook: Remove outdated section about GUIX_PACKAGE_PATH....Ludovic Courtès 2023-01-09doc: cookbook: Add "Installing Guix on a Cluster" chapter....Ludovic Courtès 2023-01-06doc: cookbook: Remove 404 link to mitpress.mit.edu....Ludovic Courtès 2022-11-27doc: cookbook: Fix commands in example....Florian Pelz 2022-11-24doc: Add a security keys section to the cookbook....Maxim Cournoyer 2022-11-06doc: cookbook: Add section on MPD with bluealsa....Ricardo Wurmus 2022-11-06doc: cookbook: Update detailed menu for "System Configuration"....Ricardo Wurmus 2022-10-13doc: Add chapter on containers to Cookbook....Ricardo Wurmus 2022-07-08doc: cookbook: Link to "A Scheme Primer"....Ludovic Courtès 2022-07-08doc: cookbook: Suggest 'guix shell'....Ludovic Courtès