aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2017, 2018 Nikita <nikita@n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libcanberra)
  #:use-module ((guix licenses)
                #:select (lgpl2.1+ gpl2 gpl2+ cc-by-sa4.0 cc-by3.0))
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system python)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages gstreamer)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages pulseaudio)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xiph))

(define-public libcanberra
  (package
    (name "libcanberra")
    (version "0.30")
    (source
     (origin
      (method url-fetch)

      ;; This used to be at 0pointer.de but it vanished.
      (uri (string-append
            "http://pkgs.fedoraproject.org/repo/pkgs/libcanberra/libcanberra-"
            version ".tar.xz/34cb7e4430afaf6f447c4ebdb9b42072/libcanberra-"
            version ".tar.xz"))
      (sha256
       (base32
        "0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2"))
      ;; "sound-theme-freedesktop" is the default and fall-back sound theme for
      ;; XDG desktops and should always be present.
      ;; http://www.freedesktop.org/wiki/Specifications/sound-theme-spec/
      ;; We make sure libcanberra will find it.
      ;;
      ;; We add the default sounds store directory to the code dealing with
      ;; XDG_DATA_DIRS and not XDG_DATA_HOME. This is because XDG_DATA_HOME
      ;; can only be a single directory and is inspected first.  XDG_DATA_DIRS
      ;; can list an arbitrary number of directories and is only inspected
      ;; later.  This is designed to allows the user to modify any theme at
      ;; his pleasure.
      (patch-flags '("-p0"))
      (patches
       (search-patches "libcanberra-sound-theme-freedesktop.patch"
                       "libcanberra-wayland-crash.patch"))))
    (build-system gnu-build-system)
    (inputs
     `(("alsa-lib" ,alsa-lib)
       ("gstreamer" ,gstreamer)
       ("gtk+" ,gtk+)
       ("libltdl" ,libltdl)
       ("libvorbis" ,libvorbis)
       ("pulseaudio" ,pulseaudio)
       ("udev" ,eudev)
       ("sound-theme-freedesktop" ,sound-theme-freedesktop)))
    (native-inputs
     (list pkg-config))
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-before 'build 'patch-default-sounds-directory
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "src/sound-theme-spec.c"
               (("@SOUND_THEME_DIRECTORY@")
                (string-append
                 (assoc-ref inputs "sound-theme-freedesktop")
                 "/share")))
             #t)))))
    (home-page "https://0pointer.de/lennart/projects/libcanberra/")
    (synopsis
     "Implementation of the XDG Sound Theme and Name Specifications")
    (description
     "Libcanberra is an implementation of the XDG Sound Theme and Name
Specifications, for generating event sounds on free desktops, such as
GNOME.  It comes with several backends (ALSA, PulseAudio, OSS, GStreamer,
null) and is designed to be portable.")
    (license lgpl2.1+)))

(define-public sound-theme-freedesktop
  (package
    (name "sound-theme-freedesktop")
    (version "0.8")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://people.freedesktop.org/~mccann/dist/"
                                  name "-" version ".tar.bz2"))
              (sha256
               (base32
                "054abv4gmfk9maw93fis0bf605rc56dah7ys5plc4pphxqh8nlfb"))))
    (build-system gnu-build-system)
    (native-inputs (list intltool))
    (synopsis "Audio samples for use as a desktop sound theme")
    (description
     "This package provides audio samples that can be used by libcanberra as
sounds for various system events.")

    ;; The license of the various sounds is given in the 'CREDITS' file.
    (license (list cc-by-sa4.0 cc-by3.0 gpl2 gpl2+))

    (home-page "https://www.freedesktop.org/wiki/Specifications/sound-theme-spec/")))

(define-public python-pycanberra
  (package
    (name "python-pycanberra")
    (version "0.1.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://ftp.n0.is/pub/releases/"
                           "pycanberra-" version ".tar.xz"))
       (sha256
        (base32
         "16jjf8fcgaprmz6jacsxrh17l1ad891fns38bxv49lg3s3mn1nj2"))))
    (build-system python-build-system)
    (arguments
     `(#:tests? #f)) ;No tests included.
    (propagated-inputs
     (list libcanberra))
    (synopsis "Ctypes wrapper for the libcanberra API")
    (description
     "Pycanberra is a basic Python wrapper for libcanberra.")
    (home-page "http://c.n0.is/ng0/pycanberra/")
    (license lgpl2.1+)))
nu/local.mk (dist_patch_DATA): De-register it. Maxim Cournoyer 2022-09-10gnu: mumble: Update to 1.4.274....* gnu/packages/telephony.scm (mumble): Update to 1.4.274. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Michael Rohleder 2022-08-14gnu: rnnoise: Unhide and rename variable....* gnu/packages/xiph.scm (xiph-rnnoise): Rename to… (rnnoise): …this. Adjust all users. [properties]: Remove HIDDEN? property as it is no longer ambiguous. Tobias Geerinckx-Rice 2022-07-31gnu: qttools: Rename to qttools-5....Automated with: git grep -l qttools | xargs sed 's/\bqttools\b/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtquickcontrols: Rename to qtquickcontrols-5....Automated via: git grep -l qtquickcontrols | xargs sed 's/\bqtquickcontrols\b/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtdeclarative: Rename to qtdeclarative-5....Automated via the following commands: git grep -l '\bqtdeclarative\b' | xargs sed -E 's/qtdeclarative/\0-5/g' -i git checkout NEWS Maxim Cournoyer 2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....This is in preparation of the qtsvg update to version 6. This change was automated via the following command: git grep -l '\bqtsvg\b' | xargs sed 's/qtsvg/qtsvg-5/g' -i Maxim Cournoyer 2022-03-20gnu: mumble: Use correct path for libmumbleoverlay....* gnu/packages/telephony.scm (mumble)[fix-mumble-overlay]: Use ‘libmumbleoverlay.so’ instead of the old ‘libmumble.so.1’. Drop trailing #t. Liliana Marie Prikler 2022-03-08gnu: mumble: Enable tests....* gnu/packages/telephony.scm (mumble)[#:tests?]: Drop argument. [#:configure-flags]: Add “-Dtests=on”. Liliana Marie Prikler 2022-03-08gnu: mumble: Update to 1.4.230....* gnu/packages/telephony.scm (find-python-interpreter-cmake-modules): New variable. (mumble): Update to 1.4.230. [source]: Adjust uri and snippet accordingly. [arguments]: Change to a list of G-expressions. <#:configure-flags>: New argument. <#:phases>: Drop ‘configure’ (moved to configure-flags). Add ‘unpack-submodules’, ‘fix-settings-crash’ and ‘hardcode-pulseaudio’. [inputs]: Add glib and poco. Liliana Marie Prikler 2022-01-13gnu: pjproject: Update to 2.11.1....* gnu/packages/telephony.scm (pjproject): Update to 2.11.1. [tests?]: Remove argument to please guix lint. Maxim Cournoyer 2022-01-13gnu: pjproject: Apply patch to install the libpjsua2 shared library....* gnu/packages/patches/pjproject-install-libpjsua2.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/telephony.scm (pjproject): Apply it. Maxim Cournoyer 2022-01-13gnu: pjproject: Remove the make-source-files-writable phase....This phase is no longer needed since commit 39e67ed697951db0c75b0ba76269ca54108d9506. * gnu/packages/telephony.scm (pjproject)[phases] {make-source-files-writable}: Delete phase. Maxim Cournoyer 2022-01-07gnu: phonesim: Add source file-name....* gnu/packages/telephony.scm (phonesim)[source]: Add file-name field. Efraim Flashner 2021-12-29gnu: Remove leftover libsndfile/fixed package....This package was equivalent to the libsndfile package, differing only in the order of its inputs. * gnu/packages/pulseaudio.scm (libsndfile/fixed): Remove variable. * gnu/packages/music.scm (liquidsfz)[inputs]: Replace libsndfile/fixed with libsndfile. * gnu/packages/telephony.scm (mumble)[inputs]: Likewise. Leo Famulari 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-12-05gnu: Add phonesim....* gnu/packages/telephony.scm (phonesim): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Demis Balbach