aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libbsd)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages crypto))

(define-public libbsd
  (package
    (name "libbsd")
    (version "0.11.7")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://libbsd.freedesktop.org/releases/"
                                  "libbsd-" version ".tar.xz"))
              (sha256
               (base32
                "0q82iaynmal3dn132jgjq21p27x3zn8zks88cg02bgzbb5h1ialv"))))
    (build-system gnu-build-system)
    (arguments
     (list #:configure-flags #~'("--disable-static")
           #:phases #~(modify-phases %standard-phases
                        (add-after 'install 'embed-absolute-libmd-references
                          (lambda* (#:key inputs #:allow-other-keys)
                            (let ((libmd (search-input-file inputs
                                                            "lib/libmd.so")))
                              ;; Add absolute references to libmd so it
                              ;; does not need to be propagated.
                              (with-directory-excursion #$output
                                (substitute* "lib/libbsd.so"
                                  (("^GROUP")
                                   (string-append "SEARCH_DIR("
                                                  (dirname libmd)
                                                  ")\nGROUP")))
                                (substitute* (find-files "lib/pkgconfig"
                                                         "\\.pc$")
                                  (("-lmd")
                                   (string-append "-L" (dirname libmd)
                                                  " -lmd")))))))
                        (add-before 'check 'disable-pwcache-test
                          (lambda _
                            ;; This test expects the presence of a root
                            ;; user and group, which do not exist in the
                            ;; build container.
                            (substitute* "test/Makefile"
                              (("pwcache\\$\\(EXEEXT\\) ")
                               ""))))
                        #$@(if (system-hurd?)
                               #~((add-after 'unpack 'skip-tests
                                  (lambda _
                                    (substitute* "test/explicit_bzero.c"
                                      (("(^| )main *\\(.*" all)
                                       (string-append all
                                                      "{\n  exit (77);//"))))))
                               #~()))))
    (inputs
     (list libmd))
    (synopsis "Utility functions from BSD systems")
    (description "This library provides useful functions commonly found on BSD
systems, and lacking on others like GNU systems, thus making it easier to port
projects with strong BSD origins, without needing to embed the same code over
and over again on each project.")
    (home-page "https://libbsd.freedesktop.org/wiki/")
    ;; This package is a collection of third-party functions that were
    ;; originally released under various non-copyleft licenses.
    (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain
                   (non-copyleft "file://COPYING"
                                 "See COPYING in the distribution.")))))
9b557ff010778f7762382f. This commit broke u-boot-tools. Maxim Cournoyer 2020-10-18gnu: u-boot: Update to 2020.10....* gnu/packages/bootloaders (u-boot): Update to 2020.10. * gnu/packages/patches/u-boot-riscv64-fix-extlinux.patch: Refresh patch. Vagrant Cascadian 2020-09-19gnu: u-boot: Reomve sdl2 dependency on non-GUI builds....* gnu/packages/bootloaders.scm (u-boot)[native-inputs]: Remove sdl2. (u-boot-tools)[native-inputs]: Add sdl2. Danny Milosavljevic 2020-07-09gnu: u-boot: Update to 2020.07....* gnu/packages/bootloaders (u-boot): Update to 2020.07. (u-boot-pinebook-pro-rk3399): Remove patches. * gnu/packages/patches: u-boot-DT-for-Pinebook-Pro.patch, u-boot-add-boe-nv140fhmn49-display.patch, u-boot-gpio-keys-binding-cons.patch, u-boot-leds-common-binding-con.patch, u-boot-support-Pinebook-Pro-laptop.patch, u-boot-video-rockchip-fix-build.patch: Remove patches. u-boot-riscv64-fix-extlinux.patch: Refresh patch. * gnu/local.mk (dist_patch_DATA): Update accordingly. Vagrant Cascadian 2020-06-25gnu: grub: Cross-build fix for system i686-linux....* gnu/packages/patches/grub-cross-system-i686.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Use it. Jan (janneke) Nieuwenhuizen 2020-06-02gnu: os-prober: Fix cross-compilation....* gnu/packages/bootloaders.scm (os-prober)[arguments]: Use CC-FOR-TARGET. Tobias Geerinckx-Rice 2020-05-26gnu: grub: Allow "grub-bios-setup" to operate on raw disk-images....* gnu/packages/patches/grub-setup-root.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Apply it. Mathieu Othacehe 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-24gnu: u-boot: Update to 2020.04....* gnu/packages/bootloaders (u-boot): Update to 2020.04. [native-inputs]: Replace sdl with sdl2. Co-authored-by: Vagrant Cascadian <vagrant@debian.org> Pierre Langlois 2020-04-23Merge branch 'master' into core-updates... Conflicts: etc/news.scm gnu/local.mk gnu/packages/bootloaders.scm gnu/packages/linphone.scm gnu/packages/linux.scm gnu/packages/tls.scm gnu/system.scm Marius Bakke 2020-04-23Revert "gnu: u-boot: Update to 2020.04."...This reverts commit be0ecfb1787b9e6954bf745bceeb1b9d2669d51a. Mathieu Othacehe 2020-04-20gnu: Add u-boot-pinebook-pro-rk3399....* gnu/packages/bootloaders (u-boot-pinebook-pro-rk3399): New variable. * gnu/packages/patches/u-boot-DT-for-Pinebook-Pro.patch: New file. * gnu/packages/patches/u-boot-add-boe-nv140fhmn49-display.patch: New file. * gnu/packages/patches/u-boot-gpio-keys-binding-cons.patch: New file. * gnu/packages/patches/u-boot-leds-common-binding-con.patch: New file. * gnu/packages/patches/u-boot-support-Pinebook-Pro-laptop.patch: New file. * gnu/packages/patches/u-boot-video-rockchip-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Add new patches. * gnu/bootloader/u-boot.scm (install-pinebook-pro-rk3399-u-boot, u-boot-pinebook-pro-rk3399-bootloader): New variable. Co-authored-by: Jan Nieuwenhuizen <janneke@gnu.org> Vagrant Cascadian 2020-04-15Merge branch 'master' into core-updatesMarius Bakke 2020-04-15gnu: u-boot: Update to 2020.04....* gnu/packages/bootloaders (u-boot): Update to 2020.04. Vagrant Cascadian 2020-03-29gnu: Add grub-minimal....* gnu/packages/bootloaders.scm (grub-minimal): New variable. Jan Nieuwenhuizen 2020-03-24gnu: grub: Support for the Hurd....* gnu/packages/virtualization.scm (qemu)[supported-systems]: Remove the Hurd. * gnu/packages/linux.scm (mdadm)[supported-systems]: Likewise. (lvm2)[supported-systems]: Likewise. (fuse)[supported-systems]: Likewise. * gnu/packages/patches/grub-verifiers-Blocklist-fallout-cleanup.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Use it. [inputs, native-inputs]: Remove non-supported dependencies on non-supported systems. Fixes build for the Hurd. Jan Nieuwenhuizen 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-21gnu: GRUB: Use the latest version of QEMU for tests....* gnu/packages/bootloaders.scm (grub)[native-inputs]: Change from QEMU-MINIMAL-2.10 to QEMU-MINIMAL. Marius Bakke 2020-03-21gnu: GRUB: Build with the latest version of Flex....* gnu/packages/bootloaders.scm (grub)[native-inputs]: Change from FLEX-2.6.1 to FLEX. Marius Bakke 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-02-26gnu: u-boot-pinebook: Fix LCD video output....* gnu/packages/bootloaders (u-boot-pinebook): Add phase applying patch submitted upstream. Vagrant Cascadian 2020-02-03Merge branch 'staging' into core-updatesMarius Bakke 2020-02-01gnu: u-boot-qemu-riscv64-smode: Patch to fix boot menu....* gnu/packages/patches/u-boot-riscv64-fix-extlinux.patch: New patch. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/bootloaders (u-boot-qemu-riscv64-smode): Add patch. Vagrant Cascadian 2020-01-31gnu: Add u-boot-qemu-riscv64....* gnu/packages/bootloaders (u-boot-qemu-riscv64): New variable. Vagrant Cascadian 2020-01-31gnu: Add u-boot-sifive-fu540....* gnu/packages/bootloaders (u-boot-sifive-fu540): New variable. Vagrant Cascadian 2020-01-31gnu: u-boot-qemu-riscv64-smode: Add package....* gnu/packages/bootloaders (u-boot-qemu-riscv64-smode): New variable. Vagrant Cascadian