aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libbsd)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages crypto))

(define-public libbsd
  (package
    (name "libbsd")
    (version "0.11.7")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://libbsd.freedesktop.org/releases/"
                                  "libbsd-" version ".tar.xz"))
              (sha256
               (base32
                "0q82iaynmal3dn132jgjq21p27x3zn8zks88cg02bgzbb5h1ialv"))))
    (build-system gnu-build-system)
    (arguments
     (list #:configure-flags #~'("--disable-static")
           #:phases #~(modify-phases %standard-phases
                        (add-after 'install 'embed-absolute-libmd-references
                          (lambda* (#:key inputs #:allow-other-keys)
                            (let ((libmd (search-input-file inputs
                                                            "lib/libmd.so")))
                              ;; Add absolute references to libmd so it
                              ;; does not need to be propagated.
                              (with-directory-excursion #$output
                                (substitute* "lib/libbsd.so"
                                  (("^GROUP")
                                   (string-append "SEARCH_DIR("
                                                  (dirname libmd)
                                                  ")\nGROUP")))
                                (substitute* (find-files "lib/pkgconfig"
                                                         "\\.pc$")
                                  (("-lmd")
                                   (string-append "-L" (dirname libmd)
                                                  " -lmd")))))))
                        (add-before 'check 'disable-pwcache-test
                          (lambda _
                            ;; This test expects the presence of a root
                            ;; user and group, which do not exist in the
                            ;; build container.
                            (substitute* "test/Makefile"
                              (("pwcache\\$\\(EXEEXT\\) ")
                               ""))))
                        #$@(if (system-hurd?)
                               #~((add-after 'unpack 'skip-tests
                                  (lambda _
                                    (substitute* "test/explicit_bzero.c"
                                      (("(^| )main *\\(.*" all)
                                       (string-append all
                                                      "{\n  exit (77);//"))))))
                               #~()))))
    (inputs
     (list libmd))
    (synopsis "Utility functions from BSD systems")
    (description "This library provides useful functions commonly found on BSD
systems, and lacking on others like GNU systems, thus making it easier to port
projects with strong BSD origins, without needing to embed the same code over
and over again on each project.")
    (home-page "https://libbsd.freedesktop.org/wiki/")
    ;; This package is a collection of third-party functions that were
    ;; originally released under various non-copyleft licenses.
    (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain
                   (non-copyleft "file://COPYING"
                                 "See COPYING in the distribution.")))))
er 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-09gnu: gtk: Do not manually move /bin....The Meson build system now takes care of that itself, just like the GNU build system. * gnu/packages/gtk.scm (gtk) [arguments]: Remove /bin from the list of moved directory in the move-files phase. Maxim Cournoyer 2023-04-07gnu: gtk+: Update to 3.24.30....This fixes <https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/issues/184>, which was visible for applications using legacy GTK+ icons such as Grsync. * gnu/packages/gtk.scm (gtk+): Update to 3.24.30. [outputs]: New field, removing inherited "doc" output. [build-system]: Use meson-build-system. [native-inputs]: Replace docbook-xml-4.1.2 with docbook-xml-4.3. Add docbook-xsl. Remove perl. [arguments]: Adjust #:imported-modules and #:modules according to build system change. Migrate #:configure-flags to Meson options. Add #:test-options argument. Update disable-failing-tests phase. Maxim Cournoyer 2023-04-07gnu: Add libpanel....* gnu/packages/gtk.scm (libpanel): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Antero Mejr 2023-03-31gnu: atk: Deprecate in favor of at-spi2-core....* gnu/packages/gtk.scm (atk): Deprecate. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret 2023-03-31gnu: atkmm: Update to 2.36.2....* gnu/packages/gtk.scm (atkmm): Update to 2.36.2. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret 2023-03-31gnu: Replace all uses of atk by at-spi2-core....* gnu/packages/animation.scm (gnash) * gnu/packages/chromium.scm (ungoogled-chromium) * gnu/packages/crates-gtk.scm (rust-atk-sys-0.14, rust-atk-sys-0.10, rust-atk-0.14, rust-gtk-0.14) * gnu/packages/gimp.scm (gimp) * gnu/packages/gnome.scm (evince, glade3, clutter, totem, rhythmbox, mutter, ghex): * gnu/packages/graphviz.scm (xdot) * gnu/packages/gtk.scm (gtk+-2, gtk+, guile-gnome, atkmm) * gnu/packages/mate.scm (mate-applets, atril, mate-control-center, mate-calc, mate-utils, eom, pluma) * gnu/packages/messaging.scm (dino) * gnu/packages/qt.scm (qtwebengine-5) * gnu/packages/rust-apps.scm (alfis) * gnu/packages/vim.scm (vim-full) * gnu/packages/vnc.scm (remmina) * gnu/packages/web.scm (castor): Replace atk by at-spi2-core. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret