aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lesstif)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix git-download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages c)
  #:use-module (gnu packages flex)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))


(define-public lesstif
  (package
    (name "lesstif")
    (version "0.95.2")
    (source
      (origin
        (method url-fetch)
        (uri (string-append
               "mirror://sourceforge/lesstif/lesstif/" version
               "/lesstif-" version ".tar.bz2"))
        (sha256
          (base32
            "1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb"))))
    (build-system gnu-build-system)
    (propagated-inputs
     (list printproto))
    (inputs
      (list libxext libxt))
    (home-page "https://lesstif.sourceforge.net/")
    (synopsis "Clone of the Motif toolkit for the X window system")
    (description "Clone of the Motif toolkit for the X window system.")
    (license license:gpl2+))) ; some files are lgpl2.1+ or x11

(define-public motif
  ;; This commit is from September 2021 and v2.3.8 from 2017.
  (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
        (revision "0"))
    (package
      (name "motif")
      (version (git-version "2.3.8" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://git.code.sf.net/p/motif/code")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32
           "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
      (build-system gnu-build-system)
      (inputs
       (list libx11 xorgproto))
      (propagated-inputs
       (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
      (native-inputs
       (list autoconf automake byacc flex libtool pkg-config))
      (home-page "https://motif.ics.com/motif")
      (synopsis "Toolkit for the X window system")
      (description "Motif is a standard graphical user interface, (as defined
by the IEEE 1295 specification), used on more than 200 hardware and software
platforms.  It provides application developers, end users, and system vendors
with a widely used environment for standardizing application presentation on a
wide range of platforms.")
      (license license:lgpl2.1+))))
ss='msg-tooltip'>* gnu/packages/shells.scm (tcsh): Add libxcrypt dependency. Change-Id: I13f37b73d8a8a618dfa628e7341b4e3bbfc018b2 Josselin Poiret 2024-07-28gnu: xonsh: Update to 0.18.2....* gnu/packages/shells.scm (xonsh): Update to 0.18.2. [source](snippet): Adjust substitution filenames and delete the vendored ply package. [arguments]<#:test-flags>: Skip new failing test. Change-Id: I9a975c9ab200075cbbfe6daf1892c33cb5c3a624 Vinicius Monego 2024-07-19gnu: nushell: Update to 0.91.0....* gnu/packages/shells.scm (nushell): Update to 0.91.0. [source]: Download from the crates-io release. [arguments]: Don't skip the tests. Add cargo-test-flags. Don't install the sources. [cargo-inputs]: Add rust-crossterm-0.27, rust-log-0.4, rust-miette-7, rust-mimalloc-0.1, rust-nix-0.27, rust-nu-cli-0.91, rust-nu-cmd-base-0.91, rust-nu-cmd-dataframe-0.91, rust-nu-cmd-extra-0.91, rust-nu-cmd-lang-0.91, rust-nu-explore-0.91, rust-nu-lsp-0.91, rust-nu-std-0.91, rust-nu-utils-0.91, rust-openssl-0.10, rust-reedline-0.30, rust-serde-json-1, rust-simplelog-0.12, rust-time-0.3, rust-winresource-0.1. Replace rust-nu-cli-0.44 with 0.91, rust-nu-command-0.44 with 0.91, rust-nu-engine-0.44 with 0.91, rust-nu-parser-0.44 with 0.91, rust-nu-path-0.44 with 0.91, rust-nu-plugin-0.44 with 0.91, rust-nu-protocol-0.44 with 0.91. Remove rust-futures-0.3, rust-mp4-0.9, rust-nu-source-0.44, rust-nu-value-ext-0.44, rust-nu-plugin-binaryview-0.44, rust-nu-plugin-chart-0.44, rust-nu-plugin-from-bson-0.44, rust-nu-plugin-from-sqlite-0.44, rust-nu-plugin-inc-0.44, rust-nu-plugin-match-0.44, rust-nu-plugin-query-json-0.44, rust-nu-plugin-s3-0.44, rust-nu-plugin-selector-0.44, rust-nu-plugin-start-0.44, rust-nu-plugin-textview-0.44, rust-nu-plugin-to-bson-0.44, rust-nu-plugin-to-sqlite-0.44, rust-nu-plugin-tree-0.44, rust-nu-plugin-xpath-0.44. [cargo-development-inputs]: Add rust-assert-cmd-2, rust-divan-0.1, rust-pretty-assertions-1, rust-tempfile-3. Replace rust-nu-test-support-0.44 with 0.91, rust-rstest-0.10 with 0.18, rust-serial-test-0.5 with 3. [native-inputs]: Remove python. [inputs]: Add mimalloc. Remove curl, libgit2, libx11, libxcb, zlib. (rust-nu-cli-0.44, rust-nu-command-0.44, rust-nu-completion-0.44, rust-nu-data-0.44, rust-nu-engine-0.44, rust-nu-errors-0.44, rust-nu-json-0.44, rust-nu-parser-0.44, rust-nu-path-0.44, rust-nu-plugin-0.44, rust-nu-plugin-binaryview-0.44, rust-nu-plugin-chart-0.44, rust-nu-plugin-from-bson-0.44, rust-nu-plugin-from-sqlite-0.44, rust-nu-plugin-inc-0.44, rust-nu-plugin-match-0.44, rust-nu-plugin-query-json-0.44, rust-nu-plugin-s3-0.44, rust-nu-plugin-selector-0.44, rust-nu-plugin-start-0.44, rust-nu-plugin-textview-0.44, rust-nu-plugin-to-bson-0.44, rust-nu-plugin-to-sqlite-0.44, rust-nu-plugin-tree-0.44, rust-nu-plugin-xpath-0.44, rust-nu-pretty-hex-0.44, rust-nu-protocol-0.44, rust-nu-serde-0.44, rust-nu-source-0.44, rust-nu-stream-0.44, rust-nu-table-0.44, rust-nu-test-support-0.44, rust-nu-value-ext-0.44): Remove variables. (rust-nu-cli-0.91, rust-nu-cmd-base-0.91, rust-nu-cmd-dataframe-0.91, rust-nu-cmd-extra-0.91, rust-nu-cmd-lang-0.91, rust-nu-color-config-0.91, rust-nu-command-0.91, rust-nu-engine-0.91, rust-nu-explore-0.91, rust-nu-glob-0.91, rust-nu-json-0.91, rust-nu-lsp-0.91, rust-nu-parser-0.91, rust-nu-path-0.91, rust-nu-plugin-0.91, rust-nu-pretty-hex-0.91, rust-nu-protocol-0.91, rust-nu-std-0.91, rust-nu-system-0.91, rust-nu-table-0.91, rust-nu-term-grid-0.91, rust-nu-test-support-0.91, rust-nu-utils-0.91): New variables. Change-Id: I431220407f2ea95e28c04036170c2b8a2655290a Efraim Flashner 2024-07-19gnu: Add rust-nu-ansi-term-0.50....* gnu/packages/shells.scm (rust-nu-ansi-term-0.50): New variable. (rust-nu-ansi-term-0.49): Inherit from rust-nu-ansi-term-0.50. Change-Id: I8ba9e3bae5e434bf1351e94e6d05cec4e7ce8f1c Efraim Flashner 2024-07-06gnu: xonsh: Improve package style....* gnu/packages/shells.scm (xonsh)[source](snippet): Remove trailing #t. [arguments]<#:phases>: Use #$output rather than the outputs alist. Change-Id: I30c1b1d8e64ba6bbce61e47cbfec91de3d3df7ae Vinicius Monego 2024-07-06gnu: xonsh: Enable tests....* gnu/packages/shells.scm (xonsh)[arguments]: Remove #:tests?. Skip failing tests in #:test-flags?. Add phase 'writable-home before 'check. [native-inputs]: Add git-minimal, python-pyte, python-pytest, python-pytest-mock, python-pytest-rerunfailures, python-pytest-subprocess, python-pytest-timeout, python-requests. Change-Id: Iba35db554b1536246efbd101d9d588f7007fb885 Vinicius Monego 2024-07-06gnu: xonsh: Move to pyproject-build-system....* gnu/packages/shells.scm (xonsh)[build-system]: Move to pyproject-build-system. Change-Id: I033a05b2eb94f15510ff7c3753768aec013dd11a Vinicius Monego 2024-07-06gnu: xonsh: Update to 0.17.0....* gnu/packages/shells.scm (xonsh): Update to 0.17.0. [source](snippet): Update substitution. Change-Id: I62d31200f8636e6db9de5d697e711e5b70fcfa9d Vinicius Monego