aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lesstif)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix git-download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages c)
  #:use-module (gnu packages flex)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))


(define-public lesstif
  (package
    (name "lesstif")
    (version "0.95.2")
    (source
      (origin
        (method url-fetch)
        (uri (string-append
               "mirror://sourceforge/lesstif/lesstif/" version
               "/lesstif-" version ".tar.bz2"))
        (sha256
          (base32
            "1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb"))))
    (build-system gnu-build-system)
    (propagated-inputs
     (list printproto))
    (inputs
      (list libxext libxt))
    (home-page "https://lesstif.sourceforge.net/")
    (synopsis "Clone of the Motif toolkit for the X window system")
    (description "Clone of the Motif toolkit for the X window system.")
    (license license:gpl2+))) ; some files are lgpl2.1+ or x11

(define-public motif
  ;; This commit is from September 2021 and v2.3.8 from 2017.
  (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
        (revision "0"))
    (package
      (name "motif")
      (version (git-version "2.3.8" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://git.code.sf.net/p/motif/code")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32
           "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
      (build-system gnu-build-system)
      (inputs
       (list libx11 xorgproto))
      (propagated-inputs
       (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
      (native-inputs
       (list autoconf automake byacc flex libtool pkg-config))
      (home-page "https://motif.ics.com/motif")
      (synopsis "Toolkit for the X window system")
      (description "Motif is a standard graphical user interface, (as defined
by the IEEE 1295 specification), used on more than 200 hardware and software
platforms.  It provides application developers, end users, and system vendors
with a widely used environment for standardizing application presentation on a
wide range of platforms.")
      (license license:lgpl2.1+))))
3-06-01 12:18:31 +0300'>2023-06-01gnu: fish: Update to 3.6.1....* gnu/packages/shells.scm (fish): Update to 3.6.1. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Greg Hogan 2023-05-24gnu: xonsh: Update to 0.14.0....* gnu/packages/shells.scm (xonsh): Update to 0.14.0. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Edison Ibáñez 2023-05-22gnu: oil: Update to 0.15.0....* gnu/packages/shells.scm (oil): Update to 0.15.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Felix Gruber 2023-04-26gnu: xonsh: Add missing input....Xonsh vim emulation mode/environment variable does not work without this. * gnu/packages/shell.scm (xonsh)[inputs]: Add PYTHON-PROMPT-TOOLKIT. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> jgart 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-06gnu: tcsh: Fix riscv64 cross-compilation....* gnu/packages/shells.scm (tcsh): fix riscv64 cross-build. [arguments]<#:phase>: Add 'update-config-scripts' phase for riscv64. [native-inputs]: Add CONFIG for riscv64. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Z572 2023-03-31gnu: zsh: Patch failing test that uses egrep....* gnu/packages/patches/zsh-egrep-failing-test.patch: New file. * gnu/packages/shells.scm (zsh): Patch it. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Josselin Poiret 2023-03-27gnu: oil: Update to 0.14.2....* gnu/packages/shells.scm (oil): Update to 0.14.2. Signed-off-by: Christopher Baines <mail@cbaines.net> Felix Gruber 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-26gnu: fish: Update to 3.6.0....* gnu/packages/shells.scm (fish): Update to 3.6.0. [source]: Remove snippet, as the bundled PCRE2 sources have been removed (see CHANGELOG.rst). Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Winter 2023-02-16gnu: scsh: Use a search path....* gnu/packages/shells.scm (scsh)[source]: Add patch. [native-search-paths]: New field. * gnu/packages/patches/scsh-nonstring-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2022-12-11gnu: oil: Update to 0.12.9....* gnu/packages/shells.scm (oil): Update to 0.12.9. Tobias Geerinckx-Rice 2022-12-11gnu: dash: Capitalise description sentences....* gnu/packages/shells.scm (dash)[description]: Capitalise ‘dash’. Tobias Geerinckx-Rice 2022-12-11gnu: dash: Update to 0.5.12....* gnu/packages/shells.scm (dash): Update to 0.5.12. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2022-12-09gnu: xonsh: Update to 0.13.4....* gnu/packages/shells.scm (xonsh): Update to 0.13.4. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Edison Ibáñez 2022-10-26gnu: oil: Update to 0.12.7....* gnu/packages/shells.scm (oil): Update to 0.12.7. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Felix Gruber 2022-09-27Merge branch 'staging' into core-updates...Conflicts resolved in: gnu/local.mk gnu/packages/cran.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/icu4c.scm gnu/packages/java.scm gnu/packages/machine-learning.scm gnu/packages/tex.scm Maxim Cournoyer