aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lesstif)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix git-download)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages c)
  #:use-module (gnu packages flex)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xorg))


(define-public lesstif
  (package
    (name "lesstif")
    (version "0.95.2")
    (source
      (origin
        (method url-fetch)
        (uri (string-append
               "mirror://sourceforge/lesstif/lesstif/" version
               "/lesstif-" version ".tar.bz2"))
        (sha256
          (base32
            "1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb"))))
    (build-system gnu-build-system)
    (propagated-inputs
     (list printproto))
    (inputs
      (list libxext libxt))
    (home-page "https://lesstif.sourceforge.net/")
    (synopsis "Clone of the Motif toolkit for the X window system")
    (description "Clone of the Motif toolkit for the X window system.")
    (license license:gpl2+))) ; some files are lgpl2.1+ or x11

(define-public motif
  ;; This commit is from September 2021 and v2.3.8 from 2017.
  (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
        (revision "0"))
    (package
      (name "motif")
      (version (git-version "2.3.8" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://git.code.sf.net/p/motif/code")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32
           "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
      (build-system gnu-build-system)
      (inputs
       (list libx11 xorgproto))
      (propagated-inputs
       (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
      (native-inputs
       (list autoconf automake byacc flex libtool pkg-config))
      (home-page "https://motif.ics.com/motif")
      (synopsis "Toolkit for the X window system")
      (description "Motif is a standard graphical user interface, (as defined
by the IEEE 1295 specification), used on more than 200 hardware and software
platforms.  It provides application developers, end users, and system vendors
with a widely used environment for standardizing application presentation on a
wide range of platforms.")
      (license license:lgpl2.1+))))
497cdcce0c7'>gnu: Add python-nbstripout....* gnu/packages/jupyter.scm (python-nbstripout): New variable. Ricardo Wurmus 2022-05-16gnu: python-bash-kernel: Do not propagate 'python-ipykernel'....Failing that, Guix-Jupyter sees both kernels in environments containing python-bash-kernel and its ";;guix environment" command thus fails. * gnu/packages/jupyter.scm (python-bash-kernel)[propagated-inputs]: Move everything to... [inputs]: ... here. Ludovic Courtès 2022-05-12gnu: xeus: Update to 2.4.1....* gnu/packages/jupyter.scm (xeus): Update to 2.4.1. [source]: Update Git URI. Maxim Cournoyer 2022-05-12gnu: python-jupyter-kernel-mgmt: Update to 0.5.1 and disable tests....* gnu/packages/jupyter.scm (python-jupyter-kernel-mgmt): Update to 0.5.1. [arguments]: New field. [propagated-inputs]: Add python-tornado. [native-inputs]: Remove python-mock. Add python-async-generator and python-pytest-asyncio. Maxim Cournoyer 2022-05-12gnu: python-jupyter-protocol: Update to 0.2.0....* gnu/packages/jupyter.scm (python-jupyter-protocol): Update to 0.2.0. [propagated-inputs]: Add python-ipython-genutils. Maxim Cournoyer 2022-05-12gnu: python-sparqlkernel: Use gexps and fix inputs....[arguments]: Use gexps. [tests?]: Add comment. [phases]: Delete trailing #t. {no-custom-css}: Use a regular lambda. {install-kernelspec}: Move after the add-installed-pythonpath phase. Remove now extraneous add-installed-pythonpath call. Adjust for gexps. [native-inputs]: Delete field. [propagated-inputs]: Add python-ipykernel, python-notebook, python-rdflib and pythopython-traitlets. [description]: Avoid '&' in description. Maxim Cournoyer 2022-05-12gnu: python-voila: Update to 0.3.5....* gnu/packages/jupyter.scm (python-voila): Update to 0.3.5. [source]: Use git. [arguments]: New field. [propagated-inputs]: Add python-jupyterlab-server, python-traitlets and python-websockets. [native-inputs]: Remove python-jupyter-packaging and python-setuptools. Add python-numpy and python-pandas. Maxim Cournoyer 2022-05-12gnu: python-jupyter-server: Update to 1.16.0....* gnu/packages/jupyter.scm (python-jupyter-server): Update to 1.16.0. [propagated-inputs]: Remove python-ipython-genutils and python-requests-unixsocket. Maxim Cournoyer 2022-05-12gnu: Add python-jupyterlab-server....* gnu/packages/jupyter.scm (python-jupyterlab-server): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-nbdime....* gnu/packages/jupyter.scm (python-nbdime): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-jupyter-server-mathjax....* gnu/packages/jupyter.scm (python-jupyter-server-mathjax): New variable. Maxim Cournoyer 2022-05-12gnu: python-nbclient: Update to 0.6.0....* gnu/packages/jupyter.scm (python-nbclient): Update to 0.6.0. [tests?]: Update comment. [propagated-inputs]: Remove python-async-generator. [native-inputs]: Delete field. [description]: Fix spacing. Maxim Cournoyer 2022-05-12gnu: python-jupyter-packaging: Update to 0.12.0, run test suite....* gnu/packages/jupyter.scm (python-jupyter-packaging): Update to 0.12.0. [arguments]: New field. Maxim Cournoyer 2022-05-06gnu: Add python-ipydatawidgets....* gnu/packages/jupyter.scm (python-ipydatawidgets): New variable. Ricardo Wurmus 2022-05-06gnu: Add python-ipympl....* gnu/packages/jupyter.scm (python-ipympl): New variable. Ricardo Wurmus 2022-01-12gnu: repo2docker: Update to 2021.08.0....* gnu/packages/jupyter.scm (repo2docker): Update to 2021.08.0. [arguments]: Disable Sphinx warnings, set PYTHONPATH, and refer to THIS-PACKAGE instead of the "name" variable directly. [native-inputs]: Add PYTHON-ENTRYPOINTS. Marius Bakke 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-20gnu: repo2docker: Use GUIX_PYTHONPATH....* gnu/packages/jupyter.scm (repo2docker)[arguments]: Use GUIX_PYTHONPATH instead of PYTHONPATH. Ricardo Wurmus 2021-08-31gnu: python-jupyter-server: Use older pytest....* gnu/packages/jupyter.scm (python-jupyter-server)[native-inputs]: Replace python-pytest-6 with python-pytest. Ricardo Wurmus 2021-08-30gnu: Add python-voila....* gnu/packages/jupyter.scm (python-voila): New variable. Ricardo Wurmus 2021-08-30gnu: Add python-jupyter-server....* gnu/packages/jupyter.scm (python-jupyter-server): New variable. Ricardo Wurmus 2021-07-21gnu: Add python-sparqlkernel....* gnu/packages/jupyter.scm (python-sparqlkernel): New variable. Lars-Dominik Braun 2021-07-21gnu: Add python-bash-kernel....* gnu/packages/jupyter.scm (python-bash-kernel): New variable. Lars-Dominik Braun 2021-07-09gnu: Add repo2docker....* gnu/packages/jupyter.scm (repo2docker): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Hugo Lecomte 2021-04-13gnu: Add python-jupyterlab-widgets....* gnu/packages/jupyter.scm (python-jupyterlab-widgets): New variable. Ricardo Wurmus 2021-04-13gnu: Add python-jupyter-packaging....* gnu/packages/jupyter.scm (python-jupyter-packaging): New variable. Ricardo Wurmus 2021-04-13gnu: Add python-nbclient....* gnu/packages/jupyter.scm (python-nbclient): New variable. Ricardo Wurmus 2021-04-13gnu: Add python-jupyterlab-pygments....* gnu/packages/jupyter.scm (python-jupyterlab-pygments): New variable. Ricardo Wurmus