aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages less)
  #:use-module (guix gexp)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages perl-compression)
  #:use-module (gnu packages file)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu))

(define-public less
  (package
    (name "less")
    (version "608")
    (source
     (origin
       (method url-fetch)
       (uri (list (string-append "mirror://gnu/less/less-"
                                 version ".tar.gz")
                  (string-append "http://www.greenwoodsoftware.com/less/less-"
                                 version ".tar.gz")))
       (patches (search-patches "less-hurd-path-max.patch"))
       (sha256
        (base32 "02f2d9d6hyf03va28ip620gjc6rf4aikmdyk47h7frqj18pbx6m6"))))
    (build-system gnu-build-system)
    (inputs (list ncurses))
    (home-page "https://www.gnu.org/software/less/")
    (synopsis "Paginator for terminals")
    (description
     "GNU less is a pager, a program that allows you to view large amounts
of text in page-sized chunks.  Unlike traditional pagers, it allows both
backwards and forwards movement through the document.  It also does not have
to read the entire input file before starting, so it starts faster than most
text editors.")
    (license gpl3+))) ; some files are under GPLv2+

(define-public lesspipe
  (package
    (name "lesspipe")
    (version "2.13")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/wofr06/lesspipe")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1hhxikpvmjwg90a3rpnxssq3ws6l2hv76d04h4fgvxhbsrr7imiv"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:tests? #f                      ; no tests
      #:phases
      #~(modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              ;; configure is a perl script which the standard configure phase
              ;; fails to execute
              (invoke "./configure"
                      (string-append "--prefix=" (assoc-ref outputs "out")))))
          (add-before 'install 'fix-makefile
            (lambda _
              (substitute* "Makefile"
                (("\\$\\(DESTDIR\\)/etc") "$(DESTDIR)$(PREFIX)/etc"))))
          (add-before 'install 'patch-command-paths
            ;; Depending on the content of the file to be displayed and some
            ;; settings, lesspipe tries to use a large variety of external
            ;; commands, e.g. rpm, dpkg, vimcolor.  We only link the
            ;; essential ones to avoid this package to pull in all these
            ;; dependencies which might never ever be used.
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((file (search-input-file inputs "/bin/file"))
                    (tput (search-input-file inputs "/bin/tput")))
                (substitute* "sxw2txt"
                  (("^use warnings;" line)
                   (string-append
                    line "\nuse lib '" #$(this-package-input "perl-archive-zip")
                    "/lib/perl5/site_perl';")))
                (substitute* "lesscomplete"
                  (("file -") (string-append file " -")))
                (substitute* "lesspipe.sh"
                  (("tput colors")
                   (string-append tput " colors"))
                  (("file -")
                   (string-append file " -")))))))))
    (inputs
     (list file
           ncurses                      ; for tput
           perl-archive-zip))
    (native-inputs (list perl))
    (home-page "https://github.com/wofr06/lesspipe")
    (synopsis "Input filter for less")
    (description "To browse files, the excellent viewer @code{less} can be
used.  By setting the environment variable @code{LESSOPEN}, less can be
enhanced by external filters to become more powerful.  The input filter for
less described here is called @code{lesspipe.sh}.  It is able to process a
wide variety of file formats.  It enables users to inspect archives and
display their contents without having to unpack them before.  The filter is
easily extensible for new formats.")
    (license gpl2+)))
packages/patches: u-boot-DT-for-Pinebook-Pro.patch, u-boot-add-boe-nv140fhmn49-display.patch, u-boot-gpio-keys-binding-cons.patch, u-boot-leds-common-binding-con.patch, u-boot-support-Pinebook-Pro-laptop.patch, u-boot-video-rockchip-fix-build.patch: Remove patches. u-boot-riscv64-fix-extlinux.patch: Refresh patch. * gnu/local.mk (dist_patch_DATA): Update accordingly. Vagrant Cascadian 2020-06-25gnu: grub: Cross-build fix for system i686-linux....* gnu/packages/patches/grub-cross-system-i686.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Use it. Jan (janneke) Nieuwenhuizen 2020-06-02gnu: os-prober: Fix cross-compilation....* gnu/packages/bootloaders.scm (os-prober)[arguments]: Use CC-FOR-TARGET. Tobias Geerinckx-Rice 2020-05-26gnu: grub: Allow "grub-bios-setup" to operate on raw disk-images....* gnu/packages/patches/grub-setup-root.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Apply it. Mathieu Othacehe 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-24gnu: u-boot: Update to 2020.04....* gnu/packages/bootloaders (u-boot): Update to 2020.04. [native-inputs]: Replace sdl with sdl2. Co-authored-by: Vagrant Cascadian <vagrant@debian.org> Pierre Langlois 2020-04-23Merge branch 'master' into core-updates... Conflicts: etc/news.scm gnu/local.mk gnu/packages/bootloaders.scm gnu/packages/linphone.scm gnu/packages/linux.scm gnu/packages/tls.scm gnu/system.scm Marius Bakke 2020-04-23Revert "gnu: u-boot: Update to 2020.04."...This reverts commit be0ecfb1787b9e6954bf745bceeb1b9d2669d51a. Mathieu Othacehe 2020-04-20gnu: Add u-boot-pinebook-pro-rk3399....* gnu/packages/bootloaders (u-boot-pinebook-pro-rk3399): New variable. * gnu/packages/patches/u-boot-DT-for-Pinebook-Pro.patch: New file. * gnu/packages/patches/u-boot-add-boe-nv140fhmn49-display.patch: New file. * gnu/packages/patches/u-boot-gpio-keys-binding-cons.patch: New file. * gnu/packages/patches/u-boot-leds-common-binding-con.patch: New file. * gnu/packages/patches/u-boot-support-Pinebook-Pro-laptop.patch: New file. * gnu/packages/patches/u-boot-video-rockchip-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Add new patches. * gnu/bootloader/u-boot.scm (install-pinebook-pro-rk3399-u-boot, u-boot-pinebook-pro-rk3399-bootloader): New variable. Co-authored-by: Jan Nieuwenhuizen <janneke@gnu.org> Vagrant Cascadian 2020-04-15Merge branch 'master' into core-updatesMarius Bakke 2020-04-15gnu: u-boot: Update to 2020.04....* gnu/packages/bootloaders (u-boot): Update to 2020.04. Vagrant Cascadian 2020-03-29gnu: Add grub-minimal....* gnu/packages/bootloaders.scm (grub-minimal): New variable. Jan Nieuwenhuizen 2020-03-24gnu: grub: Support for the Hurd....* gnu/packages/virtualization.scm (qemu)[supported-systems]: Remove the Hurd. * gnu/packages/linux.scm (mdadm)[supported-systems]: Likewise. (lvm2)[supported-systems]: Likewise. (fuse)[supported-systems]: Likewise. * gnu/packages/patches/grub-verifiers-Blocklist-fallout-cleanup.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Use it. [inputs, native-inputs]: Remove non-supported dependencies on non-supported systems. Fixes build for the Hurd. Jan Nieuwenhuizen 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-21gnu: GRUB: Use the latest version of QEMU for tests....* gnu/packages/bootloaders.scm (grub)[native-inputs]: Change from QEMU-MINIMAL-2.10 to QEMU-MINIMAL. Marius Bakke 2020-03-21gnu: GRUB: Build with the latest version of Flex....* gnu/packages/bootloaders.scm (grub)[native-inputs]: Change from FLEX-2.6.1 to FLEX. Marius Bakke