aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages lean)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages multiprecision)
  #:use-module (guix build-system cmake)
  #:use-module (guix build-system python)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix download)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages version-control)
  #:use-module (gnu packages python-build)
  #:use-module (gnu packages python-crypto)
  #:use-module (gnu packages python-web)
  #:use-module (gnu packages python-xyz))

(define-public lean
  (package
    (name "lean")
    (version "3.51.1")
    (home-page "https://lean-lang.org" )
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/leanprover-community/lean")
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "17g4d3lqnbl1yfy2pjannf73v8qhc5003d2jkmrqiy05zkqs8d9n"))))
    (build-system cmake-build-system)
    (inputs
     (list gmp))
    (arguments
     (list
      #:build-type "Release"            ; default upstream build type
      ;; XXX: Test phases currently fail on 32-bit sytems.
      ;; Tests for those architectures have been temporarily
      ;; disabled, pending further investigation.
      #:tests? (and (not (%current-target-system))
                    (let ((arch (%current-system)))
                      (not (or (string-prefix? "i686" arch)
                               (string-prefix? "armhf" arch)))))
      #:phases
      #~(modify-phases %standard-phases
          (add-before 'configure 'chdir-to-src
            (lambda _ (chdir "src"))))))
    (synopsis "Theorem prover and programming language")
    (description
     "Lean is a theorem prover and programming language with a small trusted
core based on dependent typed theory, aiming to bridge the gap between
interactive and automated theorem proving.")
    (license license:asl2.0)))

(define-public python-mathlibtools
  (package
    (name "python-mathlibtools")
    (version "1.1.1")
    (source (origin
              (method url-fetch)
              (uri (pypi-uri "mathlibtools" version))
              (sha256
               (base32
                "089pql105imx8z7ar1wiz9fn000jp6xqdfixw4jf2vric94vn9fj"))))
    (build-system python-build-system)
    (arguments
     '(#:phases (modify-phases %standard-phases
                  (add-before 'check 'fix-home-directory
                    (lambda _
                      (setenv "HOME" "/tmp"))))))
    (inputs (list python-toml
                  python-pygithub
                  python-certifi
                  python-gitpython
                  python-requests
                  python-click
                  python-tqdm
                  python-networkx
                  python-pydot
                  python-pyyaml
                  python-atomicwrites))
    (home-page "https://github.com/leanprover-community/mathlib-tools")
    (synopsis "Development tools for Lean mathlib")
    (description
     "This package contains @command{leanproject}, a supporting tool for Lean
mathlib, a mathematical library for the Lean theorem prover.")
    (license license:asl2.0)))
-5.1): New variable. Julien Lepiller 2020-07-17gnu: Add plexus-parent-pom-4.0....* gnu/packages/maven-parent-pom.scm (plexus-parent-pom-4.0): New variable. Julien Lepiller 2020-07-17gnu: Add plexus-parent-pom-3.1....* gnu/packages/maven-parent-pom.scm (plexus-parent-pom-3.1): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-oss-parent-pom-9....* gnu/packages/maven-parent-pom.scm (java-sonatype-oss-parent-pom-9): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-oss-parent-pom-7....* gnu/packages/maven-parent-pom.scm (java-sonatype-oss-parent-pom-7): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-spice-parent-pom-12....* gnu/packages/maven-parent-pom.scm (java-sonatype-spice-parent-pom-12): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-spice-parent-pom-17....* gnu/packages/maven-parent-pom.scm (java-sonatype-spice-parent-pom-17): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-spice-parent-pom-15....* gnu/packages/maven-parent-pom.scm (java-sonatype-spice-parent-pom-15): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-forge-parent-pom-10....* gnu/packages/maven-parent-pom.scm (java-sonatype-forge-parent-pom-10): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-forge-parent-pom-6....* gnu/packages/maven-parent-pom.scm (java-sonatype-forge-parent-pom-6): New variable. Julien Lepiller 2020-07-17gnu: Add java-sonatype-forge-parent-pom-5....* gnu/packages/maven-parent-pom.scm (java-sonatype-forge-parent-pom-5): New variable. Julien Lepiller 2020-07-17gnu: add java-sonatype-forge-parent-pom-4....* gnu/packages/maven-parent-pom.scm (java-sonatype-forge-parent-pom-4): New variable. Julien Lepiller 2020-07-17gnu: Add java-weld-parent-pom....* gnu/packages/maven-parent-pom.scm (java-weld-parent-pom): New variable. Julien Lepiller 2020-07-17gnu: Add apache-commons-parent-pom-50....* gnu/packages/maven-parent-pom.scm (apache-commons-parent-pom-50): New variable. Julien Lepiller 2020-07-17gnu: Add apache-commons-parent-pom-48....* gnu/packages/maven-parent-pom.scm (apache-commons-parent-pom-48): New variable. Julien Lepiller 2020-07-17gnu: Add apache-commons-parent-pom-41....* gnu/packages/maven-parent-pom.scm (apache-commons-parent-pom-41): New variable. Julien Lepiller 2020-07-17gnu: Add apache-commons-parent-pom-39....* gnu/packages/maven-parent-pom.scm (apache-commons-parent-pom-39): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-21....* gnu/packages/maven-parent-pom.scm (apache-parent-pom-21): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-19....* gnu/packages/maven-parent-pom.scm (apache-parent-pom-19): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-18....* gnu/packages/maven-parent-pom.scm (apache-parent-pom-18): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-17....* gnu/packages/maven.scm (apache-parent-pom-17): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-16....* gnu/packages/maven-parent-pom.scm (apache-parent-pom-16): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-11....* gnu/packages/maven-parent-pom.scm (apache-parent-pom-11): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-6....* gnu/packages/maven.scm (apache-parent-pom-6): New variable. Julien Lepiller 2020-07-17gnu: Add apache-parent-pom-13....* gnu/packages/maven-parent-pom.scm: New file. * gnu/local.mk: Add maven-parent-pom.scm. Julien Lepiller 020-02-03Merge branch 'staging' into core-updatesMarius Bakke 2020-01-26gnu: python-xmlschema: Update to 1.1.0....* gnu/packages/xml.scm (python-xmlschema): Update to 1.1.0. [source]: Change to GIT-FETCH. [arguments]: Adjust test invokation. Marius Bakke 2020-01-26gnu: python-elementpath: Update to 1.4.0....* gnu/packages/xml.scm (python-elementpath): Update to 1.4.0. Marius Bakke 2020-01-21Merge branch 'staging' into core-updatesMarius Bakke 2020-01-15gnu: Add python-xmlschema....* gnu/packages/xml.scm (python-xmlschema): New public variable. Marius Bakke 2020-01-15gnu: python-lxml: Move to (gnu packages xml)....* gnu/packages/python-xyz.scm (python-lxml): Move from here ... * gnu/packages/xml.scm (python-lxml): ... to here. * gnu/packages/django.scm, gnu/packages/drones.scm, gnu/packages/libreoffice.scm, gnu/packages/nutrition.scm, gnu/packages/openstack.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-science.scm, gnu/packages/tryton.scm, gnu/packages/wireservice.scm: Adjust module imports. Marius Bakke 2020-01-15gnu: python-elementpath: Update to 1.3.3....* gnu/packages/xml.scm (python-elementpath): Update to 1.3.3. Marius Bakke 2020-01-15gnu: python-elementpath: Move to (gnu packages xml)....* gnu/packages/python-xyz.scm (python-elementpath): Move from here ... * gnu/packages/xml.scm (python-elementpath): ... to here. Marius Bakke 2020-01-11Merge branch 'master' into core-updatesMarius Bakke